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List of Revisions
Index Date Version Chapter Revision

3 13.07.01 2.690 INTERBUS.DLL
2.638 SYCON.EXE

all revised, updated, extended
new chapter structure

4 04.09.01 2.700 INTERBUS.DLL
2.638 SYCON.EXE

all InterBus device counting starts with 0

5 24.01.02 2.701 INTERBUS.DLL
2.6383 SYCON.EXE

all
7.3.2
7.7
10.3

revised
Chapter: CSV Export added
Chapter: View Menu SyCon added
Chapter: Length- and ID Codes added

6

Although this program has been developed with great care and intensively
tested, Hilscher Gesellschaft für Systemautomation mbH cannot guarantee
the suitability of this program for any purpose not confirmed by us in writing.
Guarantee claims shall be limited to the right to require rectification. Liability
for any damages which may have arisen from the use of this program or its
documentation shall be limited to cases of intent.
We reserve the right to modify our products and their specifications at any
time in as far as this contribute to technical progress. The version of the
manual supplied with the program applies.



SyConIB System Configurator InterBus Table of Contents  �  3

Copyright � Hilscher Gesellschaft für Systemautomation mbH � Oi:SyConIB#6EN

Table of Contents

1 OVERVIEW SYCON ...................................................................................................7
1.1 Main Functions......................................................................................................... 7
1.2 Properties................................................................................................................. 8

2 INSTALLATION AND LICENSING ..............................................................................9
2.1 System Requirements.............................................................................................. 9
2.2 Software Installation............................................................................................... 10
2.3 Installation of the System Configurator SyCon ....................................................... 12
2.4 Licensing................................................................................................................ 14

2.4.1 Ordering a License for the SyCon Configurator .................................................14
2.4.2 Enter the License Code......................................................................................15

2.5 Scope of Functions of the Basic Version and unlicensed Fieldbus Modules........... 17

3 GETTING STARTED – CONFIGURATION STEPS ..................................................19
3.1 Overview Communication Types............................................................................ 19
3.2 Configuration Hilscher InterBus Master to any InterBus Slave................................ 20
3.3 Configuration Hilscher InterBus Slave to any InterBus Master................................ 21
3.4 Configuration Hilscher InterBus Master to Hilscher InterBus Slave......................... 22
3.5 Configuration Hilscher InterBus PCP Master to any InterBus PCP Slave ............... 24
3.6 Configuration Hilscher InterBus PCP Slave to any InterBus PCP Master ............... 25
3.7 Configuration Hilscher InterBus PCP Master to Hilscher InterBus PCP Slave ........ 26

4 CONFIGURATION OF INTERBUS WITH SYCON ...................................................27
4.1 Setting up the InterBus Configuration..................................................................... 27
4.2 EDS Files ............................................................................................................... 27
4.3 Master.................................................................................................................... 28

4.3.1 Insert Master.......................................................................................................28
4.3.2 Master Configuration ..........................................................................................29
4.3.3 Replace Master ..................................................................................................30

4.4 InterBus Slave........................................................................................................ 31
4.4.1 Insert InterBus Slave ..........................................................................................31
4.4.2 Slave Configuration ............................................................................................34
4.4.3 Replace Slave ....................................................................................................37
4.4.4 Parameter Data Channel - PCP .........................................................................38

5 SETTINGS ................................................................................................................45
5.1 Device Assignment ................................................................................................ 45

5.1.1 Driver Selection ..................................................................................................45
5.1.2 CIF Device Driver ...............................................................................................47
5.1.3 CIF Serial Driver .................................................................................................49



4  �  Overview SyCon SyConIB System Configurator InterBus

Copyright � Hilscher Gesellschaft für Systemautomation mbH � Oi:SyConIB#6EN

5.1.4 CIF TCP/IP Driver...............................................................................................51

5.2 Bus Parameters ..................................................................................................... 55
5.3 InterBus Master...................................................................................................... 58

5.3.1 Master Settings...................................................................................................58
5.3.2 Addressing Mode................................................................................................60
5.3.3 Global Settings ...................................................................................................61

5.4 InterBus Slave........................................................................................................ 62
5.4.1 Slave Settings.....................................................................................................62
5.4.2 Slave Configuration ............................................................................................64

5.5 Project Information ................................................................................................. 65
5.6 Path ....................................................................................................................... 65
5.7 Language............................................................................................................... 66
5.8 Start Options .......................................................................................................... 66

6 ONLINE FUNCTIONS ...............................................................................................69
6.1 Introduction ............................................................................................................ 69
6.2 Online to the CIF.................................................................................................... 69

6.2.1 Downloading the Configuration ..........................................................................69
6.2.2 Firmware Download............................................................................................70
6.2.3 Firmware / Reset ................................................................................................71
6.2.4 Device Info..........................................................................................................71
6.2.5 Read Project Information....................................................................................71
6.2.6 Activate Driver - Driver Licensing .......................................................................72

6.3 Automatic Network Scan ........................................................................................ 73
6.3.1 Automatic Configuration .....................................................................................74
6.3.2 Assign EDS File..................................................................................................75

6.4 Start/Stop Communication ..................................................................................... 76
6.5 Diagnostic Functions.............................................................................................. 77

6.5.1 Debug Mode (InterBus Master) ..........................................................................77
6.5.2 Global State Field ...............................................................................................80
6.5.3 Extended Device Diagnostic ..............................................................................82
6.5.4 Statistic Information ............................................................................................84

6.6 User Data Transfer................................................................................................. 87
6.6.1 I/O Monitor ..........................................................................................................88
6.6.2 I/O Watch............................................................................................................89
6.6.3 PCP-Monitor .......................................................................................................92

6.7 Message Monitor.................................................................................................... 94
6.7.1 Message Monitor for Testing of PCP (Server) ...................................................96

6.8 Control Active Configuration................................................................................... 97

7 FILE, PRINT, EXPORT, EDIT AND VIEW ................................................................99
7.1 File ......................................................................................................................... 99

7.1.1 Open...................................................................................................................99
7.1.2 Save and Save As ..............................................................................................99
7.1.3 Close...................................................................................................................99



SyConIB System Configurator InterBus Table of Contents  �  5

Copyright � Hilscher Gesellschaft für Systemautomation mbH � Oi:SyConIB#6EN

7.2 Print ..................................................................................................................... 100
7.3 Export Functions .................................................................................................. 101

7.3.1 DBM Export ......................................................................................................101
7.3.2 CSV Export .......................................................................................................101

7.4 Import Functions .................................................................................................. 105
7.4.1 CMD Import ......................................................................................................105

7.5 Edit....................................................................................................................... 107
7.5.1 Cut, Copy and Paste ........................................................................................107
7.5.2 Delete ...............................................................................................................109
7.5.3 Replace.............................................................................................................109
7.5.4 Assign EDS File................................................................................................110

7.6 View of the Configuration ..................................................................................... 111
7.6.1 Device Table.....................................................................................................111
7.6.2 Address Table ..................................................................................................112

7.7 View Menu SyCon................................................................................................ 113
7.7.1 Logical Network View .......................................................................................113
7.7.2 Toolbars............................................................................................................113
7.7.3 Status Bar .........................................................................................................113

8 TOOLS ....................................................................................................................115
8.1 EDS Viewer.......................................................................................................... 115
8.2 EDS Generator .................................................................................................... 116
8.3 Layout .................................................................................................................. 117
8.4 PKV 40 Gateway.................................................................................................. 118

9 ERROR NUMBERS ................................................................................................119
9.1 CIF Device Driver (Dual-port memory) Error Numbers (-1 .. -49).......................... 119
9.2 CIF Serial Driver Error Numbers (-20 .. -71) ......................................................... 123
9.3 CIF TCP/IP Driver Error Numbers ........................................................................ 125

9.3.1 Standard Win32 Socket API Errors ..................................................................125
9.3.2 Specific NetIdent Errors....................................................................................125

9.4 RCS Error Numbers (4 .. 93) ................................................................................ 126
9.5 Database Access Error Numbers (100 .. 130) ...................................................... 128
9.6 Online Data Manager Error Numbers ................................................................... 129

9.6.1 Online Data Manager Error Numbers (1000 .. 1018) .......................................129
9.6.2 Message Handler Error Numbers (2010 .. 2027) .............................................129
9.6.3 Driver Functions Error Numbers (2501 .. 2512) ...............................................130
9.6.4 Online Data Manager Sub functions Error Numbers (8001 .. 8035) ................130

9.7 Data Base Functions Error Numbers (4000 .. 4199)............................................. 131
9.8 Converting Functions Error Numbers (5001 .. 5008) ............................................ 135

10 APPENDIX ..............................................................................................................137
10.1 Extended Device Diagnostic Master..................................................................... 137

10.1.1 PLC_TASK Common Variables .......................................................................137
10.1.2 IBM_TASK Common Variables ........................................................................138



6  �  Overview SyCon SyConIB System Configurator InterBus

Copyright � Hilscher Gesellschaft für Systemautomation mbH � Oi:SyConIB#6EN

10.1.3 IBM_TASK Device Running States ..................................................................140
10.1.4 IBM_TASK Global State Field ..........................................................................140
10.1.5 IBM_TASK Communication Error.....................................................................141
10.1.6 IBM_TASK Extended InterBus Status..............................................................142
10.1.7 IBM_TASK PDL Requests................................................................................143
10.1.8 IBM_TASK PDL Confirmation ..........................................................................144
10.1.9 IBM_TASK PDL Indication ...............................................................................145
10.1.10 IBM_TASK Data Cycle Status ..........................................................................145
10.1.11 IBM_TASK Scanned ID Codes ........................................................................147
10.1.12 ALPMLIP Common Variables...........................................................................148
10.1.13 ALPMLIPD ALI Information ..............................................................................150
10.1.14 ALPMLIPD PMS Information............................................................................151
10.1.15 ALPMLIPD LLI Information...............................................................................152

10.2 Extended Device Diagnostic Slave....................................................................... 153
10.2.1 ALI_TASK Common Variables .........................................................................153
10.2.2 PCL_TASK Common Variables .......................................................................154
10.2.3 SUPI_TASK Common Variables ......................................................................155
10.2.4 SUPI_TASK IBS Information............................................................................157
10.2.5 SUPI_TASK ALI Information ............................................................................158
10.2.6 SUPI_TASK PMS Information..........................................................................160
10.2.7 SUPI_TASK LLI Information.............................................................................161
10.2.8 SUPI_TASK PDL Information...........................................................................162

10.3 Length and ID Codes ........................................................................................... 163
10.3.1 Length Code .....................................................................................................163
10.3.2 ID Code.............................................................................................................165

11 LISTS ......................................................................................................................169
11.1 List of Figures ...................................................................................................... 169
11.2 List of Tables........................................................................................................ 172



SyConIB System Configurator InterBus Overview SyCon  �  7

Copyright � Hilscher Gesellschaft für Systemautomation mbH � Oi:SyConIB#6EN

1 Overview SyCon
1.1 Main Functions

The main functions of the InterBus System Configurator are:
Function Section Short Description

Overview Communication Types Overview communication types and
description of the configuration steps

Configuration

Automatic Network Scan Scans the network
Diagnostic Functions Diagnostic functions, Debugger,

Global State Field etc.
Diagnostic

User Data Transfer I/O Monitor, I/O Watch, PCP Monitor,
Message Monitor

Project Information Set the project informationDocumentation
Print Print out the configuration

Table 1: SyCon Main Functions
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1.2 Properties
SyCon is a universal Fieldbus Configurator
This means you can configure the most important fieldbus systems like
PROFIBUS, InterBus, CANopen, DeviceNet, ControlNet, SDS, AS-Interface
etc. with the same tool.

SyCon is a global Fieldbus Configurator
You configure all devices with one tool. SyCon checks the dependencies
between the devices. SyCon only allows configurations that make sense. In
case of doubt SyCon will give you a warning.
To Hilscher devices you can make downloads of the configuration data. For
other devices, export functions or documentation possibilities are available.

SyCon documents your Fieldbus system
After the configuration you can print out a detailed documentation of your
fieldbus network. The details can be switched on/off. You can print
documentation with details between the bus topology and the detail of one
device.

SyCon uses standardized configuration files
Some protocols support standardized files containing information about all
features and limitations of the Slave device. SyCon uses these files for the
configuration.

SyCon is a diagnostic tool
After the configuration you can switch SyCon into the diagnostic mode. You
can watch all status information of Hilscher devices, see protocol
dependent diagnostic information. In this case a Slave is not operating
correctly will be displayed in a different colour.

SyCon can be extended
SyCon consists of a universal EXE file and several protocol specific DLLs.
Most customers demand SyCon only for one bus system.
SyCon can be enlarged later by adding one or more DLLs for any other
available protocol. The configuration of the different protocols will be as
similar as possible.
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2 Installation and Licensing
2.1 System Requirements

� PC with 486-, Pentium processor or higher

� Windows 95/98/ME, Windows NT 4.0/2000/XP

� Free disk space: 30 - 80 MByte

� CD ROM drive

� RAM: min. 16 MByte

� Graphic resolution: min. 800 x 600 pixel

� Windows 95: Service Pack 1 or higher

� Windows NT: Service Pack 6

� COM/DCOM only for OPC Server

� Keyboard and Mouse
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2.2 Software Installation
Close all application programs on the system!
Insert the CD Hilscher System software in the local CD ROM drive. The
installation program will start by itself (Autostart enabled). Otherwise
change into the root directory on the CD and start Autorun.exe (Autostart
disabled).

Note: Administrator privileges are required on Windows NT/2000/XP
systems for installation!

The installation program asks for the components you want to install.
Answer these questions with Yes or No.

Figure 1: Selection for the Installation of the System Configurator in basic version
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Figure 2: Selection for the Installation of the licensed System Configurator

It can be installed:

� System Configurator SyCon (Configuration and diagnostic tool)

� OPC-Server (For OPC Communication)

� CIF Device Driver (Device Driver for access to the CIF)

If you have a license code or it is printed of the label of the CD, then
answer the question for an existing license code with yes, otherwise a basic
version of the System Configurator will be installed. Enter your name and
the company name.
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2.3 Installation of the System Configurator SyCon
During the installation the user name and the company name must be
entered. If you have a license code or it is printed on the label of the CD, it
must also be entered now. Otherwise the System Configurator will work as
a basic version. In this case, all functions are available, but the
configuration is limited to two devices on the network, which is sufficient for
Slave devices.
A license can be ordered by filling out the order form under the menu item
Help > Licensing and fax this order form either to the distributor or directly
to us.
Follow the instructions of the installation program by selecting the fieldbus
system to be installed and answer all the questions with OK or NEXT.

Figure 3: Enter the Name, the Company Name and the license code

Note: The License Code 0123456789ABCDEF is no valid code and is only
used for explanation.

It is necessary to fill in the Name and the Company Name. It is optional to
fill in the Address, the City, State, Zip and Country.
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The installation program offers the following selections:
Selection Default Settings Meaning

Directory C:\Programs\Hilscher\SyCon Directory for Installation of the
SyCon and its Components

AS-Interface Selected
CANopen Selected
ControlNet Selected
DeviceNet Selected
InterBus Selected
PROFIBUS Selected
Ethernet/Protocol Selected
SDS Selected

Program DLL and Components of
the Fieldbus System or the Protocol

CIF Device
Driver

Selected
C:\Programs\CIF Device Driver

CIF Device Driver

Program Menu SyCon System Configurator Folder under Start > Programs

Table 2: Selection during installation

The installation program copies the program files, GSD or EDS files and
Bitmaps to the PC. Finally

� System DLLs

� The Application

� OLE Controls

� ODBC Components

are entered into the Registry.
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2.4 Licensing
This section describes the steps to license the System Configurator from
the already installed basic version of the System Configurator. To license
the System Configurator during installation was already described above.
Deliveries that contain a license for the System Configurator have a
formulary with. Fill out this paper (formulary) and fax it to your distributor or
directly to us. After you receive the license code enter it as described in
section Enter the License Code as described below on page 15.
An order form for a license for the System Configurator can be printed out
and is described in the next section.

2.4.1 Ordering a License for the SyCon Configurator
To order the license code for the selected fieldbus systems select the menu
Help > Licensing. The licensing window will be opened.

Fill in your name, the company name and the address for license
information into the planed fields.
Select one more fieldbus modules. There are three tables to do this. The
first table lists the modules, which are not licensed. Double click or select
and click the Add button to move the desired modules into the table in the
middle that is printed on the order form later. The modules, which are
already licensed, are shown in the last table.
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Figure 4: Example for select the Fieldbus Module InterBus

After selecting the modules select the button Print Order Form and send
us this paper by fax or by mail.

2.4.2 Enter the License Code
This section describes the steps to license the System Configurator from
the already installed basic version of the SyCon. To license the System
Configurator during installation was already described above.
Select the menu Help > Licensing. The licensing window will be opened.

In the table in the middle are listed the fieldbus modules that were already
selected for the order form. If this is not the case then select the fieldbus
modules from the upper table by double click or by select and Add.
Check if the name and the company name were entered exactly as printed
on the fax. Observe that the spelling is the same as on the fax, especially
the small and capital letters.
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Then select the button Enter License Code. The following window
appears. Enter the 16 digits of the license code.

Note: License codes with less than 16 digits can only be entered during the
installation. In this case uninstall the System Configurator first and then
restart the installation and enter the code. Also this System Configurator
(license codes with less than 16 digits) expects a license in the device.

Figure 5: Enter the License Code

Note: The license code showed above is an invalid license code and is
only used for explanation.

After you have entered the license code select the button OK. The code is
verified. If the license code is valid the System Configurator will ask you to
exit and restart the system to activate the license. If the license code is
invalid the following window appears.

Figure 6: Note license code invalid

In this case check

� the license code with the information on the fax

� the right spelling of the name and the company name with the
information on the fax. Check especially for small and capital letters.
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2.5 Scope of Functions of the Basic Version and unlicensed
Fieldbus Modules

The basic mode and unlicensed fieldbus modules have the following
functionality:

� Full functionality for configuring up to two devices. For the
configuration of one Hilscher Slave device this is enough.

� All diagnostic functions

� Open and download of an existing configuration file. If the
configuration file has more than two devices, a modification of this
configuration is not possible.
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3 Getting Started – Configuration Steps
3.1 Overview Communication Types

Select from the following the communication that you want to use. The
configuration steps are described in the given section.

Note: The booklet with the CD ROM contains information for the hardware
installation and information to the cable. At this point it is presupposed that
the hardware installation was already done.

Communication Device Device Described in section Page

Hilscher
InterBus
Master

Any
InterBus
Slave

Configuration Hilscher InterBus Master to any InterBus
Slave

20

Any
InterBus
Master

Hilscher
InterBus
Slave

Configuration Hilscher InterBus Slave to any InterBus
Master

21

InterBus (I/O)

Hilscher
InterBus
Master

Hilscher
InterBus
Slave

Configuration Hilscher InterBus Master to Hilscher
InterBus Slave

22

Hilscher
InterBus PCP
Master

Any
InterBus PCP
Slave

Configuration Hilscher InterBus PCP Master to any
InterBus PCP Slave

24

Any
InterBus PCP
Master

Hilscher
InterBus PCP
Slave

Configuration Hilscher InterBus PCP Slave to any InterBus
PCP Master

25

InterBus PCP

Hilscher
InterBus PCP
Master

Hilscher
InterBus PCP
Slave

Configuration Hilscher InterBus PCP Master to Hilscher
InterBus PCP Slave

26

Table 3: Overview Communication Types
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3.2 Configuration Hilscher InterBus Master to any InterBus
Slave

The following table describes the steps to configure a Hilscher InterBus
Master to any InterBus Slave as it is typical for many cases.

# Action Menu in the System Configurator Detail information in section Page

1 Create a new project File > New > InterBus Setting up the InterBus
Configuration

27

2 Choose Hilscher InterBus
Master

Insert > Master Insert Master 28

3 Choose InterBus Slave (*1) Insert > Remote Bus Branch Interface
or
Insert > Local Bus Branch Interface or
Insert > Remote Bus Device or
Insert > Local Bus Device

Insert InterBus Slave 31

4 Assign the input and output
modules

5 Assign the offset addresses

Mark the Slave (left Mouse click), then
Settings > Slave Configuration

Slave Configuration 34

6 Set device assignment if no
automatic assignment has
occurred

Mark the Master (left Mouse click), then
Settings > Device Assignment

Device Assignment 45

7 Save project File > Save Save and Save As 99

8 Download Mark the Master (left Mouse click), then
Online > Download

Downloading the
Configuration

69

9 Start Debugger Mark the Master (left Mouse click), then
Online > Start Debug Mode

Debug Mode (InterBus
Master)

77

10 Device diagnostic Mark the Slave (left Mouse click), then
Online > Device Diagnostic

InterBus Slave Device
Diagnostic

78

11 Stop Debugger Online > Stop Debug Mode Debug Mode (InterBus
Master)

77

12 Global Diagnostic Mark the Master (left Mouse click), then
Online > Global State Field

Global State Field 80

13 Transfer user data:
Write output, read input

Mark the Master (left Mouse click), then
Online > I/O Monitor

I/O Monitor (*2) or
I/O Watch

88
89

Table 4: Steps for Configuration Hilscher InterBus Master to any InterBus Slave

Note (*1): If the Slave device is missing in the selection list, an EDS file can
be produced with the System Configurator under the menu Tools > EDS
Generator (described on page 116).

Note (*2): Alternatively the CIF Device Driver Test program can be used for
the test. After Board Select: Data Transfer > I/O Data > DevExchangeIO.
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3.3 Configuration Hilscher InterBus Slave to any InterBus
Master

The following table describes the steps to configure a Hilscher InterBus
Slave to any InterBus Master as it is typical for many cases.

# Action Menu in the System Configurator Detail information in section Page

1 Create a new project File > New > InterBus Setting up the InterBus
Configuration

27

2 Choose Hilscher InterBus
Master (*1)

Insert > Master Insert Master 28

3 Choose Hilscher InterBus
Slave

Insert > Remote Bus Device Insert InterBus Slave 31

4 Set Length Code for Hilscher
InterBus Slave
Set ID code to 03H

Mark the Slave (left Mouse click), then
Settings > Slave Settings

Slave Settings 62

5 Assign the input and output
modules (*2)

Mark the Slave (left Mouse click), then
Settings > Slave Configuration

Slave Configuration 34

6 Set device assignment if no
automatic assignment has
occurred

Mark the Slave (left Mouse click), then
Settings > Device Assignment

Device Assignment 45

7 Save project File > Save Save and Save As 99

8 Download Mark the Slave (left Mouse click), then
Online > Download

Downloading the
Configuration

69

9 Switch the Hilscher InterBus
Slave off and then on (make
it voltage less) (*3)

- - -

10 Transfer user data:
Write output, read input

Mark the Slave (left Mouse click), then
Online > I/O Monitor

I/O Monitor (*4) 88

Table 5: Steps for Configuration Hilscher InterBus Slave to any InterBus Master

Note (*1): Insert a Hilscher InterBus Master. This Master is a place holder
and it is not necessary to match the connected Master.

Note (*2): The Offset addresses assigned in the Slave configuration are
always related to the Hilscher InterBus Master and have no meaning here.

Note (*3): Modifications of the Ident and of the Length Code that are taken
over by the Hilscher InterBus Slave device only, if it is switched off (without
voltage) and switched on again .

Note (*4): Alternatively the CIF Device Driver Test program can be used for
the test. After Board Select: Data Transfer > I/O Data > DevExchangeIO.
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3.4 Configuration Hilscher InterBus Master to Hilscher
InterBus Slave

The following table describes the steps to configure a Hilscher InterBus
Master to a Hilscher InterBus Slave as it is typical for many cases.

# Action Menu in the System Configurator Detail information in section Page

1 Create a new project File > New > InterBus Setting up the InterBus
Configuration

27

2 Choose Hilscher InterBus
Master

Insert > Master Insert Master 28

3 Choose Hilscher InterBus
Slave

Insert > Remote Bus Device Insert InterBus Slave 31

4 Set Length Code for Hilscher
InterBus Slave
Set ID code to 03H

Mark the Slave (left Mouse click), then
Settings > Slave Settings

Slave Settings 62

5 Assign the input and output
modules (*1)

6 Assign the offset addresses

Mark the Slave (left Mouse click), then
Settings > Slave Configuration

Slave Configuration 34

7 Set device assignment for
the Master if no automatic
assignment has occurred

Mark the Master (left Mouse click), then
Settings > Device Assignment

Device Assignment 45

8 Set device assignment for
the Slave if no automatic
assignment has occurred

Mark the Slave (left Mouse click), then
Settings > Device Assignment

Device Assignment 45

9 Save project File > Save Save and Save As 99

10 Download to the Master Mark the Master (left Mouse click), then
Online > Download

11 Download to the Slave Mark the Slave (left Mouse click), then
Online > Download

Downloading the
Configuration

69

12 Switch the Hilscher InterBus
Slave off and then on (make
it tensionless) (*2)

- - -

13 Start Debugger Mark the Master (left Mouse click), then
Online > Start Debug Mode

Debug Mode (InterBus
Master)

77

14 Device diagnostic Mark the Slave (left Mouse click), then
Online > Device Diagnostic

InterBus Slave Device
Diagnostic

78

15 Stop Debugger Online > Stop Debug Mode Debug Mode (InterBus
Master)

77

16 Global Diagnostic Mark the Master (left Mouse click), then
Online > Global State Field

Global State Field 80

17 Transfer user data:
Write output, read input

Mark the Master (left Mouse click), then
Online > I/O Monitor

I/O Monitor (*3) or
Alternative(for the Master):
I/O Watch

88

89

Table 6: Steps for Configuration Hilscher InterBus Master to Hilscher InterBus Slave

Note (*1): The Offset addresses assigned in the Slave configuration are
always related to the Hilscher InterBus Master.
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Note (*2): Modifications of the Ident and of the Length Code are taken over
by the Hilscher InterBus Slave device only, if it is switched off (without
voltage) and becomes switched on again.

Note (*3): Alternatively the CIF Device Driver Test program can be used for
the test. After Board Select: Data Transfer > I/O Data > DevExchangeIO.
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3.5 Configuration Hilscher InterBus PCP Master to any
InterBus PCP Slave

The following table describes the steps to configure a Hilscher InterBus
PCP Master to any InterBus PCP Slave as it is typical for many cases.

# Action Menu in the System Configurator Detail information in section Page

1 Create a new project File > New > InterBus Setting up the InterBus
Configuration

27

2 Choose Hilscher InterBus
PCP Master

Insert > Master Insert Master 28

3 Choose InterBus PCP Slave
(*1)

Insert > Remote Local Bus Device Insert InterBus Slave 31

4 Set InterBus PCP Parameter
(*2)

Mark the Slave (left Mouse click), then
Settings > Communication Reference
List (CRL)

Communication Reference
List (CRL)

38

5 Set objects (*2) Mark the Master (left Mouse click), then
Settings > Object Directory

Object Directory 42

6 Set device assignment if no
automatic assignment has
occurred

Mark the Master (left Mouse click), then
Settings > Device Assignment

Device Assignment 45

7 Save project File > Save Save and Save As 99

8 Download Mark the Master (left Mouse click), then
Online > Download

Downloading the
Configuration

69

9 Transfer user data:
Read and write data

Mark the Master (left Mouse click), then
Online > PCP Monitor

PCP-Monitor 92

Table 7: Steps for Configuration Hilscher InterBus PCP Master to any InterBus PCP Slave

Note (*1): If the Slave device is missing in the selection list, an EDS file can
be produced with the System Configurator under the menu Tools > EDS
Generator (described on page 116).

Note (*2): Consider to it also the configuration notes in the manual of the
InterBus Slave.
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3.6 Configuration Hilscher InterBus PCP Slave to any
InterBus PCP Master

The following table describes the steps to configure a Hilscher InterBus
PCP Slave to any InterBus PCP Master as it is typical for many cases.

# Action Menu in the System Configurator Detail information in section Page

1 Create a new project File > New > InterBus Setting up the InterBus
Configuration

27

2 Choose Hilscher InterBus
PCP Master (*1)

Insert > Master Insert Master 28

3 Choose Hilscher InterBus
PCP Slave

Insert > Remote Bus Device Insert InterBus Slave 31

4 Set Length Code for Hilscher
InterBus PCP Slave
Set ID code to F0H

Mark the Slave (left Mouse click), then
Settings > Slave Settings

Slave Settings 62

 5 Set InterBus PCP Parameter
(*2)

Mark the Slave (left Mouse click), then
Settings > Communication Reference
List (CRL)

Communication Reference
List (CRL)

38

6 Set Objects Mark the Master (left mouse click), then
Settings > Object Directory

Object Directory 42

7 Set device assignment if no
automatic assignment has
occurred

Mark the Slave (left Mouse click), then
Settings > Device Assignment

Device Assignment 45

8 Save project File > Save Save and Save As 99
9 Download Mark the Slave (left Mouse click), then

Online > Download
Downloading the
Configuration

69

10 Switch the Hilscher InterBus
Slave off and then on (make
it voltage less) (*2)

- - -

11 Transfer user data:
Read and write data

Mark the Slave (left Mouse click), then
Online > Message Monitor

Message Monitor 94

Table 8: Steps for Configuration Hilscher InterBus PCP Slave to any InterBus PCP Master

Note (*1): Insert a Hilscher InterBus PCP Master. This Master is a place
holder and it is not necessary to match the connected Master.

Note (*2): Modifications of the Ident and of the Length Code that are taken
over by the Hilscher InterBus Slave device only, if it is switched off (without
voltage) and switched on again .
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3.7 Configuration Hilscher InterBus PCP Master to Hilscher
InterBus PCP Slave

The following table describes the steps to configure a Hilscher InterBus
PCP Master to a Hilscher InterBus PCP Slave as it is typical for many
cases.

# Action Menu in the System Configurator Detail information in section Page

1 Create a new project File > New > InterBus Setting up the InterBus
Configuration

27

2 Choose Hilscher InterBus
PCP Master

Insert > Master Insert Master 28

3 Choose Hilscher InterBus
PCP Slave

Insert > Remote Bus Device Insert InterBus Slave 31

4 Set Length Code for Hilscher
InterBus Slave
Set ID code to F0h

Mark the Slave (left Mouse click), then
Settings > Slave Settings

Slave Settings 62

5 Set InterBus PCP Parameter Mark the Slave (left Mouse click), then
Settings > Communication Reference
List (CRL)

Communication Reference
List (CRL)

38

6 State objects Mark the Slave (left Mouse click), then
Settings > Object Directory

Object Directory 42

7 Set device assignment for
the Master if no automatic
assignment has occurred

Mark the Master (left Mouse click), then
Settings > Device Assignment

8 Set device assignment for
the Slave if no automatic
assignment has occurred

Mark the Slave (left Mouse click), then
Settings > Device Assignment

Device Assignment 45

9 Save project File > Save Save and Save As 99

10 Download to the Master Mark the Master (left Mouse click), then
Online > Download

11 Download to the Slave Mark the Slave (left Mouse click), then
Online > Download

Downloading the
Configuration

69

12 Switch the Hilscher InterBus
Slave on and off (make it
voltage less) (*1)

- - -

13 Transfer user data:
Read and write data

Mark the Master (left Mouse click), then
Online > PCP Monitor
Mark the Slave (left Mouse click), then
Online > Message Monitor

PCP-Monitor
Message Monitor for Testing
of PCP (Server)

92
96

Table 9: Steps for Configuration Hilscher InterBus PCP Master to Hilscher InterBus PCP
Slave

Note (*1): Modifications of the Ident and of the Length Code that are taken
over by the Hilscher InterBus Slave device only, if it is switched off (without
voltage) and switched on again .
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4 Configuration of InterBus with SyCon
4.1 Setting up the InterBus Configuration

To create a new configuration, choose the File > New menu. This will offer
a selection list of fieldbus systems. Choose the InterBus. If only the
InterBus fieldbus system is installed, the configuration window will open
directly.
The name of the configuration file can be allocated when the configuration
is finished or with File > Save As.

4.2 EDS Files
EDS (Electronic Data Sheet of a device) files contain and describe the
functions and characteristics of InterBus devices. All the available EDS files
together form the device database.
When the System Configurator is started, the program automatically
retrieves all the EDS files stored in the EDS directory. The device names
for example are placed into an internal list. During the configuration, the
device-specific data is retrieved directly from the EDS files.
If an EDS file for a device is needed which does not appear in the selection
list, you can generate with the System Configurator in the menu Tools >
EDS Generator an EDS file (see section EDS Generator on page 116). If
an EDS file was already generated then the EDS file can be copied into the
EDS directory with File > Copy EDS. Another possibility is to copy the EDS
file into the SyCon EDS directory with the Windows Explore and then
retrieve the EDS files into the EDS directory with Settings > Path and OK.
The EDS files can be viewed with the Tools > EDS Viewer menu.

Figure 7: EDS files and bitmaps directory

The EDS files for Hilscher devices as well as devices from other
manufacturers are already included in the scope of delivery and installed.
The files are based on no standard and can not be obtained from other
manufacturers because of this reason.
The EDS directory is adjustable. In order to alter the directory from the
default setting in another directory, use the Settings > Path menu. All EDS
files must be placed in this directory.
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4.3 Master

4.3.1 Insert Master
In order to insert a Hilscher Master into the configuration, choose the Insert
> Master menu, in order to open the selection window, or click on the
symbol:
Insert > Master

Figure 8: Insert > Master Symbol

The window opens from which exactly one Master can be chosen. After this
selection the chosen master is at the first position in the configuration
window.

Figure 9: Insert > Master

This example shows a CIF 50-IBM. It gets no Station address but the
standard description Master. This description is changeable in this window.
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4.3.1.1 Hardware Assignment

If you have configured the CIF Device Driver Setup for your hardware and
you insert the right Master in the SyCon it detects this hardware. SyCon
displays at which board and which driver was detected and ask if the
hardware should be assigned.

Figure 10: Assign hardware Master

If you answer with Yes, the hardware is assigned. If you answer with No
you have to assign this hardware with Settings > Device Assignment
(look in section Device Assignment at page 45).

4.3.2 Master Configuration
The configuration specific to the Master is carried out in the following
window.
Set the focus on the Master (left mouse click at the Master) and then select
the Settings > Master Configuration menu
or
a double click on the symbol of the Master to be configured will open the
following window.

Figure 11: Settings > Master Configuration

In this Master Configuration window can be set:

� a (symbolic) Description of the Master

� the window Master Settings (described on page 58) can be opened

� the window Global Settings (described on page 61) can be opened
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4.3.3 Replace Master
If a Master already exists in the configuration and should be replaced
against another Master, you first have to set the focus on the Master (left
mouse click at the Master) and then choose the menu Edit > Replace. In
the opened window appears the question if the Master should be replaced.

Figure 12: Security question replace Master

If you click the button Yes a new window opens, where you can replace the
Master against the existing Master.

Figure 13: Edit > Replace Master

In this window you select the Master you want by clicking on it and then
click the Add button to put the Master to Selected devices. With OK you
confirm the selection and the Master will be replaced.
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4.4 InterBus Slave

4.4.1 Insert InterBus Slave
In order to insert an InterBus Slave into the configuration, choose the Insert
> Remote Bus Branch Interface, Insert > Local Bus Branch Interface,
Insert > Remote Bus Device, Insert > Local Bus Device menu to open
the selection window
or
click on the symbol:
Insert > Remote
Bus Branch
Interface

Insert > Local Bus
Branch Interface

Insert > Remote
Bus Device

Insert > Local Bus
Device

Table 10: Insert an InterBus Slave

The mouse pointer automatically changes to the Insert Slave pointer. First
the mouse pointer for “no insert position” appears.
Mouse pointer “no insert position”

Table 11: Mouse pointer “no insert position“

Possible insert positions are displayed with a colored circle . If you
move the mouse pointer on the colored circle, it changes into these
symbols:
Mouse pointer for
Insert > Remote
Bus Branch
Interface

Mouse pointer for
Insert > Local Bus
Branch Interface

Mouse pointer for
Insert > Remote
Bus Device

Mouse pointer for
Insert > Local Bus
Device

Table 12: Mouse pointer for insert an InterBus Slave

Click on the position where the Slave is to be inserted.
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Figure 14: Possible insert positions of devices with identification by a colored circle

The window opens where one or more Slaves could be selected.

Figure 15: Insert > Remote Bus Device

The list on the left displays for selection all the Slave devices whose EDS
files have been put in the EDS directory. A filter can be used to limit the
selection list of the manufacturer. Further information on a Slave is shown
below the selection list (Available Slaves) when it is selected (one mouse
click). Apart from the manufacturer name and the description especially the
ID-Code, the Length-Code, the file name and the file revision are given.
The Slave appears on the right-hand list with a mouse click or with the Add
button. All devices in the right-hand list are assigned to the current insert
point that is also shown in this window. If the Slaves in the right-hand list
are chosen one after the other (with a mouse click), a name can be
assigned for every Slave in the Description field.
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4.4.1.1 Hardware Assignment

If you have configured the CIF Device Driver Setup for your hardware and
you insert the right Slave device in the SyCon it detects this hardware.
SyCon displays at which board and which driver was detected and ask if
the hardware should be assigned.

Figure 16: Assign hardware Slave

If you answer with Yes, the hardware is assigned. If you answer with No
you have to assign this hardware with Settings > Device Assignment
(look in section Device Assignment at page 45).
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4.4.2 Slave Configuration
First click the symbol of the Slave with the left mouse button and then
choose the Settings > Slave Configuration menu.

or
open the Slave configuration window by double clicking on the InterBus
Slave device.
The Slave-specific configuration is carried out in this window. Here, the
modules and their addresses are assigned in the process data memory in
the Hilscher Master. Note that the address must agree with that in the PC
application.

Note: The information of the offset addresses refers to the addressing of
the data in the Master! The address information does not refer to the
addressing of the data in the Slave! The Slave organizes its own data
addressing.

Note: With the Hilscher Slave, the input or output data at the Bus are taken
over directly into the Dual-port Memory.

Figure 17: Settings > Slave Configuration
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The device-specific configuration is carried out here. These are in detail:

� a description of the device,

� activate or deactivate the Slave in the actual configuration,

� configure the Process Data Addressing (see following description)

� selecting an other device without leaving the window

� changing the settings for the Parameter Data Channel with the PCP
Config... button, if the device is PCP capable. You first have to set
the focus on the Slave (left mouse click) and select the menu Edit >
Replace. The Parameter Data Channel - PCP is described in an own
section on page 38.

If Activate device in actual configuration is selected, the Master carries
out a data exchange to this device. Is this setting deactivated, then the
master doesn't carry out a data exchange to this device. In both cases
however the memory in the process image is used respectively reserved in
the Master.
The I/O addresses can be automatically assigned by SyCon or can be
allocated by the user. For this purpose you have to activate (Auto
addressing) and deactivate (manual addressing) respectively it in the menu
Settings > Global Settings the Process Data Auto Addressing. When
the Auto Addressing is active, then the addresses of the Slaves will be
allocated in their physical order by SyCon. The addresses can be viewed
and checked in the View > Address Table. When the Auto addressing is
deactivated, then only the address 0 is shown in the I Addr or O Addr and
must be overwritten by the user.
In the state of auto configuration is shown if the Process Data Addressing
are placed automatically by SyCon (selected) or manual by the user (not
selected).
Depending on the Addressing mode, which can be set in the InterBus
Master Settings, the addresses are either Byte or Word addresses. For
further details of this, see the description in the section Addressing Mode
on page 60.
At actual device you can change to another Slave device without leaving
the window.
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Individual InterBus Slave devices can be combined to groups with the
group number. This is optional. In the field group number you can

� indicate only one number (from 1 to 255)

� also indicate an alternative number (from 1 to 255) apart from the
group number in the course of which group number and alternative
have to be separated with a hyphen. For example: 2-4 (group 2,
alternative 4).

The group number is used to switch devices of one group on and off
together.
The alternative number is used to switch on one or another alternative,
however not more than one alternatives.



SyConIB System Configurator InterBus Configuration of InterBus with SyCon  �  37

Copyright � Hilscher Gesellschaft für Systemautomation mbH � Oi:SyConIB#6EN

4.4.3 Replace Slave
To replace a Slave device in the configuration against another you first
have to set the focus on the Slave (left mouse click at the Slave) and select
the menu Edit > Replace. In the opened window the question appears if
the Slave device should be replaced.

Figure 18: Security question replace device

If you answer this question with Yes, the following window appears where
you can select another Slave device.

Figure 19: Edit > Replace Device

In this window you can choose the device you want by clicking on it. By
clicking the Add button the Slave is shown under Selected devices. With
OK you confirm the selection and the Slave will be replaced.
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4.4.4 Parameter Data Channel - PCP
The PCP Channel offers the user data exchange with the functions read
and write.
The direction of user data is shown in the following table:
Function Direction of user

data

Read From server to client
Write From client to server

Table 13: PCP Channel: direction of user data for reading and writing

Before you are able to use the functions read and write you first have to

� Set logic connection (Communication Reference List, CRL) in both
devices (see section Communication Reference List (CRL) at page
38) as well as

� Set objects in the sever (see section Object Directory at page 42)
With the Download of the configuration into the Hilscher InterBus Master
the Communication Reference List is loaded into the Master.

With the Download of the configuration into the Hilscher InterBus Slave the
Communication Reference List and the Object Directory of the Slaves are
loaded into the Slave.

4.4.4.1 Communication Reference List (CRL)

Communication between two PCP devices is only possible, when a
communication relation is configured between both devices (each device
has to be PCP capable). This means both devices get information how to
communicate with the other device. This information is saved in a data
base, called Communication Reference List (CRL).
The logic connection (Communication Reference CR) can be set from the
view of the Master or from the view of the Slave.
From the view point of the Master:
At first you have to mark the Master (left mouse click) and then select the
menu Settings > Communication Reference List...
or
right mouse click on Master and click on Communication Reference
List...
A new Communication Reference will be added in the CRL Table with Add
or Insert.
If a new entry is added or insert into an empty CRL table, this entry gets the
description CR 2 because CR 1 is used internally.
In Remote address / device you can select the remote station for the
current Communication Reference.
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Note: The number of the Communication Reference is the key for the
communication.

The difference between CR Add and Insert is:
With the button Add you insert the new entry at the end of the list. With
Insert the new entry is fitted in at the current position and the other CR in
the list move one position forwards.
The following figure shows the typical settings for Max. SCC, Max. RCC,
Max SAC, Max RAC, the Client Services, the Server Services, the Acyclic
Control Interval (ACI) as well as for  the Max. PDU Size Send and Max.
Size Receive.

Figure 20: Communication Reference List from the view of the Master

Note: Please note that the permissible settings in the instruction of InterBus
Slave device (configuration instructions).

Note: Please note that these settings also exist in the communication
partner device!
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From the view point of the Slave:
At first you have to mark the Slave (left mouse click) and select the menu
Settings > Communication Reference List...
or
right mouse click on the Slave and click on Communication Reference
List...
or
double click on the Slave and press in the window Device Configuration
the button PCP Config... In the following window PCP Configuration you
have to choose Device CRL. Finally confirm with the OK button.

Figure 21: Selection of Master or Device CRL

A window with the CRL of the selected Device appears.
You have to carry out the settings as already described in this section.
These settings are from the view point of the Slaves.
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Figure 22: Communication Reference List from the Slaves point of view
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4.4.4.2 Object Directory

The Slave expects a description about the objects, which are available in
the user application. For this you have to create an Object Directory. All
configured objects are shown in the window Object Directory. Objects can
be added or removed and their specific property can be set.
First mark the Slave (left mouse click) and select the menu Settings >
Object Directory
or
right mouse click on the Slave and select Object Directory.

Figure 23: Object Directory single element

Insert a new object into the Object Directory with Add or Insert.
� General

The Object index describes a unique number which is assigned to a
definite data object inside the Object Directory of the Slave. You can
save a short text as a description to each object. Here appears a
standard object with the index 1000h.

� Data Type
The Data Type of an object is decisive for its length. Here you can
select different Data Types: Boolean, Int8, Int16, Int32, Uint8, Uint16
and two string Data Types (ASCII in OCTET), which require
information for it's length.

� Object Type
Objects can be distinguished according to single element or field.
Single element Types (Standard Object Types or Single Element)
are for example Integer-Variable. On the other hand field Object
Types are Arrays. Arrays need the information about the number of
the available Elements.
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Figure 24: Object Directory Array (field)
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5 Settings
5.1 Device Assignment

The Device Assignment setting determines how the System Configurator
communicates with the device. This is selected in the device arrangement
via the menu Settings > Device Assignment.

5.1.1 Driver Selection
Calling up the Device Assignment, firstly a dialog window opens, where a
driver has to be selected.

Figure 25: Driver Selection

With the selection of the driver, it is determined, how the System
Configurator communicates with the device. The following drivers are
available:

� CIF Device Driver
The System Configurator communicates with the Hilscher device via
the Dual-port memory of the device.
This communication is utilized when the System Configurator is used
on the same PC on which the Hilscher device is installed.

Note: The CIF Device Driver has to be installed and it must have access to
the Hilscher device.

� CIF Serial Driver
The System Configurator communicates with the Hilscher device via
a serial connection. In this case a COM port of the PC must be
connected with the diagnostic interface of the Hilscher device via a
diagnostic cable.

Note: The pin assignment of the diagnostic cable is described in the
hardware documentation of the device manufacturer.

This communication is utilized when the System Configurator has to
access the device via the diagnostic interface of the Hilscher device.
The following two application cases are possible:
Application case 1: The System Configurator is installed on another
PC (e.g. a notebook) than the Hilscher device.
Application case 2: The System Configurator is installed on the same
PC on which the Hilscher device is situated. Then the application can
use the Dual-port memory to access the Hilscher device and the
diagnostic interface can be used at the same time to communicate
with the device (diagnostic data).
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� CIF TCP/IP Driver
The System Configurator communicates with the Hilscher device via
an Ethernet TCP/IP connection.
This communication is utilized when the System Configurator is
installed on a PC and the PC and the Hilscher device is connected
via Ethernet.
It has to be distinguished:
1. The Hilscher device is installed in a PC and the TCP/IP connection
is built up to the PC, which means the IP address of the PC is used
as IP address.
2. The Hilscher device has an own Ethernet connection and the
TCP/IP connection is built up to the Hilscher device, that means the
IP address of the Hilscher device is used as IP address.

Select the favored driver for the communication between the System
Configurator and the used device from the lower table.
You find a detailed instruction about the selection of the several drivers in
the denoted section:
Driver Described in section Page

CIF Device Driver CIF Device Driver 47
CIF Serial Driver CIF Serial Driver 49

CIF TCP/IP Driver CIF TCP/IP Driver 51

Table 14: Driver Selection

To select a driver, mark the favored driver by clicking on it in the dialog
window Driver Select and confirm your selection with OK.

The configuration window of the favored driver opens.
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5.1.2 CIF Device Driver
The CIF Device Driver supports up to four Hilscher devices in one PC, and
they are accessed via the Dual-port memory.

Driver Description

Figure 26: CIF Device Driver - Driver Description

In the upper part of the CIF Device Driver dialog the actual used CIF
Device Driver and its version number are displayed.
This display is only for information purposes and is not editable by the user.

Board Selection

Figure 27: CIF Device Driver - Board Selection

If an assignable device is found by the CIF Device Driver, the checkbox
next to the board number is selectable. To select the device, you have to
enable it by clicking in the checkbox located left of the desired board and
confirm this selection with OK.

Checkbox Description

Device is still not assigned and it can be selected.

Device is assigned. The Assignment can be abrogated by deselecting.

The assignment of the device is not possible.

The device is still assigned in another open configuration and can not be
selected here.

Table 15: Device Assignment - Checkboxes of the CIF Device Driver
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Now the device is connected with the System Configurator via the CIF
Device Driver and the Device Assignment dialog is closed.
By clicking the Cancel button, the Device Assignment is closed without an
assignment has been completed or respectively changed.

More Details of the CIF Device Driver
Next to the field Board Selection there is a button with the name more>>.
Selecting this button, a dialog opens which displays further information
about the CIF Device Driver.

Figure 28: CIF Device Driver - More Details

In this dialog the used Dual-port memory base address, the Dual-port
memory size and the Interrupt number of the selected board are
displayed. Interrupt number 0 means polling mode.
This display is only for information purposes and is not editable by the user.
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5.1.3 CIF Serial Driver
The CIF Serial Driver supports the interfaces COM1 to COM 4 of the PC, in
order to get the configuration or to do diagnostic serially via the diagnostic
interface of the Hilscher device.

Driver Description

Figure 29: CIF Serial Driver - Driver Description

In the upper part of the CIF Serial Driver dialog the actual used driver is
displayed.
This display is only for information purposes and is not editable by the user.

Board Selection

Figure 30: CIF Serial Driver - Board Selection

First the connection must be established by clicking on the button Connect
COM1 or Connect COM2 or Connect COM3 or Connect COM4.
They can be used depending on which COM interfaces are installed and
free on the PC.
The System Configurator sends a request to the corresponding COM Port
and polls the Firmware of the device. If the device is connected, the
Firmware of the device is displayed and the checkbox of the corresponding
COM interface is selectable.
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Checkbox Description

Device is still not assigned and it can be selected.

Device is assigned. The Assignment can be abrogated by deselecting.

The assignment of the device is not possible.

The device is still assigned in another open configuration and can not be
selected here.

Table 16: Device Assignment - Checkboxes of the CIF Serial Driver

This selection has to be confirmed by clicking the OK button. Now the
device is connected with the System Configurator via the serial driver and
the Device Assignment dialog is closed. If the assignment is not possible or
if the assignment has failed, this is displayed by an error number in the
Error column.
If the error number (-51) appears after activating one of the buttons, a
timeout error has occurred. That means no device is connected to this
COM port.
The error number (-20) indicates that this COM port is not available or not
free (already in use).
By clicking the Cancel button, the Device Assignment is closed without an
assignment has been completed or respectively changed.
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5.1.4 CIF TCP/IP Driver
The CIF TCP/IP Driver builds up a connection to the Hilscher device via
Ethernet TCP/IP.
This communication is utilized when the System Configurator is installed on
a PC and the PC and the Hilscher device are connected via Ethernet.
It is distinguished between two application possibilities:
1. The Hilscher device is installed in a PC and the TCP/IP connection is
built up to the PC, which means the IP address of the PC is used as IP
address.
This PC is called Remote PC in the following. The following two
requirements have to be accomplished to get access to the Hilscher device
via Ethernet TCP/IP:

Note: The CIF Device Driver has to be installed and it must have access to
the Hilscher device. Additionally the TCP/IP Server has to be started on the
Remote PC.

2. The Hilscher device has an own Ethernet connection and the TCP/IP
connection is built up to the Hilscher device, that means the IP address of
the Hilscher device is used as IP address.

Driver Description

Figure 31: CIF TCP/IP Driver - Driver Description

In the upper part of the CIF TCP/IP Driver dialog the actual used driver and
its version number are displayed.
This display is only for information purposes and is not editable by the user.
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Build up TCP/IP Connection
There are two possibilities to enter the IP address to build up a TCP/IP
connection between the Hilscher device and the PC.

� Scan network for devices
Clicking on the NetIdent Rescan button, the local Ethernet network is
scanned for Hilscher devices. This devices need to support the
identification by the Hilscher NetIdent Protocol.
Devices found during the network scan and which are connectable to
the PC are displayed in the table Board Selection.

� Type in IP Address manually
If the device to be connected is not located in the local Ethernet
network, it is necessary to type in the IP address of the device
manually.
Also some devices do not support the identification by the Hilscher
NetIdent Protocol. In this case the IP address of the device has to be
typed in manually, too.

Figure 32: CIF TCP/IP Driver - Type in IP Address manually

The IP address of the device to be connected need to be typed in the field
Add IP Address. Clicking the Add button, it is tried to build up a CIF
TCP/IP connection between the PC and the device.
If a device with the typed in IP address was found, it is displayed in the
table Board Selection.
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Board Selection
In the table Board Selection the devices are displayed, which were found
via inserting the IP address or via the Hilscher NetIdent Protocol and which
can be connected to the PC.

Figure 33: CIF TCP/IP Driver - Board Selection - Found Device

When the device already has an IP address, this is shown in the field IP
Address.
If the shown IP address is 0.0.0.0, an IP address has to be assigned to the
device with the button Set IP Address. Further information for changing the
IP address you find in section Change IP Address on page 54.

Connect Device
To connect a device to the PC, the checkbox of the favored device has to
be selected in front of the IP Address field.

Checkbox Description

Device is still not assigned and it can be selected.

Device is assigned. The Assignment can be abrogated by deselecting.

Table 17: Device Assignment - Checkboxes of the CIF TCP/IP Driver

Note: A connection can be build up to exactly one device.

The following picture shows an assigned device:

Figure 34: CIF TCP/IP Driver - Board Selection - Assigned Device

This selection has to be confirmed by clicking the OK button. Now the
device is connected with the System Configurator via the CIF TCP/IP Driver
and the Device Assignment dialog is closed.
By clicking the Cancel button, the Device Assignment is closed without an
assignment has been accomplished or respectively changed.
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Filtered Devices

Figure 35: CIF TCP/IP Driver - Filtered Devices

Devices listed in the table Filtered Device(s) were found during the
network scan in the local Ethernet network, but they can not be assigned,
because they belong to another device family.

5.1.4.1 Change IP Address

A new IP address is assigned to a device or respectively an existing IP
address of a device is changed via the button Change IP Address.

Note: The IP address can only be changed in case of Hilscher devices
which are connected directly to the Ethernet and which support the function
'Change IP Address'. These are for example: NL-MPI, NN40, NN42, CIF
104-EN, COM-C-EN, COM-EN.

Therefore the device has to be selected in the table Board Selection by
activating the checkbox. Via the Change IP Address button the following
dialog opens:

Figure 36: Set IP Address

Type in the IP address for the device and confirm the entry by clicking on
the Set IP button.

Note: The IP address set by clicking the Set IP button is only temporarily
adjusted. A permanent storage of the IP address takes place with a
download of the configuration from the framework.
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5.2 Bus Parameters
The Bus Parameters can be displayed with the menu Settings > Bus
Parameters.

Figure 37: Settings > Bus Parameters

Attention: The alteration of Bus Parameters can cause communication
faults.

Note: The displayed Bus Parameters are offline values. The Bus
Parameters are used after the download of the configuration to the Hilscher
device.

The Baud rate is only adjustable up to 500kBaud. We reserve the right for
extensions.
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The Network Supervision Parameters serve for adjustment of error
tolerance in the case of data cycle errors. The Master supervises every
data cycle. If an error appears, this data cycle is repeated after an
identification cycle was executed.
� Maximum try time to execute one valid, faultless process data

cycle before network is reset and rescanned. This parameter is a
time in the multiples of 8 milliseconds, in which the master tries to
transmit a disturbed data cycle error free N times. After a data cycle
error the master always starts an identification cycle, in order to
recognize all available Slave devices, before the same data cycle is
restarted. This procedure is repeated until the data cycle is
transferred without an error and is however terminated when the
maximum configured time interval exceeds its limit. At least then the
network is reset. As a function of the Behaviour in case of defective
Slave device and Network Scan Time Interval if devices missing
the master stops the entire communication or tries to initialize the
network again.

� Maximum number of bundled process data cycle errors before
network is reset and rescanned. Sometimes it is possible, e.g. by
an EMC disturbance within the InterBus network that a whole
sequence of successive data cycles are destroyed. The maximum
permissible number of direct successively disturbed cycles is defined
here. A value of 20 is the presented value. If this value is exceeded,
the master as a function of Behaviour in case of defective Slave
device  and Network Scan Time Interval if devices missing stops
entire communication or tries to reinitialize the network again.

� Maximum number of error detecting network scans after a
defective process data cycle, before the process data cycle is
retried again. If a data cycle error occurs, the master starts
automatically an identification cycle, in order to determine the source
of error in the network. If this following identification cycle is executed
also incorrect too, the master tries to repeat it according the number
indicated here, before it reacts in accordance to the Behaviour in
case of defective Slave device and Network Scan Time Interval if
devices missing.
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The Behaviour in case of defective Slave device determines the
procedure of the Masters, if a Slave is detected as missed during run time
and during the first network start up phase
� Try to hold the rest of the network operative, if one device is

defective. The master does not consider the status of the attached
Slaves and the resetting of the network in the case of an error is
disabled. Depending on the Network Scan Time Interval in case of
missing devices, the master tries to get all missing devices
preoperative by rescanning the network cyclically.

� Reset the whole network and stop the communication, if one
device is missing. The master stops entire network communication
and resets the entire network, if it detects a missing Slave device
during the first network scan or during the data exchange.

� Reset the whole network and stop the communication, if one
device is reporting peripheral error. The master stops the entire
communication and resets the whole network, if at least one Slave
device is reporting an InterBus specific module error. Modules
reporting such an error is indicating thereby e.g. short-circuit at an
output or under voltage.

� Reset the whole network and stop the communication, if one
device is reporting peripheral error or device is missing. The
master stops entire communication and resets the network, if it
detects a missing Slave during the first network scan or during the
data exchange or if at least one Slave device indicates an InterBus
specific module error.

Network scan time interval in case of missing devices
This parameter enables or disables the scan cycles in those cases a
missing Slave device was detected. If the value is configured to 0, this
function is deactivated.
The first cycle of the network scan, which is executed by the master directly
after the initialization, is independent of this parameter and is always
executed. Values unequal of 0 configure a cycle time in the multiples of 800
msec. Please note that the cyclic data exchange during this rescan is
interrupted, but the initially left and original process data during this cycle
are remaining at their old values.
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5.3 InterBus Master

5.3.1 Master Settings
To enter the Master settings, choose the Settings > Master Settings or
click with the right mouse button on the corresponding Master symbol and
select the menu Master Settings from the list that opens. The Master
Settings is also available in the Master Configuration window.
The Master settings contain parameters that determine the behaviour of the
Master device as well as the user interface. These settings are only valid
for Hilscher devices and are included in the download of the configuration.

Figure 38: Settings > Master Settings

� Startup behaviour after system initialization
When Automatic release of the communication by the device has
been set, the Master device starts with the data exchange at the Bus
after the initializing has been finished. When Controlled release of
communication by the application program has been set, the
application program has to activate the data exchange at the Bus.
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� User program monitoring
The Watchdog time determines how long the device waits for a
triggering of the software watchdog by the application program until it
sets the outputs of the Slave devices to zero. This behaviour must be
activated by the user program and does not start automatically.

Note: This is not a special InterBus function.

An example of the use of this function can be a SoftPLC.

� Addressing mode
The addressing mode of the process data image determines how the
addresses (Offsets) of the process data are interpreted. Either of the
addressing modes Byte addresses or Word addresses are
possible. See also details on the next page.

� Storage format (word module)
The storage format determines how the data words are stored in the
process image. For the Word data type it is possible to choose
higher/lower value Byte or lower/higher value Byte.

Storage format (word module)

MSB/LSB = higher/lower = Motorola format = Big Endian
LSB/MSB = lower/higher = Intel format = Little Endian

Table 18: Storage format

� Handshake of the process data
These various types are used for setting the handshake of the
process data for the Master. The choice of used type is important for
the correct data exchange between the application program and the
device.
The used handshake of the process data needs to be supported by
the application program. Mostly the buffered, host controlled
handshake is supported. The setting no consistence, uncontrolled
works without handshake and the processes run free.

� Hardware parameter
This parameter displays the full size of the dual-port memory. This is
read only information. If the size is for example 2KB then 1KB is
usable for the process image.
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5.3.2 Addressing Mode
The addresses in the configuration of the Nodes define the starting point of
the data in the process depiction. This can work in a Word or Byte oriented
method by means of the Addressing mode parameter.
Addresses Meaning

Byte addresses The process image has a Byte structure and each Byte has its own
address.

Word addresses The process image has a Word structure and each Word has its own
address.

Table 19: Addressing Mode

This has nothing to do with the physical size of the Dual-port memory – this
is always Byte-oriented! When the application makes a Word access, it is
automatically divided by the PC into two sequential Byte accesses.
The following table shows the different storing of the various data types in
the Byte- or Word-oriented process image:

IEC
address
in Byte
mode

IEC
addresses
in word
mode

Offset
address
es in the
dual-
port
memory

Data in
the
process
image

Output to an I/O Module

QB 0 QB 0 0 0000 0000
QB 1 1 0000 0000
QB 2 QB 1 2 1110 0010 Output of QB2 / QB1 to a single Byte module:

D7 D6 D5 D4 D3 D2 D1 D0
  1    1    1    0    0    0    1    0

QB 3 3 0000 0000
QB 4
QB 5

QB 2 4
5

1111 1000
0000 0111

Output of two Bytes beginning from QB4 / QB2 to a module that is
defined as a Byte module with the data count 2 (no differentiation
between the two memory formats as the data are of Byte type):
D7 D6 D5 D4 D3 D2 D1 D0  D7 D6 D5 D4 D3 D2 D1 D0
  1    1    1    1    1    0    0    0    0    0    0    0    0    1    1    1

QW 6 QW 3 6
7

1111 1111
0100 0100

Output of QW6 / QW3 in the data format lower/higher value Byte:
D15 D14 D13 D12 D11 D10 D9 D8 D7 D6 D5 D4 D3 D2 D1 D0
  0      1      0      0      0      1     0    0     1    1    1    1    1    1    1   1
Output of QW6 / QW3 in the data format higher/lower value Byte:
D15 D14 D13 D12 D11 D10 D9 D8 D7 D6 D5 D4 D3 D2 D1 D0
  1      1      1      1      1      1     1    1     0    1    0    0    0    1    0   0

Table 20: Example for data in the process data image
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The following table is meant to clarify the method of addressing:

Byte addressing Word addressing
Byte 0 IB 0 IB 0
Byte 1 IB 1

IW 0 Word 0
-

IW 0

Byte 2 IB 2 IB 1
Byte 3 IB 3

IW 2 Word 1
-

IW 1

Byte 4 IB 4 IB 2
Byte 5 IB 5

IW 4 Word 2
-

IW 2

Table 21: Image of the method of addressing for input

Byte addressing Word addressing
Byte 0 QB 0 QB 0
Byte 1 QB 1

QW 0 Word 0
-

QW 0

Byte 2 QB 2 QB 1
Byte 3 QB 3

QW 2 Word 1
-

QW 1

Byte 4 QB 4 QB 2
Byte 5 QB 5

QW 4 Word 2
-

QW 2

Table 22: Image of the method of addressing for output

5.3.3 Global Settings
In this window it is set whether the process data addressing is executed
automatically by SyCon (active selected) or manually by the user (active
not selected).

Figure 39: Settings > Global Settings



62  �  Settings SyConIB System Configurator InterBus

Copyright � Hilscher Gesellschaft für Systemautomation mbH � Oi:SyConIB#6EN

5.4 InterBus Slave

5.4.1 Slave Settings
The InterBus Slave settings contain parameters that define the behaviour of
the device at its user interface, which does not belong to the InterBus
configuration. This menu point is only valid for Hilscher devices. These
settings are transferred with the download of the InterBus configuration to
the device.
In order to open the InterBus Slave settings menu, first choose the Slave
and then open the window in the Settings > Slave Settings menu.

Figure 40: Settings > Slave Settings
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� Ident- and Length Code
The Ident code determines the behaviour of the device at the bus.
With the length code the entire data length of the Slaves is
determined within an InterBus cycle. This length reduced with the
parameter data length (if necessarily) results in the remaining (cyclic)
process data length.

ID-Code Meaning

3,03h Digital I/O
240,F0h PCP (two words)

Table 23: Ident-Code (for Hilscher InterBus Slaves)

Length Code Length for ID Code 3, 03h Length for ID Code 240, F0h

1, 01h 1 Word (2 Octets) I/O -
2, 02h 2 Words (4 Octets) I/O 2 Words PCP (2 Octet)
3, 03h 3 Words (6 Octets) I/O 1 Words (2 Octets) I/O and 2 Words PCP
4, 04h 4 Words (8 Octets) I/O 2 Words (4 Octets) I/O and 2 Words PCP
5, 05h 5 Words (10 Octets) I/O 3 Words (6 Octets) I/O and 2 Words PCP
6, 06h 6 Words (12 Octets) I/O 4 Words (8 Octets) I/O and 2 Words PCP
7, 07h 7 Words (14 Octets) I/O 5 Words (10 Octets) I/O and 2 Words PCP
9, 09h 8 Words (16 Octets) I/O 6 Words (12 Octets) I/O and 2 Words PCP
14, 0Eh 9 Words (18 Octets) I/O 7 Words (14 Octets) I/O and 2 Words PCP
15, 0Fh 10 Words (20 Octets) I/O 8 Words (16 Octets) I/O and 2 Words PCP
21 ,0F 1 Octet -

Table 24: Length Code (for Hilscher InterBus Slaves)

� Generation of peripheral errors
In this field events can be determined, which results in a station
error for the Slave for in the InterBus Master. These events are as
follows:

� if the configured time of the user program monitoring ran out
(Softwarewatchdog)

� if the NotReady Bit was set

� after an initialization error

� after a renewed initialization command.

� Startup behaviour after system initialization
If automatic release of communication is selected by the system,
the Slave is ready to communicate with the master. If controlled
release of communication is selected by the application program,
the user program must release the communication.
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� User program monitoring
The monitoring time indicates, how long the device for a user
triggering will wait, until it resets all outputs to zero. This must be
activated by the application program (triggering of the software
watchdog).

� Parameter to process data interface
With these different functions that is selected the, handshake of the
process data of the Slaves. The selection of the function is important
for correct data exchange between application and the device (look at
page 58).

5.4.2 Slave Configuration
The Slave configuration is described further above in the section
Slave Configuration on page 34.



SyConIB System Configurator InterBus Settings  �  65

Copyright � Hilscher Gesellschaft für Systemautomation mbH � Oi:SyConIB#6EN

5.5 Project Information
If the user creates an own project, the project information can be typed in
into the Settings > Project Information menu. Anybody can then read this
entry when this menu is opened.

Figure 41: Settings > Project Information

By clicking the OK button the Project Information is saved.

5.6 Path
When the Settings > Path menu is selected, then the search path for EDS
files is displayed.

Figure 42: Settings > Path

If you click the OK button all EDS files are read in.
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5.7 Language
Choose the Settings > Language menu and the following window opens:

Figure 43: Settings > Language

Here can be set the language of the System Configurator. Select the
desired language and confirm the entry with the OK button.

A message appears that the System Configurator must be started again in
order to activate the selected language. Please carry this out.
After restarting the System Configurator, the language will have changed to
the one selected.

Note: Up to now not all languages are available for all fieldbuses!

5.8 Start Options
Starting from the window Network View (menu Window > Network View)
the menu Settings > Start... opens the window Start Options. The
different start options or modes can be set. Some of these settings are only
for the OPC server.

Note: This menu option Start Options is only displayed in the selection
Settings, if a project is loaded.
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Figure 44: Settings > Start Options

� Simulation mode ON/OFF
Only valid for the OPC Server.

� Start SyCon hidden if started via OPC
Only valid for the OPC Server.

� Start SyCon next time with last Configuration
When this is selected the last saved configuration in the SyCon is
automatically loaded when the SyCon is started again.

� Logic Network View visible
When this is selected possibility of diverting to the network mode
without having to install the SyCon with OPC. It is also possible to
use the Watch List from the network mode.

� Fast start ON/OFF
Only valid for the OPC Server.

� MSG tracing ON/OFF
Only valid for the OPC Server.
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� Auto connect ON/OFF
If this is marked, when opening a configuration automatically a
connection to that Hilscher devices is manufactured without the
device assignment additionally have to be executed.

� Send Message only when changed
Only valid for the OPC Server.

� Message transfer synchronous
Only valid for the OPC Server.

� Start with multiple configurations
If this option is selected you have the possibility to start SyCon with
up to four configurations simultaneously. The paths are shown in the
window and they are changeable there.
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6 Online Functions
6.1 Introduction

In this section, all the functions that directly influence Hilscher InterBus
devices, e.g. CIF 50-IBM, CIF 30-IBS, are presented.

Note: Please note that this also permits an interruption of the running
communication or that input and output can be switched ON or OFF.

6.2 Online to the CIF

6.2.1 Downloading the Configuration
First, the desired device must be chosen for downloading by a left mouse
click on the symbol of the device.
In order to transfer the configuration, a transfer download to the
CIF/COM/PKV devices must be carried out on the Online > Download
menu. A warning will appear that the communication on the InterBus will be
interrupted. This warning must be confirmed.

Figure 45: Security question before download

Attention: The download overwrites the configuration in the device.

Figure 46: Online > Download

Before the Download is executed, the configuration is checked by the
Configurator. The most common cause of error is overlapping of addresses
in the process data image. This can be checked by calling up the address
table with the View > Address Table menu.
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If the assignment of addresses in the process data image should be carried
out automatically, then the Auto Addressing button in the Master
Configuration window must be activated.
The configuration is transferred into the selected device and is stored there
in FLASH memory in a zero voltage manner so that the configuration is
available when the power supply is switched off and on again.
After the download, the device carries out an internal restart and begins
with the communication if in Master Settings the Automatic Release of
Communication by the Device menu has been set.

Note: (only for the Slave) Modifications of the Ident and of the Length Code
that are taken over by the Hilscher InterBus Slave device only, if it is
switched (without voltage) and becomes switched on again .

6.2.2 Firmware Download
If you want to carry out a Firmware download, act as follow: First the
desired device for Firmware downloading must be chosen in that the
symbol of the device is selected with a left mouse click. Then, call up the
Online > Firmware Download menu. Select the new Firmware and
retrieve it with Download into the device. The Firmware is now
downloaded.

Figure 47: Online > Firmware Download
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6.2.3 Firmware / Reset
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then the Online > Firmware / Reset menu must be
called up and the name and the version of the Firmware are displayed.

Figure 48: Online > Firmware / Reset

The device can be reset with the Reset button.

6.2.4 Device Info
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Device Info menu in order
to obtain further information on the selected device.
The manufacturer date, the device number and the serial number of the
device is read out and shown.

Figure 49: Online > Device Info

6.2.5 Read Project Information
With Online > Read Project Information can be read out the project
information from the device.
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6.2.6 Activate Driver - Driver Licensing
The driver has to be licensed, if the software PLC or SyCon OEM is used.
If the driver was ordered by buying the SyCon, you don't need to license it
because this was done before.
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Activate Driver menu.

Figure 50: Online > Activate Driver

Note: The code 01234567890ABCDEF is not a valid code and is only an
example.
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6.3 Automatic Network Scan
This function scans the network structure. During the scan it will be
detected which devices are connected to this InterBus. Therefore the
following steps are necessary:

� Create a new project: Select the menu File > New and InterBus.

� Select the Master: Select the Master from the menu Insert > Master.
� If the Master isn't initialized you need to make a download first. To

make this download select the menu Online > Download.

� Scan the network: Select the menu Online > Automatic Network
Scan. Hereby the Length and ID code as well as the installation
depth of all users attached at the network are determined.

Figure 51: Online > Automatic Network Scan (security question)

Answer this question with Yes, if the connected InterBus network should be
scanned. Answer this question with No, if these functions should not be
performed.

Figure 52: Online > Automatic Network Scan (During the Scan)

All buttons are grey during the network scan.
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Figure 53: Online > Automatic Network Scan (After the Scan)

6.3.1 Automatic Configuration
If you activate the button Automatic Configuration, the following safety
question appears.

Figure 54: Online > Automatic Network Scan > accept configuration

Answer the question with Yes, if the read in structure is to be taken over as
configuration. Answer the question with No, if the old configuration is to be
maintained.
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6.3.2 Assign EDS File
After reading the network structure the Length and ID Codes of the
connected devices are known, an assign of EDS files is possible. With the
menu Edit > EDS file assign opens a dialog that contains a list with the
suitable EDS files, from which the correct device can be selected.

Figure 55: Online > Automatic Network Scan > Assign EDS file

Description of the navigation buttons:
With the navigation buttons it is possible to assign each device an EDS-file
directly by clicking on these buttons. Without this buttons you need to close
the dialog Assign Device with the OK button and select another device in
the window Actual Network Structure to assign the other devices.
Button Meaning

With this button the first detected device is loaded into the dialog

With this button the previous device is loaded into the dialog

With this button the next device is loaded into the dialog

With this button the last detected device is loaded into the dialog

Table 25: Assign EDS files - buttons and their meaning

The option "Jump to next device" make it easier to assign the EDS-files,
too.
If this option is activated the next device is loaded into the dialog
automatically after the user had assigned an EDS-file for a previous device.
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6.4 Start/Stop Communication
First the desired device must be chosen with a left mouse click on the
symbol of the device. The communication between InterBus Master and
InterBus Slave can be manually started or stopped. In order to do this
select the Online > Communication start or Online > Communication
stop menu.
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6.5 Diagnostic Functions

6.5.1 Debug Mode (InterBus Master)
Starting from the Master select the menu Online > Start Debug Mode. The
System Configurator cyclically reads out the status of the network
communication on the Hilscher device and the individual condition of the
devices.
To end the Debug Mode select the menu Online > Stop Debug Mode.

6.5.1.1 Debug Window

When started the debug session the configuration window changes into the
debug window. The devices and the line between them are displayed in
green or red colour depending on the established network communication.

Figure 56: The Debug Window

If diagnostic information is available for a specific device, next to the device
icon the text Diag appears in red. To get further device specific diagnostic
information then double-click on the device itself or set the focus to the
device and select Online > Device Diagnostic.

The master icon has the sign  to show the Master is in stop mode.

In run mode the master icon has the sign .
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6.5.1.2 InterBus Slave Device Diagnostic

After the debugger was started from this time SyCon requests the status of
all devices from the Master. If there is an error on a device the bus line to
this Slave is drawn in red colour otherwise it is green. This information is
displayed closer if you click with the mouse onto the corresponding device
in debug mode.
To activate the debug mode you have to mark the Master and select the
menu Online > Start Debug Mode. Then set the focus at the Slave and
with the menu Online > Device Diagnostic you activate the InterBus
device diagnostic. To end the Debug Mode you have to mark the Master
again and select the menu Online > Stop Debug Mode.

Figure 57: Online > Device Diagnostic (InterBus standard diagnostic)
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The individual bits in the Device Diagnostic have the following meaning:
Bits in the Device
Diagnostic

Meaning

No answer The station is configured but missing at the network.
Please you check the cable connection between the
master and the Slave device.

Error buffer overflow An error can occur at each Slave device during operation.
These errors are stored in an internal buffer, which can
take up 50 error registrations per Slave device. This bit is
set, if the buffer overflows.

Peripheral device error The Slave device announces a peripheral device error.
That can be e.g. a short-circuit at the device outputs or an
under voltage.

Configuration error The ID code or the Length Code of the Slave device does
not correspond with the configured ID code or length code.

Reconfiguration The device announces a reconfiguration request.
Error interface 1 An error on the outgoing interface 1 was detected.
Error interface 2 An error on the outgoing interface 2 was detected.
Deactivated The Slave device is deactivated in the current

configuration and does not participate in the data
exchange.

Number of CRC errors This counter accumulates all detected check sum errors.
Length-/Ident-Code The real length code and ID code of the Slave device are

displayed here.
Online error The currently detected errors are displayed here.
Number of error registrations This value indicates the number of entries in the internal

error buffer.
Error table This table shows the detected errors in the occurred order.

Table 26: Meaning of the bits in the Device Diagnostic
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6.5.2 Global State Field
With the menu option Online > Global State Field opens a window in that
cyclically Statistic about the bus status and attached devices to be output.

Figure 58: Online > Global State Field

The first row displays the main state of the Master. It can have the state
OPERATE or STOP.
The next row displays individual bus errors. A pending error is displayed
with a red field. The meaning of the individual abbreviations is described in
the following.
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Status Bits Meaning

I2ER INTERFACE-2-ERROR: If this bit is set at least one remote bus interface
(called outgoing interface 2) of a Slave device was detected during the ID
scan, which has produced a timeout after it was opened in this session. This
error can only occur either at InterBus branch interface or at remote bus
devices, because both are having the outgoing interface 2 to connect it to
the next remote bus device. If more defective interfaces were detected at
the same time, the value shows the physically nearest Slave device to the
master in the InterBus ring.

I1ER INTERFACE-1-ERROR: If this bit is set at least one local bus interface or
remote bus branch interface (called outgoing interface 1) of a Slave device
was detected during the ID scan, which has produced a timeout after it was
opened in this session. This error can only occur at InterBus branch
interfaces, because these are the only components which have an interface
1 to manage InterBus branching. If more defective interfaces were detected
at the same time, the value shows the physically nearest Slave device to the
master in the InterBus ring.

NRDY HOST-NOT-READY-NOTIFICATION: indicates if the host program has set
its state to operative or stop. If this bit is set the host program is not ready to
communicate.

EVE EVENT-ERROR: The used InterBus master chip has detected at least one
transmission error. The number of detected events are counted in Number
of defective process data cycles and the error Number of network
reinintializations. The bit will be set when the first event was detected and
will not be cleared any more and remains set then.

PRHL PERIPHERAL-ERROR: Some InterBus modules have the capability to
indicate if they have detected low power or a short circuit in the in the
external periphery. If at least one module reports this error it is shown in this
bit. If all errors have disappeared, the bit will be released.

NEXC NON-EXCHANGE-ERROR: An activated bit indicates that at least one of
the configured Slave device is not operational because of a configuration
fault or simply because it's not present in the network.

ACLR AUTO-CLEAR-ERROR: This bit is set, when the master stops the
communication to all handled Slave devices because of missing Slave
devices. Before doing this the Master sets all output values of the left Slave
devices to the save zero condition. The behaviour, if the master shall shut
down or not, when it loses the contact to at least one device, is configurable
in SyCon configuration tool or in the bus parameter download procedure.
After the master has shut down only a warm- or cold start (reset) can
reactivate the communication again.

CTRL CONTROL-ERROR: Configuration error or heavy runtime error. Some of
them can occur during startup procedure of the master. For example if the
InterBus controller Ix1 of the master card do not respond or the
configuration of SyCon has inconsistencies.

Table 27: Meaning of collecting status bits in the Global State Field

Further displays are:
Error at device address and Corresponding error event indicate the
address of the faulty station and the actual error in plain text. Statistical bus
information indicates the number of the detected bus short-circuits and
rejected telegrams.
Devices specific status bits:
These display the parameterized devices, the active devices or the
devices with diagnostic according to the activated button. Pending
diagnostic information can be received by a double click on the respective
number of the station.
This display is cyclically updated.
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6.5.3 Extended Device Diagnostic
The Extended Device Diagnostic helps to find bus errors and configuration
errors when the SyCon menu functions are of no further help.
First select the Hilscher device with a left mouse click on the symbol of the
device. Then select the Online > Extended Device Diagnostic menu.

This menu opens a list of diagnostic structures. These contain online
counters, status information and parameter information:

Figure 59: Online > Extended Device Diagnostic

First the list for the InterBus Master and far down the list for the InterBus
Slave follows.

6.5.3.1 Extended Device Diagnostic for the InterBus Master
IBM_TASK: InterBus Administration

ALPMLIPD: Application interface (PCP Channel)

Task / Task State Page

PLC_TASK Common Variables 137
IBM_TASK Common Variables 138
IBM_TASK Device Running States 140
IBM_TASK Global State Field 140
IBM_TASK Communication Error 141
IBM_TASK Extended InterBus Status 142
IBM_TASK PDL Requests 143
IBM_TASK PDL Confirmation 144
IBM_TASK PDL Indication 145
IBM_TASK Data Cycle Status 145
IBM_TASK Scanned ID Codes 147
ALPMLIP Common Variables 148
ALPMLIPD ALI Information 150
ALPMLIPD PMS Information 151
ALPMLIPD LLI Information 152

Table 28: Extended Device Diagnostic for the InterBus Master
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6.5.3.2 Extended Device Diagnostic for the InterBus Slave

PLC_TASK
SUPI_TASK
ALI_TASK
Task / Task State Page

ALI_TASK Common Variables 153
PCL_TASK Common Variables 154
SUPI_TASK Common Variables 155
SUPI_TASK IBS Information 157
SUPI_TASK ALI Information 158
SUPI_TASK PMS Information 160
SUPI_TASK LLI Information 161
SUPI_TASK PDL Information 162

Table 29: Extended Device Diagnostic for the InterBus Slave
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6.5.4 Statistic Information
In the window Statistic Information a long-term recording of the InterBus
communication can be activated and deactivated. Occurred error
messages can be stored into a log file.

Figure 60: Online > Statistic Information

Under log file the path and the name of the file can be changed. The
recording is started by clicking the Start button.
If the Master is connected, the information about data cycles, ID scan
cycles, transfer errors and the transfer rate are displayed online.
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The following figure shows a faultless communication.

Figure 61: Online > Statistic Information (faultless)
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The following figure shows an error message to a data transfer with an
occurred communication error. The displayed figure shows an error
message of a cable interruption (cable disconnected and connected again).

Figure 62: Online > Statistic Information (error displayed)



SyConIB System Configurator InterBus Online Functions  �  87

Copyright � Hilscher Gesellschaft für Systemautomation mbH � Oi:SyConIB#6EN

6.6 User Data Transfer
The following table shows test functions with user data transfer and the
usability for

� Hilscher InterBus Master devices

� Hilscher InterBus Slave devices

User data transfer function Usage Usable with Hilscher
InterBus Master
devices

Usable with Hilscher
InterBus Slave devices

I/O Monitor Read input data and set output
data. (cyclic I/O data exchange)

Yes Yes

I/O Watch Read input data and set output
data. (cyclic I/O data exchange)

Yes No

PCP-Monitor Read or write data (objects) Yes No

Table 30: Overview User Data Transfer
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6.6.1 I/O Monitor
This is an easy way of displaying and changing the first 32 Bytes of the
process data image.

Figure 63: Online > I/O Monitor

DEC/HEX get the representation of the input data. The output data are
always in the decimal form.
Enter the output value and then press Update.
Always the first 32 input and output Bytes of the process data image are
shown, also when these Bytes have not been occupied by the
configuration.
The display is always in a Byte manner.
A more comfortable display is offered by the I/O Watch Monitor that is
described in the next section.
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6.6.2 I/O Watch
The I/O Watch monitor can be used in place of the I/O Monitor and offers
more functionality.

� Various data formats: Hex, Unsigned Decimal, Signed Decimal, Bit

� The I/O Watch monitor works symbol oriented

� It is not necessary to know the offset addresses

The following firmware supports the I/O Watch monitor function:
Fieldbus From Version

PROFIBUS-DP Master 1.040 (Combimaster) resp. 1.140 (DP-Master)
InterBus Master 2.040
CANopen Master 1.040
DeviceNet Master 1.058

Table 31: Firmware for I/O Watch function

The following table lists the typical steps to use the I/O Watch monitor.
Preconditions:

� The project/configuration already exists, containing an InterBus
Master and the InterBus Slave(s) as described in section Getting
Started – Configuration Steps on page 19.

� The Configuration has been downloaded into the InterBus Master
using Online > Download

� Running bus system

1. Open the existing project using File > Open.
2. Open the Windows dropdown menu and select Window > Logical

Network View to change the window. A window with three sections
opens

Left Window Center Window Right Window

Logical network view Tag list IO Watch

3. Open the tree structure in the left window to reach the I/O module of
the device desired:

Project > Master > Slave > Module > (possible) Submodule
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Figure 64: Logical Network View and I/O Watch

4. Left click on the module desired and the tags (I/Os) will be displayed in the
center window of the Logical Network View.
5. Select with the left mouse button the tag/symbol desired and drag

and drop them in the right window (I/O Watch) of the Logical Network
View.

6. In the right hand side window select the desired tag with the left
mouse click to highlight it then right mouse click to open a menu.
Select Start. A new window called I/O Watch appears.

7. A table shows the Device, Symbolic Name, IEC Address (Offset),
Data type Representation and Value.

8. Input data are displayed and can’t be changed. Output data can be
entered into the value column.
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Figure 65: I/O Watch Window

In the column representation can be selected the data type: Bit Pattern,
Char, Decimal Signed, Decimal Unsigned, Hex
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6.6.3 PCP-Monitor
With this function InterBus services based on the current configuration, can
be carried out.
First select the Master with a left mouse click on the Master device. Then
select Online > PCP Monitor.

Figure 66: Online > PCP Monitor

The Read or Write service on the desired Object can be selected by
means of the corresponding Communication reference and can be
activated via the Send button. When writing, the data must be entered in
the Value field. On the left side, the acknowledgement, or when reading,
the received data are displayed.

Note: Only Client functions are available in this version. Server functions
are not supported.
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Positive result:

Figure 67: Online > PCP Monitor (positive result)

Negative result:

Figure 68: Online > PCP Monitor (negative result)
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6.7 Message Monitor
The Message Monitor permits access to the Mailbox of the CIF.

Note: The usage of the Message Monitor assumes advanced knowledge
from the user.

First the Hilscher device must be chosen with a left mouse click on the
symbol of the Hilscher device. Then select the Online > Message Monitor
menu.

Figure 69: Online > Message Monitor

A Message can be saved and loaded and has the file extension *.MSG.
File > New: clears the window
File > Open: opens a Message (Message can be loaded)
File > Save or File > Save As: saves a Message
File > Exit: ends the Message Monitor and returns to the SyCon.
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Edit > Create answer: creates an answer Message
Edit > Reset counter: resets the Message counter

View > Review the received data: all received data are shown
View > Review the send data: all the send data are shown
View > Number of receipt errors: the number of the received errors is
shown
View > Decimal/Hexadecimal: Switch the display format

It is recommend to create a sub-directory MSG and to save the messages
in it.

Figure 70: Save a Message
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6.7.1 Message Monitor for Testing of PCP (Server)
In the following, the Message Monitor for reading and writing via PCP as a
server is described.
To read data over PCP from the Slave the following has to be set in the
Message Monitor. A reading message must have been transmitted before
from the Master to the Slave. The Slave creates its response as follows:
Message for Read via PCP

Message header
Rx = 1 (always) Tx = 255
Ln = (calculated) Nr = 0 .. 255
A = 17 F = 0
B = 0 E = 0
Telegram header Meaning for PCP Value range
Device Adr CR 2, 3 (2..63 for the Master)
Data Area unused 0
Data Address Object 15..65535
Data Index Index 0..240
Data Count Data Count 1 .. 240
Data Type Data Type 1..6, 9, 10
Function Read 1
Reading data
Fill in as many data as the value in data count

Table 32: Message Monitor - Example PCP Read

The following must be entered in the Message Monitor in order to write data
via PCP to a Slave. A writing message must have been transmitted before
from the Master to the Slave. The Slave creates its response as follows:
Message for Write via PCP

Message header
Rx = 1 (always) Tx = 255
Ln = (calculated) Nr = 0 .. 255
A = 17 F = 0
B = 0 E = 0
Telegram header Meaning for PCP Value range
Device Adr CR 2, 3 (2..63 by the Master)
Data Area unused 0
Data Address Object 15..65535
Data Index Index 0..240
Data Count Data Count 1 .. 240
Data Type Data Type 1..6, 9, 10
Function Write 2

Table 33: Message Monitor - Example PCP Write
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6.8 Control Active Configuration
In the menu Online > Control Active Configuration the communication
between Master and Slave can be switched on and off.
If the Master is selected (focus on Master) and the menu Online > Control
Active Configuration is called out, a selection list is displayed.

Figure 71: Online > Control Active Configuration

When the Slave is selected (focus on Slave) and the menu Online >
Control Active Configuration, no selection list is shown.

Note: If a bus branch interface is switched off, all attached InterBus Slave
devices are always switched off.

If groups were defined, these groups can be switched off or on.

Note: If the InterBus Slave device is assigned to a group, this group is
completely switched off.

Note: If a group contains alternatives, then only exactly one alternative of
this group can be turned on.
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7 File, Print, Export, Edit and View
7.1 File

7.1.1 Open
An existing project can be opened with File > Open.

7.1.2 Save and Save As
When the file name is known, then the configuration can be saved under
the File > Save menu, otherwise the File > Save As menu must be
selected.

7.1.3 Close
The current project can be closed with File > Close.
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7.2 Print
After the current printer has been selected in the File > Printer Setup
menu, the configuration can be printed out under the File > Print menu. For
a page view, select the File > Page View menu.

Figure 72: File > Print

Topology prints the topology of the Bus system.
Bus parameters prints the Bus parameters of the Bus system.
Address table prints the address table of the Master.
Device table prints the device table.
The scope can be given with the Device selection menu point. The
following can be chosen:

� All

� From station number to station number

� Selection of a device by means of its description
If no option is selected and the OK button is pressed nothing will be printed
out. It is like clicking the Cancel button.
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7.3 Export Functions

7.3.1 DBM Export
Select the File > Export > DBM menu in order to save the previously
saved project file (*.IB Microsoft Access Format) in a DBM file (Hilscher
binary format). This DBM file can be loaded in the DOS Compro program.
The configuration is stored in the Project directory in the path of the SyCon
installation with the extension *.DBM.

Attention: The file name can have max. 8 characters.

7.3.2 CSV Export
With the menu File > Export > CSV the configuration data of the
connected Slaves can be exported into a table.
Requirement is that the configuration was saved before the export is
executed. The exported file has the ending .csv (comma separated value)
and is taken off in the same directory as the configuration, but with the
ending *.csv.
The CSV file can be read with a table program like for example Excel.
The CSV Export saves only the text and the values of the configured
Slaves. The meaning of the individual values can be shown in the table.
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Here is the description of the parameters:
Parameter Meaning

Stationaddress The Stationaddress is the unique device address of the Slave on the
bus.

RecordType The RecordType defines the version of the following structure and is
always 2.

IdentNumber This number is the unique device number of the Slave.
VendorNumber The Vendor Number is the clear number of the vendor (if available).
VendorName Here the name of the vendor is shown (max. 32 characters).
Device Name of the device (max. 32 characters).
Description This is the description of the device, which is set by the user (max. 32

characters).
MasterAddress This is the number of the Master Address, where the devices are

related to.
Settings Contains information about the addressing mode and the storage

format of the process data (words, double words and floats) see
section Description of the Parameter Settings.

Reserved reserved
ModulCount Number of the modules of the device. For each module the parameters

data type, data size, data position and offset address are given. It can
be follow max 60 modules. The parameters for module 1 are marked
with ..._0 and of the module 60 are marked with ..._59.

DataSize_0 Number of bytes, which were used by the module.
DataType_0 The DataType, which is used in the configuration. The code for this

you find below this table in section Description of the Parameter
DataType.

DataPosition_0 The byte Data Position, which is used in the configuration. The code
for this you find below this table in section Description of the
Parameter DataPosition.

Address_0 Offset Address in the Dual-port memory
... ...
DataSize_59 if used, see at the top
DataType_59 if used, see at the top
DataPosition_59 if used, see at the top
Address_59 if used, see at the top

Table 34: CSV Export - Meaning of the values
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7.3.2.1 Description of the Parameter Settings
D7 D6 D5 D4 D3 D2 D1 D0

Reserved Area Format Address Mode

0 byte Address
1 word Address

1 little Endian (LSB/MSB)
0 big Endian (MSB/LSB)

reserved
Table 35: CSV-Export - Description of the Byte Settings

7.3.2.2 Description of the Parameter DataType
D7 D6 D5 D4 D3 D2 D1 D0

SubFlag Data Direction Data Format
according EN standard
0 blank space
1 Boolean
2 Integer 8
3 Integer 16
4 Integer 32
5 Unsigned Integer 8
6 Unsigned Integer 16
7 Unsigned Integer 32
8 Float
9 ASCII
10 String
14 Bit

0 empty space
1 input
2 output

0 start of a module
1 sub module

Table 36: CSV Export > DataType Code

7.3.2.3 Description of the Parameter DataPosition
D7 D6 D5 D4 D3 D2 D1 D0

Reserved Area Bit Position
Bit Position of the Offset Address

reserved
Table 37: CSV Export > DataPosition Code



104  �  File, Print, Export, Edit and View SyConIB System Configurator InterBus

Copyright � Hilscher Gesellschaft für Systemautomation mbH � Oi:SyConIB#6EN

7.3.2.4 Example of a CSV file

Example of a CSV file which was exported in Excel:

Figure 73: Example of a CSV File in Excel

Cell Parameter Value Meaning

A1 StationAddress 2 Station address of the InterBus Slave device.
B1 RecordType 2 The Record Type is always 2.
C1 IdentNumber 3 Ident Number of the Slaves.
D1 VendorNumber 21 The Vendor Number is 21.
E1 VendorName Hilscher GmbH Vendor name of the device.
F1 Device CIF30-IBS Description of the device.
G1 Description Device0 Description of the device which is also shown in SyCon as the name

of the device.
H1 MasterAddress 255 Address of the related Master.
I1 Settings 0 The addressing mode (byte- or word addressing) and the data format

of the process data are shown. The description you see in section
Description of the Parameter Settings.

J1 reserved reserved reserved
K1 ModulCount 2 Number of the modules of the device. For each module the

information with data type, data size, data position and the offset
address follow. The information for
module 1 you find in the cells L1, M1, N1, O1 and for
module 2 in the cells P1, Q1, R1, and S1.

L1 DataSize 20 The size of the module is 20 bytes.
M1 DataType 21 Input; Data type unsigned Integer 8
N1 DataPosition 0 Output; Data type unsigned Integer 8
O1 Offsetaddress 0 4 Byte-Module starting with the offset address 0.
P1 DataSize 20 The size of the module is 20 bytes.
Q1 DataType 37 Output; Data type unsigned Integer 8
R1 DataPosition 0 Data position of the second module.
S1 Offsetaddress 0 4 Byte-Module starting with the offset address 0.
T1...IQ1 ... 0 The modules 3 till 59 are not used for this device and so a 0 is

shown.

Table 38: Example of a CSV file in Excel

If two or more Slave devices are connected to the Master, these are
displayed in the next lines of the table.
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7.4 Import Functions

7.4.1 CMD Import
SyCon offers the possibility of importing a project from project engineering
and diagnostic program IBS CMD G4 of the company Phoenix Contact
GmbH. This project must be present in an ASCII file (*.CSV).

The ASCII file can be produced in IBS CMD G4 with the following steps:
� Parameter memory select: With one mouse click on the appropriate

symbol you select the parameter memory.

� ASCII file produce: With the menu Configuration > ASCII file write
> project files (*.CSV) the production of the ASCII file are initiated.
All control fields of the dialog must remain activated.

� Format of the ASCII file determine: With CSV-options the desired
format of the ASCII file is determined.

For the import of the ASCII file in the SyCon the following steps are
necessary:
� Create new project: With the menu File > New and the selection of

the InterBus a new project is produced.

� Masters select: With the menu Insert > Master the Master is
selected.

� ASCII file import: With the menu File > Import > CMD the import is
started.

Figure 74: File > Import > CMD
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After selection of the ASCII file which can be imported you must indicate
the adjustments for the format of the file, made in IBS CMD G4.

Figure 75: File > Import > CMD (Settings IBS CMD G4)

Close the window with the button OK, if the import is to be started. Close
the window with Cancel, if no import is to be made.
With the import the System Configurator assigns a suitable EDS file to each
Slave device.
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7.5 Edit

7.5.1 Cut, Copy and Paste
With Edit > Cut and Edit > Copy you put the cut/copied Slave device with
its settings and configuration (only not the description of the device) in the
Clipboard and with Edit > Paste it can be insert.
The difference between Cut and Copy is:
With the menu option Edit > Cut you move a Slave device from one point
in the configuration to another. With the menu option Edit > Copy you
duplicate an existing Slave device.
If you select Edit > Cut a security question appears.

Figure 76: Security question cut device

If you answer this question with Yes the Slave device is cut and stays in the
clipboard.
When you select Edit > Paste the device can be insert again at the position
you want.

Possible insert positions are displayed with a colored circle . If you
move the mouse pointer over this circles it changes into one of these
symbols dependent on which Slave device was cut or copied.
Mouse pointer - possible insert positions

Remote Bus Branch
Interface

Local Bus Branch
Interface

Remote Bus Device Local Bus Device

Table 39: Mouse pointer - possible insert positions
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Figure 77: Paste a Slave device in the configuration

Click on the position where the Slave is to be inserted. A window opens
where the cut/copied Slave device can be selected.

Figure 78: Edit > Paste Insert Device from Clipboard

With the OK button the Slave will be insert.
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7.5.2 Delete
To delete the Master or a Slave device you have to have to mark this
device and then select the menu Edit > Delete. Before SyCon deletes the
Master or a Slave a security question appears.

Figure 79: Security question delete device

Note: When you delete a device the settings and the configuration of this
device get lost.

7.5.3 Replace
With the menu Edit > Replace the Master or a Slave device can be
replaced. How to replace the Master look in section Replace Master at
page 30. If you want to replace a Slave device look in section Replace
Slave at page 37.
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7.5.4 Assign EDS File
With the menu Edit > Assign EDS File the following window appears:

Figure 80: Edit > Assign EDS File

In this window you are able to assign an existing EDS file to a Slave device
which was scanned before (Scan with Automatic Network Scan see at page
73).
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7.6 View of the Configuration
The configuration can be displayed in a table. The following tables are
available:

� Device Table

� Address Table (Occupation of the process image memory in the
Hilscher InterBus Master )

7.6.1 Device Table
The View > Device Table menu shows the list of all devices which are
used in the configuration.

Figure 81: View > Device Table
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7.6.2 Address Table
A list of all addresses used in the process data image is displayed in the
View > Address table menu.

Figure 82: View > Address Table

It is possible to sort the addresses according to Slave numbers or data
addresses.
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7.7 View Menu SyCon

7.7.1 Logical Network View
In the menu View > Logical Network View the user can activate or
deactivate the network view by selecting it (with hook) or by not selecting it
(without hook).
The network view is used for example for the Start Options.

7.7.2 Toolbars
In the menu View > Toolbars the user has the possibility to activate or
deactivate the Toolbars Standard and Fieldbus. If this function is
deactivated the toolbars are not shown.

7.7.3 Status Bar
In the menu View > Status Bar this bar can be activated (with hook) or
deactivated (without hook).
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8 Tools
8.1 EDS Viewer

The menu Tools > EDS Viewer opens an EDS file to view it.

Figure 83: Tools > EDS Viewer

ID-Code, Length Code, input length and output length are not displayed, if
the device supports several ID- and Length Codes.
The following device types are available:

� Remote Bus Branch Interface

� Local Bus Branch Interface

� Remote Bus Device

� Local Bus Device
The button Layout displays the assigned figures of the device (see section
Layout on page 117).
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8.2 EDS Generator
If an InterBus device is not contained into the provided EDS files, the
appropriate EDS file can be produced with Tools > EDS Generator.

Figure 84: Tools > EDS Generator

In this window the device-specific data must be filled in. See manual of this
device. The two most important parameters are the Length Code and the
ID-Code, which are also imprinted on the devices normally. Both guarantee
that the Slave device is detected in the network.
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8.3 Layout
On the basis of Tools > EDS Viewer or Tools > EDS Generator the
current course arranging of bitmaps of the device can be seen.
The bitmaps of the device for
� Configuration Phase (typical colour grey),

� Operating Phase (typical colour: green),

� Diagnostic Phase (typical colour: red)
are displayed.

Figure 85: Layout for Tools > EDS Viewer or Tools > EDS Generator
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8.4 PKV 40 Gateway
The Tools menu for the PKV40 is described in an own operating manual.
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9 Error Numbers
9.1 CIF Device Driver (Dual-port memory) Error Numbers (-1

.. -49)
This is the list of error numbers of dual-port memory access using the CIF
Device Driver.
Error Number Description

-1 Driver: Board not initialized
The communication board is not initialized by the driver.
No or wrong configuration found for the given board, check the driver
configuration.
Driver function used without calling DevOpenDriver() first.

-2 Driver: Error in internal ‘Init state‘
-3 Driver: Error in internal ‘Read state‘
-4 Driver: Command on this channel is active
-5 Driver: Unknown parameter in function occurred
-6 Driver: Version is incompatible

The device driver version does not correspond to the driver DLL version.
From version V1.200 the internal command structure between DLL and
driver has changed. Make sure to use the same version of the device
driver and the driver DLL.

-10 Device: Dual port memory RAM not accessible (board not found)
Dual-ported RAM (DPM) not accessible / no hardware found.
This error occurs, when the driver is not able to read or write to the Dual-
port memory.
Check the BIOS setting of the PC Memory address conflict with other PC
components.
Try another memory address, check the driver configuration for this
board, and check the jumper setting of the board.

-11 Device: Not ready (RDY flag=Ready flag failed)
Board is not ready. This could be a hardware malfunction or another
program writes inadmissible to the dual-port memory.

-12 Device: Not running (RUN flag=Running flag failed)
The board is ready but not all tasks are running, because of an
initialization error. No data base is loaded into the device or a wrong
parameter can causes that a task can't initialize.

-13 Device: Watch dog test failed
-14 Device: Signals wrong Operating System version

No license code found on the communication board. Device has no
license for the used operating system or customer software. No firmware
or no data base to the device is loaded.

Table 40: CIF Device Driver Error Numbers (-1..-14)
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Error Number Description

-15 Device: Error in dual port memory flags
-16 Device: Send mailbox is full
-17 Device: Function PutMessage timeout

No message could be send during the timeout period given in the
DevPutMessage() function.
If you use an interrupt, check the interrupt on the device and in driver
setup. These settings have to be the same! Is an interrupt on the board
set? Is the right interrupt set? The interrupt could already be used by
another PC component, also if the operating system reports it as
unused.
If you use polling mode, then make sure that no interrupt is set on the
board and that polling is set in the driver setup. These settings have to
be the same!
Device internal segment buffer full and therefore PutMessage() function
is not possible, because all segments on the device are in use. This
error occurs, when only PutMessage() is used but not GetMessage().
HOST flag is not set for the device. No messages are taken by the
device. Use DevSetHostState() to signal a board an application is
available.

-18 Device: Function GetMessage timeout
No message received during the timeout period given in the
DevGetMessage() function.
If you use an interrupt, then check the interrupt on the device and in
driver setup. These settings have to be the same! Is an interrupt on the
board set? Is the right interrupt set? The interrupt could already be used
by another PC component, also if the operating system reports it as
unused.
If you use polling mode, then make sure that no interrupt is set on the
board and that polling is set in the driver setup. These settings have to
be the same!
The used protocol on the device needs longer than the timeout period
given in the DevGetMessage() function.

-19 Device: No message available

Table 41: CIF Device Driver Error Numbers (-15..-19)
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Error Number Description

-20 Device: Reset command timeout
The board is ready but not all tasks are running, because of an
initialization error. No data base is loaded into the device or a wrong
parameter can causes that a task can't initialize.
The device needs longer than the timeout period given in the DevReset()
function. Using device interrupts. The timeout period can differ between
fieldbus protocols.
If you use an interrupt, then check the interrupt on the device and in
driver setup. These settings have to be the same! Is an interrupt on the
board set? Is the right interrupt set? The interrupt could already be used
by another PC component, also if the operating system reports it as
unused.
If you use polling mode, then make sure that no interrupt is set on the
board and that polling is set in the driver setup. These settings have to
be the same!

-21 Device: COM flag not set
The device can not reach communication state. Device not connected to
the fieldbus. No station found on the fieldbus. Wrong configuration on
the device.

-22 Device: IO data exchange failed
-23 Device: IO data exchange timeout

The device needs longer than the timeout period given in the
DevExchangeIO() function.
If you use an interrupt, then check the interrupt on the device and in
driver setup. These settings have to be the same! Is an interrupt on the
board set? Is the right interrupt set? The interrupt could already be used
by another PC component, also if the operating system reports it as
unused.
If you use polling mode, then make sure that no interrupt is set on the
board and that polling is set in the driver setup. These settings have to
be the same!

-24 Device: IO data mode unknown
-25 Device: Function call failed
-26 Device: Dual-port memory size differs from configuration
-27 Device: State mode unknown

Table 42: CIF Device Driver Error Numbers (-20..-27)
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Error Number Description

-30 User: Driver not opened (device driver not loaded)
The device driver could not be opened. Device driver not installed.
Wrong parameters in the driver configuration. If the driver finds invalid
parameters for a communication board and no other boards with valid
parameters are available, the driver will not be loaded.

-31 User: Can’t connect with device board
-32 User: Board not initialized (DevInitBoard not called)
-33 User: IOCTRL function failed

A driver function could not be called. This is an internal error between
the device driver and the DLL. Make sure to use a device driver and a
DLL with the same version. An incompatible old driver DLL is used.

-34 User: Parameter DeviceNumber invalid
-35 User: Parameter InfoArea unknown
-36 User: Parameter Number invalid
-37 User: Parameter Mode invalid
-38 User: NULL pointer assignment
-39 User: Messagebuffer too short
-40 User: Size parameter invalid
-42 User: Size parameter with zero length
-43 User: Size parameter too long
-44 User: Device address null pointer
-45 User: Pointer to buffer is a null pointer
-46 User: SendSize parameter too long
-47 User: ReceiveSize parameter too long
-48 User: Pointer to send buffer is a null pointer
-49 User: Pointer to receive buffer is a null pointer

Table 43:CIF Device Driver Error Numbers (-30..-49)

Error Number Description

1000 If the operating system of the device reports an initialization error, then a
value of 1000 will be add to the error number and shown to the user

Table 44: CIF Device Driver Error Numbers (1000)
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9.2 CIF Serial Driver Error Numbers (-20 .. -71)
This is the list of error numbers using the serial driver.
Error Number Description

-20 Driver: No COM port found or COM port already in use.
-21 Driver: COM port already opened
-22 Driver: Function call into driver has failed
-23 Driver: Internal driver error
-24 Driver: Could not create read thread
-25 Driver: Could not create read event
-26 Driver: Could not create write event
-27 Driver: Could not create timer event
-28 Driver: Error by writing data
-29 Driver: Wrong COM state
-30 Driver: COM state error is set
-31 Driver: COM buffer setup failed
-32 Driver: COM set timeout failed
-33 Driver: Receive buffer overrun
-34 Driver: Receive buffer full
-35 Driver: Send busy
-36 Driver: Error during close driver
-40 User: COM port not opened
-41 User: Invalid handle value
-42 User: Invalid COM number
-43 User: Size parameter invalid
-44 User: Size parameter zero
-45 User: Buffer pointer is NULL
-46 User: Buffer too short
-47 User: Setup error

Table 45: CIF Serial Driver Error Numbers (-20..-47)
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Error Number Description

-50 User: Send message, timeout error
-51 User: Could not send a message

Cable not connected.
Wrong cable.
Device does not respond.

-52 User: Send message, no device connected
-53 User: Error by send message, message receiving
-54 User: Telegram collision
-55 User: Telegram, no acknowledgement received
-56 User: Telegram, noise
-57 User: Telegram, data overrun
-58 User: Telegram, parity error
-59 User: Telegram, framing error
-60 User: Telegram, unknown error
-70 User: Timeout by receive a message
-71 User: No message received

Table 46: CIF Serial Driver Error Numbers (-20..-47)
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9.3 CIF TCP/IP Driver Error Numbers
This is the list of error numbers using the CIF TCP/IP Driver.

9.3.1 Standard Win32 Socket API Errors
Error Number Description

10013 Permission denied
10024 Too many open sockets.
10048 Address already in use
10049 Cannot assign requested address.
10050 Network is down
10051 Network is unreachable
10052 Network dropped connection on reset
10053 Software caused connection abort. An established connection was

aborted by the software in your host machine, possibly due to a data
transmission time-out or protocol error.

10054 Connection reset by peer
10055 No buffer space available
10056 Socket is already connected
10057 Socket is not connected.
10058 Cannot send after socket shutdown
10060 Connection timed out
10061 Connection refused
10065 No route to host
10092 Winsock.dll version out of range

Table 47: CIF TCP/IP Driver Error Numbers - Standard Win32 Socket API errors

9.3.2 Specific NetIdent Errors
Error Number Description

0x8004c701 Unknown Device Error
0x8004c702 Request Pending
0x8004c703 Set IP time exceeded
0x8004c704 IP address invalid
0x8004c705 Returned IP address invalid
0x8004c706 Answer from wrong device
0x8004c707 Wrong OP code received
0x8004c708 NetIdent Timeout

Table 48: CIF TCP/IP Driver Error Numbers - Specific NetIdent Errors
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9.4 RCS Error Numbers (4 .. 93)
This is the list of error numbers returned by the RCS (Realtime
Communication System), that is the operating system of Hilscher devices.
The error number is returned in an answer message. Command messages
and answer messages are used to communicate between the application
(e.g. the System Configurator) and the Hilscher device. An example of this
communication is the download of a configuration.
Error Number Description

4 Task does not exist
5 Task is not initialized
6 The MCL is locked
7 The MCL rejects a send command because of an error
20 The user will download a database into the device that is not valid for

this device type.
21 Data base segment not configured or not existent
22 Number for message wrong during download
23 Received number of data during download does not match to that in the

command message
24 Sequence identifier wrong during download
25 Checksum after download and checksum in command message do not

match
26 Write/Read access of data base segment
27 Download/Upload or erase of configured data base type is not allowed
28 The state of the data base segment indicated an error. Upload not

possible
29 The access to the data base segment needs the bootstraploader. The

bootstraploader is not present
30 Trace buffer overflow
31 Entry into trace buffer too long
37 No or wrong license. The OEM license of the System Configurator

allows only communication to devices that have the same license inside
38 The data base created by the System Configurator and the data base

expected by the firmware is not compatible
39 DBM module missing

Table 49: RCS error numbers (answer message) (4..39)
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Error Number Description

40 No command free
41 Command unknown
42 Command mode unknown
43 Wrong parameter in the command
44 Message length does not match to the parameters of the command
45 Only a MCL does use this command to the RCS
50 FLASH occupied at the moment
51 Error deleting the FLASH
52 Error writing the FLASH
53 FLASH not configured
54 FLASH timeout error
55 Access protection error while deleting the FLASH
56 FLASH size does not match or not enough FLASH memory
60 Wrong structure type
61 Wrong length of structure
62 Structure does not exist
70 No clock on the device
80 Wrong handle for the table (table does not exist)
81 Data length does not match the structure of this table
82 The data set of this number does not exist
83 This table name does not exist
84 Table full. No more entries allowed
85 Other error from DBM
90 The device info (serial number, device number and date) does already

exist
91 License code invalid
92 License code does already exist
93 All memory locations for license codes already in use

Table 50: RCS error numbers (answer message) (40..93)
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9.5 Database Access Error Numbers (100 .. 130)
The following table lists the error numbers of the database access errors
Error Number Description

100 Database already opened
101 Dataset could not be opened
103 Error while opening database occurred
104 No valid path name
105 No connection to data base. Call function DbOpen().
106 Error in parameter
107 Error during opening a table
108 Nullpointer occurred
109 Table not opened. Call function OpenTable() first.
110 The first record is reached
111 The last record is reached
112 Unknown type in the record found
113 Data has to be truncated
114 No access driver installed on the system
115 Exception received
116 This table is set to read only
117 There is no data set in the table
118 The requested table could not be edit
119 An operation could not be completed
120 User gives an unexpected length in WritsDs().
121 An assertion failed
122 DLL not found
123 DLL couldn't be freed
124 Specified function not found in the DLL
125 ODBC Function returns an error
126 Count of data bytes in the record exceeds 1938
127 DBM32 DLL is not loaded
128 Field with the given index was not found
129 This table contains no records
130 Invalid character (' ') found in a Table or Column

Table 51: Database Access Error Numbers (100..130)
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9.6 Online Data Manager Error Numbers

9.6.1 Online Data Manager Error Numbers (1000 .. 1018)
The following table lists the error numbers of the Online Data Manager.
Error Number Description

1000 Driver OnlineDataManager not opened
1001 Initialization of the OnlineDataManager has failed
1002 No DriverObject found. OnlineDataManager Sub DLL not found.
1003 No DeviceObject found. Device not found.
1004 Application not found
1010 Application has requested an unknown event
1011 Application has requested an unknown function mode, operating mode.

Known function modes, operating modes are Reset, Download, Register
Server, Unregister Server.

1012 Application has requested an unknown command
1013 Message Server already exists
1014 Message Server not registered
1015 Device already in use
1016 Device not assigned
1017 Device has changed
1018 Command active

Table 52: Online Data Manager Error numbers (1000..1018)

9.6.2 Message Handler Error Numbers (2010 .. 2027)
The following table lists the error numbers of the Message handler of the
Online Data Manager.
Error Number Description

2010 Message handler: Messagebuffer empty
2011 Message handler: Messagebuffer full
2021 Message handler: Invalid Message ID (msg.nr)
2022 Message handler: No entry
2023 Message handler: Message already active
2024 Message handler: Wrong Application
2025 Message handler: Message Timeout
2026 Message handler: Wait for Delete
2027 Message handler: No cyclic Message

Table 53: Error Numbers of the Message Handler of the Online Data Manager (2010..2027)
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9.6.3 Driver Functions Error Numbers (2501 .. 2512)
The following table lists the error numbers of the Driver Functions of the
Online Data Manager.
Error Number Description

2501 OnlineDataManager Sub DLL not found
2502 Function missing
2503 'Read Thread' not created
2504 'Write Thread' not created
2505 'IO Thread' not created
2510 Function failed
2512 Assign reports error. Return neither OK or cancel

Table 54: Error Numbers of the Driver Functions of the Online Data Manager (2501..2512)

9.6.4 Online Data Manager Sub functions Error Numbers (8001 ..
8035)

The following table lists the error numbers of the Sub functions of the
Online Data Manager.
Error Number Description

8001 Driver not opened. E.g. CIF Device Driver
8002 Application has requested an unknown event
8003 Application has requested an unknown command
8004 Command has failed
8005 Command active
8006 Device invalid
8010 No device was assigned
8011 Device was already assigned
8020 Driver not connected
8021 Driver already connected
8030 Faulty 'GetState'
8031 Send error (PutMessage returns error)
8032 Send active (PutMessage active)
8033 Receive error (GetMessage returns error)
8034 Receive active (GetMessage active)
8035 IO Error (ExchangeIO returns error)

Table 55: Sub function Error Numbers of the Driver Functions of the Online Data Manager
(8001..8035)
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9.7 Data Base Functions Error Numbers (4000 .. 4199)
The following table lists the error numbers of the converting functions.
Error Number Description

4000 File does not exist
4001 Success in compromising
4002 Dataset does not exist
4003 Last respectively first entry reached
4004 Not enough memory
4005 File directory full
4006 Max number of entries reached
4007 No writing to this table possible, because the table is located in the

FLASH
4008 Table name does already exist
4009 File name does not exist
4010 Free RAM length from RCS_CNF.P86 is smaller than E_F_INDEX * 2
4011 Parameter ‘next’ wrong
4012 Not enough free space to copy data set
4013 Set is deleted
4014 Value for Index is wrong
4015 Access not allowed
4016 open_file used before init_file
4017 Drive is not ready
4018 Not enough drive memory
4019 File name or path does not exist
4020 Cannot create path
4021 Wrong path
4022 Wrong flag
4023 The delete path is the root path
4024 Path file exists
4025 Write error during write a file
4026 Error during create a file
4027 Error during close a file
4028 No DBM file
4029 Length of the read data is unequal of the file length

Table 56: Error numbers of converting functions (4000..4029)
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Error Number Description

4030 Path too long
4031 Directory changed
4032 Directory created
4034 Length of converting stream is 0
4035 Non equal data set found
4036 Non equal data set found
4037 Non equal data set found
4038 Data set has length 0
4039 The function DbmInit has assigned a Zero pointer during RCS

initialization
4040 Printer not ready
4041 The data base is used from another function
4042 New length of data base is smaller than used
4043 Unknown access mode
4044 Old data base has to be converted
4045 Error while converting. Function not known
4046 Unknown type in set 0 found
4047 No float function available
4048 Function not in RCS module
4049 Check failed
4050 Checksum check failed
4051 More segments are existing in file, than in the structure FILE_INFO_T in

wMaxEintraege
4052 SegLen in structure FILE_INFO_T is smaller then the length in the file.

Return of function dbm_restore_data
4053 The header file holds an other information for a length than in the

segment itself
4054 Not enough memory for allocation on the PC
4055 No index for file handle in structure FLASH_DIR of RCS found
4057 File type 2 can not be printed because of too many definitions
4058 The definitions need too many lines to display them, than in the program

available
4059 An unknown format for the parameter. Valid is U, H, or S
4060 Unknown parameter type

Table 57: Error numbers of converting functions (4030..4060)
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Error Number Description

4061 The data base was transmitted into the FLASH
4062 Set 0 contains no structure definition
4063 Set 0 can not be deleted
4064 Error during execution of a ODBC data base access
4065 Initializing of DBM through RCS had no success
4066 Passed data length incorrect
4067 Sorting function not linked
4068 Error in function parameter
4069 Error from ODBC table
4070 No free handle available. Too many data base links are already opened
4071 Unknown data type found in the table
4072 Structure of table GLOBAL not correct or no such table existing
4073 No name of an ACCESS data base
4074 Download window can’t be created
4075 Download not fully performable

Table 58: Error numbers of converting functions (4061..4075)
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Error Number Description

4082 More than 32 tables should be created
4083 No entry in element szSourceFile
4084 ODBC connection initialization not possible. This could happen when in

file ODBCINST.INI in section [Microsoft Access Driver (*.mdb)] is no
valid path to ODBCJT16/32.DLL.

4085 Error in structure in the ACCESS data base that is in DBM format
4086 Error in structure in the ACCESS data base that is in DBM format
4087 No data in a ODBC table
4088 No entry
4089 ODBC set length not valid
4090 Not enough data sets in ODBC table
4091 Table CreateTab not found
4092 Error in structure of table CreateTab
4093 No entry in element szSourceTable
4094 No entry in element szDestTable
4095 Entry in iSourceType of table CreateTab is wrong
4096 Entry in iTranslate of table CreateTab is wrong
4097 Function SQLAllocStmt reports an error
4098 ODBC source table not found
4099 ODBC data truncated
4100 Download timeout
4101 Library load error
4102 Library function error
4103 Error in description 'toggle'
4104 Error in description 'KB'
4105 Column does not exists
4106 ODBC structure different
4107 ODBC address error
4108 No CRC sum exists (table GLOBAL exists or old)
4109 Table GLOBAL is old
4110 Calculated CRC different to CRC in table GLOBAL
4199 Programming error

Table 59: Error numbers of converting functions (4082..4199)
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9.8 Converting Functions Error Numbers (5001 .. 5008)
The following table lists the error numbers of converting functions.
Error Number Description

5000 Function PackLongToByteShort: Not enough space in pvD (Number of
elements greater than reserved memory)

5001 Function PackLongToByteShort: Not enough space in pvD. Detected
during converting of pvS

5002 Function PackLongToByteShort: Not enough space in pvD
5003 Function StringToByte: Not enough space in pvD
5004 Function IntToByte: Not enough space in pvD
5005 Function LongToShort: Not enough space in pvD
5006 Function PackStringDumpToByteArray: Not enough space in pvD
5007 Function PackStringDumpToByteArray: A character was found, which is

not convertible into a HEX value
5008 Function PackStringDumpToByteArray: Number of character odd
5009 Function PackStringDumpToByteArray: Not enough space in pvD
5010 Function PackStringDumpToByteArray: The current data set needs to be

appended the previous one
5011 Function PackStringDumpToByteArray: No corresponding function to the

given number exist
5012 Converting error

Table 60: Error Numbers of data base functions (5000 .. 5012)
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10 Appendix
10.1 Extended Device Diagnostic Master

On the following pages the task state structures of the InterBus Master are
described.

10.1.1 PLC_TASK Common Variables

Figure 86: PLC_TASK Common Variables

Variable Meaning

Version Compiled Hardware
Task State Task State
Handshake
Counter

Counter for the performed process data hand shakes

Handshake Mode This value represents the actual handshake mode between
application and CIF.
0 = Bus synchronous, Device Controlled
1 = Buffered, Device Controlled
2 = Uncontrolled
3 = Buffered, Host Controlled
4 = Bus synchronous, Host Controlled

Table 61: Meaning of Variables
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10.1.2 IBM_TASK Common Variables

Figure 87: IBM_TASK Common Variables

Configuration State Meaning

Configured devices number of device that are actual configured
Wrong configured devices the master executes a consistency check of each Slave

parameter set and increments this counter by each found
faulty data set

Connected remote bus
devices

this value shows the actual number of scanned remote
bus device in the connected network.

Projected remote bus devices this value indicates the number of configured remote bus
devices the master wants to run with.

Turned off remote bus
devices

in case of configuration faults, like wrong ID code for
example, the master deactivates these network
components. The number of disabled device is indicated
here. The value should normally be 0.

Connected local bus devices this value shows the actual number of scanned local bus
device in the connected network.

Projected local bus devices this value indicates the number of configured local bus
devices the master wants to run with.

Turned off local bus devices in case of configuration faults, like wrong ID code for
example, the master deactivates these network
components. The number of disabled device is indicated
here. The value should normally be 0.

Defective I1-Interfaces for each timeout causing branch interface of the network
this counter is incremented. The value should normally be
zero, else check the network visual and search for red LB-
LEDs on the modules. This indicates the defective
interface module.

Defective I2-Interfaces for each timeout causing remote interface of the network
this counter is incremented. The value should normally be
zero, else check the network visual and search for red RB-
LEDs on the modules. This indicates the defective
interface module.
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Counter of data cycles this value shows the actual number of driven process data
cycles since the last master reset.

Counter of ident cycles this value is normally incremented during the startup
phase of the InterBus network when the master does its
management ID-sequence. If the counter increments
during runtime, then the master has to proceed some
extra ID-sequences because of defective data cycles. So
normally the value shouldn’t increment.

No. of shifting process bits the master adds up here the number of actual shifted
process data bits of all active devices.

Error detected in line the master code has special debug information included,
which shows in case of a hard communication to the
fieldbus controller at which source code line the error
happened.

IX1 response status this value represents the actual confirmation command of
the fieldbus controller. During runtime the value is 48hex
which indicates ‘Start data cycle confirmation’.

SetConf service counter during the management ID-sequence startup phase of the
network. The values should normally be zero.

DataCycle service counter here the master counts all InterBus process data cycle
errors which forced him to leave the process data
exchange and need to drive an extra management ID
cycle to search for the error location. The data errors as
well as CRC errors and module errors are errors which
can occur normally during runtime because of electrical
disturbance. These kinds of errors can be corrected by the
master and influences the process data exchange in case
of moderate occurrence only a little. But the system errors
which mean timeout in the incoming process data stream,
or loop errors which means the InterBus ring was
shortened, forces the master to go into stop and resets the
network.

SetConf, CheckConf,
DataCycle and Get Conf
counter

These counter are incremented only if the Master detects
heavy communication errors. These values should
normally be zero.

Table 62: Configuration State
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10.1.3 IBM_TASK Device Running States

Figure 88:IBM_TASK Device Running States

Variable Meaning

Device x (x=0..128) Textural state for station address

Table 63: IBM_TASK Device Running States

10.1.4 IBM_TASK Global State Field
See section Global State Field on page 80.
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10.1.5 IBM_TASK Communication Error

Figure 89: IBM_TASK Communication Error

Variable Meaning

Slave x (x=0..128) Actual error number of the Slave

Table 64: IBM_TASK Communication Error
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10.1.6 IBM_TASK Extended InterBus Status

Figure 90: IBM_TASK Extended InterBus Status

The extended InterBus status displays special variables, which are stored
directly after the first ID cycle. These values can help networks errors in
special cases in again installed InterBus to localize. These values can be
interpreted just with our Hotline and because of this they are not described
here furthermore.
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10.1.7 IBM_TASK PDL Requests

Figure 91: IBM_TASK PDL Requests

The Peripherals Data Link (PDL) layer is part of Data Link Layer (DLL)
which is responsible for the safety transmission of data packages trough
the PCP protocol and ensures that each PDL message is transported to the
other remote station without any error.
The Counter for PDL Requests counts for each Slave the number of sent
PDL service data units from the master to a PCP capable Slave device.
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10.1.8 IBM_TASK PDL Confirmation

Figure 92: IBM_TASK PDL Confirmation

The Peripherals Data Link (PDL) layer is part of Data Link Layer (DLL)
which is responsible for the safety transmission of data packages trough
the PCP protocol and ensures that each PDL message is transported to the
other remote station without any error.
The Counter for PDL Confirmations counts for each Slave the number of
confirmed PDL service data units which were previously sent by the master
as requests.
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10.1.9 IBM_TASK PDL Indication

Figure 93: IBM_TASK PDL Indication

The Peripherals Data Link (PDL) layer is part of Data Link Layer (DLL)
which is responsible for the safety transmission of data packages trough
the PCP protocol and ensures that each PDL message is transported to the
other remote station without any error.
The Counter for PDL Indications counts for each Slave the number of
received PDL service data units which were sent by a PCP capable Slave
device to the master. Usually an indication is received from a PCP server
Slave when a previous request was sent before, or can be received at any
time if a Slave works as PCP client Slave.

10.1.10 IBM_TASK Data Cycle Status

Figure 94: IBM_TASK Data Cycle Status
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Variable Meaning

Noise received after a process data cycle is finished normally no further
data should be received be the master in the backline of
the InterBus ring. But in case of electronically disturbance
the InterBus can be influence in this way that noise is
produced in the shifting register. Before the master starts
the next data cycle it looks for received noise telegrams. If
noise was received it increments the counter and drives
an ID-cycle to search for the error location.

Idle indication the master supervises the incoming bit stream all the time.
Because of the InterBus principle there exits always bus
activity also in process data idle times. If the incoming bus
activity is interrupted because of a cut wire for example,
the master increment this value and drive ID cycles to
search for the error.

Data byte missing the master supervises the InterBus delay of incoming
process data. If this time equidistant value is overstepped
in its limit, the mater drives ID-cycles to search for the
error.

State bits changed each telegram that is sent into the InterBus ring has an
IBS specific 3 bit head information included which is
transported by each device back to the master
transparently. If the master detects differences between
the constellations it has sent and the constellation that
comes back from the devices it drives an extra ID-cycle
and searches for the error.

Wrong loop back word the transmission of the process data, must be received
back after all process input data was received without any
change. If there are differences detected a transmission
error has occurred and the master drives an extra I
management cycle.

CRC-Check timeout after each data cycle a CRC check procedure is following.
This procedure is supervised by a timer. If the time limit is
overstepped for the incoming CRC telegrams of the
devices a transmission error has occurred and the master
drives an ID-cycle.

Last CRC-Error class 1 = Stop bit unequal zero
2 = CRC indicated transmission error
3 = Faulty InterBus-Telegramstatusbits
4 = Process data transfer timeout
5 = Checksum transfer timeout

Num. of CRC-Checks failed here the number of failed CRC procedures is counted.
Check sum status low Counts the number of received invalid checksum-status

low telegrams
Check sum status high Counts the number of received invalid checksum-status

high telegrams

Table 65:IBM_TASK Data Cycle Status
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10.1.11 IBM_TASK Scanned ID Codes

Figure 95: IBM_TASK Scanned ID Codes

This buffer represents always the last received ID code image of the
current connected InterBus network. Is it updated by the master on each
extra driven ID cycle during the process data cycle transfer. With its
contents conclusions are possible for the kind of error and error location.
For example the picture above shows a scanned ID-Code to D503hex and
the next value to A518hex = loop back word. The master sends in case of a
transmission error always the number of expected active (devices + 1) loop
back words into the InterBus ring. Normally it will receive back all ID-Codes
of the connected device instead of the loop back word, but in the picture it
receives only the ID-Code of the first device. So it seems that the contact
was interrupted to all the following Devices and this was actually the fault
that was produced here in this example constellation.
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10.1.12 ALPMLIP Common Variables

Figure 96: ALPMLIP Common Variables

This common variables structure is responsible for the indication of
connection establishment errors during the initiate phase of the master in a
PCP connection. The structure always shows the latest information of a
failed connection initialization.



SyConIB System Configurator InterBus Appendix  �  149

Copyright � Hilscher Gesellschaft für Systemautomation mbH � Oi:SyConIB#6EN

Variable Meaning

Initiate request Counts the number of initialization requests of all Client-
Slaves.

Initiate response pos. Counts globally the number of faultless master
initializations to PCP Slaves.

Initiate response neg. Counts globally the number of failed master initializations
to PCP Slaves.

Error class 0 = Initiate
5 = Service
6 = Access
8 = Other

Error code 1 = Max. PCP length insufficient
2 = Service not supported.

Additional code Actually not used.
Max. send length low Maximum supported send PCP length with low priority of

the last requested device to which the connection
initialization has failed

Max. send length high Not supported, always 0
Max. recv. length low Maximum supported receive PCP length with low priority

of the last requested device to which the connection
initialization has failed.

Max. recv. length high Not supported, always 0
Client services 1 Bit 7 (128) Get OV Long
Client services 2 Bit 5 (32) Read

Bit 4 (16) Write
Client services 3 Bit 7 (128) Information Report
Server services 1 Bit 7 (128) Get OV Long
Server services 2 Bit 5 (32) Read

Bit 4 (16) Write
Server services 3 Bit 7 (128) Information Report

Table 66: ALPMLIP Common Variables
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10.1.13 ALPMLIPD ALI Information

Figure 97: ALPMLIPD ALI Information

This table shows the actual status information of all ever requested and
received services within the master since its last reset.
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10.1.14 ALPMLIPD PMS Information

Figure 98: ALPMLIPD PMS Information

Variable Meaning

Send response Number of sent master response to previous
corresponding Slave request.

Send request Number of sent master requests.
Receive indication Number of received Slave requests.
Receive confirmation Number of received Slave response to previous

corresponding master request.

Table 67: ALPMLIPD PMS Information
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10.1.15 ALPMLIPD LLI Information

Figure 99: ALPMLIPD LLI information

Variable Meaning

PDL receive ind./conf. Number of all ever received Slave confirmation or
indications.

LLI send res./req. Number of all ever sent master requests or responses.
LLI abort request Number of ever sent connection aborting requests.
PDL reset Number of internal resets of the sub protocol stacks PDL.

Table 68: ALPMLIPD LLI information
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10.2 Extended Device Diagnostic Slave
At the following pages you see the task state structures for the InterBus
Slave.

10.2.1 ALI_TASK Common Variables

Figure 100: ALI_TASK Common Variables

Variable Meaning

Com. State CR 2 displays the current status of CR2 (possible display:
closed, init, open)

Com. State CR 3 displays the current status of CR3 (possible display:
closed, init, open)

Message Counter Counter for the number of received instruction messages
MailBox Counter Counter for the number of received response messages
User Error Counter is not used
Error Code holds the last error, which occurred in the task

Table 69: ALI_TASK Common Variables
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10.2.2 PCL_TASK Common Variables

Figure 101: PCL_TASK Common Variables

Variable Meaning

PLC Task Version Task compiled for IB Slave status
Task Status status of the task
Cycle Time Is not used
PLC Mode holds the actual PLC mode
Event Counter counter as the number of finished events
Handshake counters for the number of transacted user data cycle
Data update counters for the number of transacted process data cycles
Not Ready Event counters for the number of detected NOT ready events

Table 70: PCL_TASK Common Variables
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10.2.3 SUPI_TASK Common Variables

Figure 102: SUPI_TASK Common Variables
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Variable Meaning

IBS ID Code holds the ID configured code
IBS Length Code holds the Length configured code
IBS Data Length holds the Length of the real (cyclic) process data
Message Counter Counter for the number of received instruction Messages
Received Interrupts Counter for the number of received program interrupts
Received Answers Counter for the number of received response Messages
Data Exchange Counter Counter for the number of transacted process data cycles
Init Message Counter Counter for the number of received init Messages
Error Counter Counter for the number of detected Message errors
Last Error holds the last error, which occurred in the task
Additional Error Counter holds an additional error description
User Reset Counter for the number of executed user resets
Initiate Indication Counter for the number of received Initiate.Indications
   Initiate CR with the Initiate.Indication detected CR
Abort Indication Counter for the number of received Abort.Indications
   Locally Generated True or False, if locally or issued generates
   Abort ID ID code of the service
   Reason Code reason for Abort service
   Result result
   Error Class error class
   Error Code error Code
   Additional Code additional code
Reject Indication Counter for the number of received Reject.Indications
Read Indication Counter for the number of received Read.Indications
Read Confirmation Counter for the number of received Read.Confirmations
Write Indication Counter for the number of received Write.Indications
Write Confirmation Counter for the number of received Write.Confirmations
PNM7 Event Indication Counter for the number of received PNM7-

Event.Indications
Initiate Indication Counter for the number of received Initiate.Indications
   Initiate Result result of the Initiate attempt
Initiate Error Confirmation Counter for the number of missed Initiate.Confirmations
VFD Status Confirmation Counter for the number of received VFD

Status.Confirmation
VFD Identify Confirmation Counter for the number of received VFD

Identify.Confirmation
Get OD Confirmation Counter for the number of received Get-OD.Confirmation
Info Report Indication Counter for the number of received InfoReport.Indications

Table 71: SUPI_TASK Common Variables
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10.2.4 SUPI_TASK IBS Information

Figure 103: SUPI_TASK IBS Information

Variable Meaning

Physical State physical status of the Slaves (possible display: ready for
OP, Partially ready, not ready for OP, service required)

Logical State logical status of the Salves (possible display: Ready for
Communication, Limited NO SVC)

Bus Reset true or false
Bus Active true or false
Data Exchange true or false

Table 72: SUPI_TASK IBS Information
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10.2.5 SUPI_TASK ALI Information

Figure 104:SUPI_TASK ALI Information



SyConIB System Configurator InterBus Appendix  �  159

Copyright � Hilscher Gesellschaft für Systemautomation mbH � Oi:SyConIB#6EN

Variable Meaning

Read Request Counter for the number of transmitted Read.Requests
Read Indication Counter for the number of received Read.Indications
Read Response Counter for the number of transmitted Read.Response

Read Response (�) Counter for the number of transmitted incorrect
Read.Responses

Read Response Error Type Result, if response incorrectly, otherwise 0
Write Request Counter for the number of transmitted Write.Requests
Write Indication Counter for the number of received Write.Indications
Write Response Counter for the number of transmitted Write.Response

Write Response (�) Counter for the number of transmitted incorrect
Write.Responses

Write Response Error Type Write Response error type
Initiate Request Counter for the number of transmitted Initiate.Requests
Initiate Indication Counter for the number of received Initiate.Indications
Initiate Response Counter for the number of transmitted Initiate.Response
Initiate Error Response Counter for the number of transmitted incorrect

Initiate.Responses
Abort Request Counter for the number of transmitted Abort.Requests
Abort Indication Counter for the number of received Abort.Indications
Abort Reason reason for the Abort service
Reject Indication Counter for the number of received Reject.Indications
Reject Reason reason for the Reject service
Information Report Request Counter for the number of transmitted Report Requests
Get-OD Request Is not used
Get-OD Indication Counter for the number of received Get-OD.Indications
Get-OD Confirmation Counter for the number of received Get-OD.Confirmation

Get-OD Confirmation (�) Counter for the amount of received incorrect Get-
OD.Confirmation

Get-OD Confirmation Error
Type

Result, if response incorrectly, otherwise 0

Get-OD Response Is not used
Status Indication Counter for the number of received Status.Indications
Identify Indication Counter for the number of received Identify.Indications
Identify Confirmation is not used
Identify Response is not used
PNM7 Event Indication is not used
Status Confirmation is not used

Table 73: SUPI_TASK ALI Information
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10.2.6 SUPI_TASK PMS Information

Figure 105: SUPI-TASK PMS Information

Variable Meaning

Send Response Counter for the number of transmitted Responses
Send Request Counter for the number of transmitted Requests

Table 74: SUPI-TASK PMS Information
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10.2.7 SUPI_TASK LLI Information

Figure 106:SUPI-TASK LLI Information

Variable Meaning

PDL Indication Counter for the number of received services
LLI Send Response/Request Counter for the number of transmitted Requests or

Responses
LLI Abort Request Counter for the number of received Abort.Requests
PDL Reset is not used

Table 75: SUPI-TASK LLI Information
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10.2.8 SUPI_TASK PDL Information

Figure 107: SUPI_TASK PDL Information

Variable Meaning

PDL Main State Current status of the PDL status machine
Receive Main State Receive status of the PDL
Transmit Main State Transmit status of the PDL
SUPI Interrupts Counter for the number of detected program interrupts,

causes through for the interface module SUPI
Bus Not Active Counter for the number of the “BusNot Active“
Bus Reset Counter for the number of the “BusResets“
Receive Interrupt Counter for the number of detected Receive Program

Interrupts
Transmit Interrupt Counter for the number of detected Transmit Program

interrupts
Data Exchange Counter for the number of detected Data Exchange

Program interrupts
State: Cycle End Counter for the number of “CycleEnd“
State: Receive Counter for the number of “Receive“
State: Transmit Counter for the number of “Transmit“
State: Init Counter for the number of “Init“
State: FCB Response Counter for the number of “WaitFcbResponse“
Paramsync. is not used
PMA Reset Counter for the number of the PDL-Resets

Table 76:SUPI_TASK PDL Information
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10.3 Length and ID Codes

10.3.1 Length Code
The Length Code contains information about the (max. possible) data
weight of the Slave. The Master can read out the 5 bit containing Length
Code over the Bus from the Slave. The following table shows the
determination in accordance with the InterBus standard DIN EN 50254.
Decimal Hexadecimal Meaning Alternatively Interpretation

(Hex)

0 00 No Data 00
1 01 1 Word 01
2 02 2 Words 02
3 03 3 Words 03
4 04 4 Words 04
5 05 5 Words 05
6 06 8 Words 08
7 07 9 Words 09
8 08 4 Bit 41
9 09 1 Byte 81
10 0A 12 Bit 43
11 0B 3 Byte 83
12 0C 1 Bit C1
13 0D 2 Bit C2
14 0E 6 Words 06
15 0F 7 Words 07
16 10 reserved -
17 11 26 Words 1A
18 12 16 Words 10
19 13 24 Words 18
20 14 32 Words 20
21 15 10 Words 0A
22 16 12 Words 0C
23 17 14 Words 0E
24 18 reserved -
25 19 reserved -
26 1A reserved -
27 1B reserved -
28 1C reserved -
29 1D reserved -
30 1E reserved -
31 1F reserved -

Table 77: Lengths Code

Note see next page.
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Note: The given values in the column Alternatively Interpretation (8 Bits)
are used partly by other configuration software and printed on the labels of
Slaves or they are given in the product documentation. SyCon used the
Length Code in accordance with DIN EN 50254. Is for example the Length
Code 41H printed on the Slave (Alternatively Interpretation), you have to
use 08H in SyCon.
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10.3.2 ID Code
The ID Code contains information about the device type. A part of this are
for example the information Remote Bus-, Local Bus Device, Bus Branch,
digital or analog modules and further more the PCP capacity of the device.
Dec Hex Description of the Module Function

1 01 Remote Bus Device, digital Output modules
2 02 Remote Bus Device, digital Input modules
3 03 Remote Bus Device, digital In- and Output modules
4 04 Bus Branch with InterBus-Loop-Branch
5 05 Remote Bus Device (digital), ISO-Valve Ile (Output)
8 08 Bus Branch with 2-Conductor-Local Bus Branch
12 0C Bus Branch with 2-Conductor-Remote Bus Branch
13 0D Remote Bus Device (digital), profile concurring digital Output modules
14 0E Remote Bus Device, profile concurring digital Input modules
47 2F Remote Bus Device, profile concurring digital In- and Output modules
49 31 Remote Bus Device, analog Output modules
50 32 Remote Bus Device, analog Input modules
51 33 Remote Bus Device, analog In- and Output modules
52 34 Bus Branch with 8-Conductor-Local Bus Branch
53 35 Remote Bus Device, profile concurring analog Output modules
54 36 Remote Bus Device (analog), ENCOM with Input data
55 37 Remote Bus Device (analog), ENCOM with In- and Output data
56 * 38 * Remote Bus Device with Parameter Cannel, "µP_Not_Ready" with

register interlock
58 3A Remote Bus Device, profile concurring analog Input modules
59 3B Remote Bus Device, profile concurring analog In- and Output modules
60 * 3C * Remote Bus Device with Parameter Channel, "µP_Not_Ready" for

reinitialization
83 53 Local Bus Device, analog In- and Output modules with event Inputs and

Configuration Outputs
91 5B Local Bus Device, analog Output modules with event Inputs
95 5F Local Bus Device, analog Input modules with Configuration Outputs
99 ** 63 ** Local Bus Device, analog Loop In- and Loop Output modules with event

Inputs and Configuration Outputs
102 66 Local Bus Device (analog), ENCOM with Input data
103 67 Local Bus Device (analog), ENCOM with In- and Output data
104 * 68 * Local Bus Device with Parameter Channel, "µP_Not_Ready" for

reinitialization, Loop
107 ** 6B ** Local Bus Device, analog Loop Output modules with event Inputs
108 * 6C * Local Bus Device with Parameter Channel, "µP_Not_Ready" for

reinitialization, Local Bus
111 ** 6F ** Local Bus Device, analog Loop Input modules with configuration Outputs
113 71 Local Bus Device, analog Loop Output modules
114 72 Local Bus Device, analog Loop Input modules
115 73 Local Bus Device, analog Loop In- and Output modules
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120 * 78 * Local Bus Device with Parameter Channel, "µP_Not_Ready" with
register interlock

121 79 Local Bus Device, profile concurring analog Output modules
122 7A Local Bus Device, profile concurring analog Input modules
123 7B Local Bus Device, profile concurring analog In- and Output modules
125 7D Local Bus Device, analog Output modules
126 7E Local Bus Device, analog Input modules
127 7F Local Bus Device, analog In- and Output modules
177 B1 Local Bus Device, digital-InterBus-Loop Output modules
178 B2 Local Bus Device, digital-InterBus-Loop Input modules
179 B3 Local Bus Device, digital-InterBus-Loop In- and Output modules
181 B5 Local Bus Device, profile concurring digital Output modules
182 B6 Local Bus Device, profile concurring digital Input modules
183 B7 Local Bus Device, profile concurring digital In- and Output modules
187 BB Local Bus Device, screwing controller
189 BD Local Bus Device, digital Output modules
190 BE Local Bus Device, digital Input modules
191 BF Local Bus Device, digital In- and Output modules
192 * C0 * Local Bus Device with Parameter Channel, DRIVECOM (2 PCP-Words)
193 * C1 * Local Bus Device with Parameter Channel, DRIVECOM (4 PCP-Words)
195 C3 Local Bus Device with Parameter Channel, DRIVECOM (1 PCP-Word)
212 * D4 * Local Bus Device with Parameter Channel, ENCOM (2 PCP-Words)
213 * D5 * Local Bus Device with Parameter Channel, ENCOM (4 PCP-Words)
215 D7 Local Bus Device with Parameter Channel, ENCOM (1 PCP-Word)
216 * D8 * Local Bus Device with Parameter Channel, profile concurring

(2 PCP-Words)
217 * D9 * Local Bus Device with Parameter Channel, profile concurring

(2 PCP-Words)
219 DB Local Bus Device with Parameter Channel, profile concurring

(1 PCP-Word)
220 * DC * Local Bus Device, module with Parameter Channel (2 PCP-Words)
221 * DD * Local Bus Device, module with Parameter Channel (4 PCP-Words)
223 DF Local Bus Device, module with Parameter Channel (1 PCP-Word)
224 * E0 * Remote Bus Device with Parameter Channel, DRIVECOM

(2 PCP-Words)
225 * E1 * Remote Bus Device with Parameter Channel, DRIVECOM

(4 PCP-Words)
227 E3 Remote Bus Device with Parameter Channel, DRIVECOM

(1 PCP-Word)
228 * E4 * Remote Bus Device with Parameter Channel, profile concurring modules

(2 PCP-Words)
229 * E5 * Remote Bus Device with Parameter Channel, profile concurring modules

(4 PCP-Words)
231 E7 Remote Bus Device with Parameter Channel, profile concurring modules

(1 PCP-Word)
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240 * F0 * Remote Bus Device, module with Parameter Channel (2 PCP-Words)
241 * F1 * Remote Bus Device, module with Parameter Channel (4 PCP-Words)
243 F3 Remote Bus Device, module with Parameter Channel (1 PCP-Word)
244 * F4 * Remote Bus Device with Parameter, ENCOM (2 PCP-Words)
245 * F5 * Remote Bus Device with Parameter, ENCOM (4 PCP-Words)
247 F7 Remote Bus Device with Parameter, ENCOM (1 PCP-Word)

Table 1: ID-Codes

* This ID Code is not supported until the InterBus Master Generation 4.
** This ID Code is not supported until the InterBus Master Firmware V 4.50.
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