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Preface

PURPOSE

The FactoryLink 6.5.0 Tutorial is designed to teach you the fundamentals of 
FactoryLink. When you have completed this tutorial, you will be able to use the 
Application Editor to create applications and execute the applications in a 
run-time environment to test the items configured. 

This manual is prepared to present the technical information users of 
FactoryLink 6.5.0 need to complete their applications. 

• Accuracy is paramount—This FactoryLink documentation must provide 
accurate and reliable information and procedures.

• Time is valuable—This FactoryLink documentation must guide the 
programmer through what he needs to know quickly and efficiently.

AUDIENCE

The major audience of this manual is anyone interested in learning how to use 
FactoryLink.

In addition, FactoryLink Customer Support Services personnel use the 
procedures and examples included here to help you develop and troubleshoot your 
applications.

STRUCTURE OF THE TUTORIAL

The Tutorial is part of the Base set of documents in the overall FactoryLink 
Documentation Set. Refer to the Preface in Fundamentals for the structure of the 
entire Documentation Set.

This manual is divided into three chapters followed by an Index:
• Introduction—includes information about the requirements for the tutorial 

and the Application Editor.

• Quick Start — teaches the fundamentals of setting up and running an 
application using template items provided with FactoryLink. 

• Basics — teaches some of the more advanced functions that you may use when 
creating your own applications. 

Each lesson guides you, step by step, through:

• Creating a user-interface screen with graphics and text using the Application 
Editor.
FactoryLink 6.5.0 / Tutorial / 3
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• Animating the graphic and text objects to allow them to receive and display 

information from the FactoryLink application. 

• Simulating input data received from communications with an external device. 
In a real application, communication with an external device provides input 
data. 

• Executing the application in run time to test the items configured. 

HOW TO USE THIS MANUAL

The material in this manual is presented sequentially in performance order. We 
recommend you first read the introduction, then complete the Quick Start 
chapter, followed by the Basics chapter, which presents more advanced features of 
FactoryLink.

… at-a-Glance

This manual contains a section named … at-a-Glance that provides a quick key to 
where you will find information to perform the procedures detailed in each 
chapter with hypertext links to those locations.

CONVENTIONS

The material in the Documentation Set adheres to the guidelines published in The 
Digital Technical Documentation Handbook by Schultz, Darrow, Kavanagh, and 
Morse; Developing International User Information by Jones, Kennelly, Mueller, 
Sweezy, Thomas, and Velez; and corporate style guidelines.

This manual uses the following conventions:

Convention Description

italic type Italic type is used to denote user-supplied variables 
in command examples.
Italic type also sets off references to specific 
documents.

monospace type Monospace type is used to denote command names 
and code examples or example output.

bold monospace type Bold monospace type is used in command examples 
to indicate words that must be typed literally.
/ FactoryLink 6.5.0 / Tutorial
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Conventions
sans serif type Sans Serif type is used to set off field names, 
button names, and keys on the keyboard.

blue type Blue type is used for headings and to call attention 
to information within the text.

press nnnnn Press is used to denote a key on the keyboard. The 
key name will appear in a sans serif type.

click on nnnnn Click on is used to denote a button on the screen. 
The button name will appear in a sans serif type.

Shift+F1 The + indicates the keys must be pressed 
simultaneously.
Shift+F1 indicates you hold down the Shift key 
while you press another key or mouse button 
(indicated here by F1). 
Other key combinations are presented in the same 
manner.

F1 F2 F3 The space between the key callouts indicates press 
and release.
The key sequence F1 F2 F3 indicates you press and 
release F1, then F2, and then F3.
Other key combinations are presented in the same 
manner.

File>Open The > indicates a progression through a menu 
sequence.
File>Open indicates you choose Open from the File 
menu to perform the required action.
Other menu sequences are presented in the same 
manner.

Convention Description
FactoryLink 6.5.0 / Tutorial / 5
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Example Syntax

Example syntax using these conventions is provided below:

command input_file [input_file…] {a|b} output_file 

where

command is typed as it is displayed in the syntax.

input_file indicates a variable the user supplies.

[input_file…] indicates the user can optionally supply multiple input file 
names, each name separated by a space.

{a|b} indicates either the a or b must be specified as an argument.

output_file indicates the user must specify an output file.

GETTING HELP

Contact your Sales or Customer Support Representative for help troubleshooting 
problems. 

Also, help files are included for each configuration panel. These are accessed by 
clicking on Help on the panel menu bar.

FLAPP\user\drw\mydrw.g The \ indicates the directory structure for the 
listed file.
FLAPP\user\drw\mydrw.g indicates the drawing file 
mydrw.g is located in the drw sub-directory of the 
user sub-directory to the FLAPP directory.
Other directory structures are presented in the 
same manner.

[ ] Brackets indicate an optional argument. You can 
choose none, one, or all of the options.

{ } and | Braces indicate a choice. You must choose one of 
the elements. The vertical bar separates choices 
within braces.

Convention Description
/ FactoryLink 6.5.0 / Tutorial
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Tutorial at a Glance
Using Tutorial

For details on performing the following steps... Go to...

1. Read about the requirements for the tutorial and 
the Application Editor.

Chapter 1, “Introduction”

2. Install the FactoryLink 6.5.0 software and the 
Programmer’s Access Kit software if they are not 
already installed.

FactoryLink 6.5.0 
Installation Guide

3. Read about the fundamentals of setting up and 
running an application using template items 
provided with FactoryLink,including starting the 
Application Editor, creating a graphic screen, 
creating a trending screen, testing the application, 
and saving and restoring the tutorial.

Chapter 2, “FactoryLink 
Basic Features”

4. Read about the basics to learn about more 
advanced functions you may use when creating 
your own applications.

Chapter 3, “FactoryLink 
Advanced Features”
FactoryLink 6.5.0 / Tutorial / 7
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This chapter contains information about:

• Requirements for the Tutorial
• The Application Editor
FactoryLink 6.5.0 / Tutorial / 9
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REQUIREMENTS FOR THE TUTORIAL

Follow the instructions in the FactoryLink 6.5.0 Installation Guide to install 
FactoryLink on your system before running the tutorial. 

Once FactoryLink is installed, use the New Application (FLNEW) utility to create 
a starter application that serves as a base for building a FactoryLink application.

Caution: Running FLNEW deletes and overwrites any 
existing application in the target directory. If an 
application exists in the target directory that must 
be saved, use a different directory name for the new 
application. 

Create the new application by double-clicking on the New Application icon. 

FLAPP is the default directory FactoryLink will place the new application in. 

The tutorial assumes you are familiar with basic computer concepts and the 
features and syntax of the operating system and hardware you are running. 
 / FactoryLink 6.5.0 / Tutorial
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THE APPLICATION EDITOR

The Application Editor is used during development to create and animate the 
graphical user interface screens for the FactoryLink run-time application. These 
interface screens allow you to view, monitor and write data to the real-time 
database. You will be using the Application Editor to create and animate screens 
during the tutorial lessons. Refer to The Application Editor Guide for a detailed 
description. 

Throughout the tutorial, the pull-down menu functions for executing a feature are 
specified by menu bar title followed by the specific function. For example, 
Edit>Copy. The alternate toolbox tool to perform a function is not indicated in the 
tutorial. The toolbox is displayed below with each function called out. Refer to The 
Application Editor Guide for a detailed description of each pull-down menu 
function and toolbox tool. 

When the tutorial indicates a mouse-click, assume it is the left mouse button 
unless otherwise specified. 

Select
Reshape

Cut

Copy

Align Front

Combine

Connect

Text Line

Rectangle

Ellipse

Parabola
Spline

Line Attrbs

Fill Attrbs

Output Text
Input Text

Bar

Symbol

Button

Legend

Template
Test

Rotate

Paste

Back

Separate

Polygon

Arc

Legend

Text Attrbs

Paint

Chart

Power VB

Tag Dict
FactoryLink 6.5.0 / Tutorial / 11
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This chapter teaches you the basic features of FactoryLink using templates called 
Power Packs. Power Packs are composed of intelligent objects called Power 
DragOns, which have built-in animation and logic. When you place a Power 
DragOn into a drawing, the system prompts you for details that allow you to 
operate the logic and animation to work with your system. FactoryLink Power 
Packs are powerful yet easy to use and create applications typical of what you 
might use at your own site.

This 30 minute lesson teaches you how to set up, animate, and test an application 
you create using Power Packs. You will create an application to initiate, monitor, 
and control the flow of liquid from one tank to another. You will be able to view 
tank contents, open/close valves, and regulate pump speed from the screen. You 
will also configure the screen to alert any problems with the fluid transfer.

You will also create a screen used to track the flow rate trend over time. This type 
of information might be used by supervisors to monitor fluid transfer and ensure 
the process is within specification tolerances.
FactoryLink 6.5.0 / Tutorial / 13
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STARTING THE APPLICATION EDITOR

Accessing the Application Editor

You open the Application Editor in a number of ways. For this tutorial, access the 
FactoryLink 6.5.0 program directory and double-click on the FactoryLink 
Application Editor icon.

If you choose to open the Application Editor from within the Configuration 
Manager, ensure the current domain selected is USER in the Configuration 
Manager Domain Selection box. 

Opening a Drawing

 1 Choose File>Open from the Application Editor main screen to display the File 
Selection dialog.

 2 Highlight overview.g and double click on it. Overview.g should be in the File Name 
field. 
 / FactoryLink 6.5.0 / Tutorial
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 3 Click on OK to display the overview drawing.

 4 Choose File>Open Power Pack to display the Open Power Pack dialog. 

 5 Highlight tutorial.gp and double click on it. Tutorial.gp displays in the File Name 
field. Click on OK to display the tutorial power pack. 

Now you are ready to create the overview screen. 
FactoryLink 6.5.0 / Tutorial / 15
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CREATING A GRAPHIC SCREEN

Copying and Pasting Items

You will be copying objects from the power pack and pasting them in the overview 
drawing. Normally, the cursor displays as an arrow. When you are in paste mode 
on a graphic screen, the cursor displays as a cross hair.

After you have finished pasting an object, the Application Editor remains in paste 
mode to paste objects multiple times, if desired. Choose Edit>Select Object from the 
pull-down menu bar to exit the paste mode. The cursor changes back to an arrow. 

You will be copying a pump, slider gauge, dial gauge, one of each type of tank, two 
valves, two horizontal sections of pipe, two different elbow angles, and a simulator 
to create the following screen.

For now, just copy the objects from the tutorial power pack to the overview 
drawing. Don’t be too concerned about the position of the objects, even if they 
overlap. Once you have copied all the objects from the power pack, you can place 
them in their final position.
 / FactoryLink 6.5.0 / Tutorial
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Pasting the Tank

 1 Choose Window>Power Pack- User: tutorial.gp to display the Power Pack. 

 2 Place the cursor over the tank you want to copy from the tutorial power pack and 
click the left mouse button. 

 3 Release the mouse button. Hollow blocks display around the tank indicating it is 
selected and copied. 

 4 Choose Window>Drawing -User: overview.g to select the overview drawing. The paste 
cursor (cross hairs) displays on the drawing. 

 5 Move the cursor to the approximate area of the drawing where you would like to 
position the tank, then click and release the left mouse button.

Tank
FactoryLink 6.5.0 / Tutorial / 17
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 6 A template dialog displays.

FactoryLink uses tag names to refer to elements in the real-time database. Each 
element must have a unique name so, whenever FactoryLink writes information 
to or reads information from the element, it accesses the correct element. 

Note:  These names are case sensitive. The system views tank 
as different from TANK. 

Use the tag names suggested on the dialog as you will refer back to objects by 
name later in this tutorial. 

The template items used in this tutorial have default values assigned to the object 
properties associated with the object. This means preconfigured values are 
assigned for such functions as the maximum value of the tank and the alarms. To 
change these defaults for the item being pasted, position the cursor in the value 
field, highlight the default value, and type in the value you desire. We recommend 
leaving the default values configured for the tutorial.

Position the cursor in the value field on the template for Tag name (i.e. tank1), 
click the mouse button, and enter the tag name tank1. 

 7 The Default maximum level (ex: 100) value field contains a default value of 100 to 
indicate the volume of liquid that can be held in the tank - in this case, 100 liters. 

You define alarms flags that can be configured for any tag in the database. If the 
value for the tag meets the criteria specified for the alarm, an alarm message 
displays on the screen. Multiple alarms can be configured for different criteria 
points for the same tag. 
 / FactoryLink 6.5.0 / Tutorial
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In this example, configure the system so the operator will be notified when the 
level of the liquid in the tank falls below 10 liters (LO alarm) and to send a critical 
warning to the operator when the level of liquid falls below 5 liters (LOLO alarm). 
In addition, you want the operator to be notified when the level of liquid in the 
tanks rises above 90 liters (HI alarm) and to receive a critical warning when the 
level of liquid rises above 95 liters (HIHI alarm).

 8 The LOLO alarm limit (ex: 5) value field contains a default value of 5 as the alarm 
limit. The LO alarm limit (ex: 10) value field contains a default value of 10 as the 
alarm limit. 

 9 Click on the scroll bar once to see the bottom of the template dialog. The HI alarm 
value field (ex: 90) contains a default value of 90 as the alarm limit. The HIHI 
alarm (ex: 95) value field contains a default value of 95 as the alarm limit.

 10 Click on OK to display the tank.
FactoryLink 6.5.0 / Tutorial / 19
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 11 Choose Edit>Select Object to return the cursor to an arrow to select the next object 

to be pasted. 

Pasting the Vessel

 1 Repeat steps 1-7 for the vessel, entering the tag name tank2. The same maximum 
and alarm values are configured as defaults for the vessel level as for the tank 
level since each container in the example holds the same amount of liquid. 

Vessel

Dial Gauge

Slider Gauge

Pump
 / FactoryLink 6.5.0 / Tutorial
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Pasting the Pump

 1 Repeat steps 1-7 under Pasting the Tank for the pump, entering the tag name 
pump1. 

 2 Configure a minimum pump speed of 0 and a maximum pump speed of 100 as 
defaults to specify the flow rate range of the pump. 

 3 Click on OK to display the pump. 

 4 Choose Edit>Select Object to return the cursor to an arrow to select the next object 
to be pasted. 

Pasting the Dial Gauge

 1 Repeat steps 1-5 under Pasting the Tank for the dial gauge. When prompted to 
display the tag, enter pump1 to display the speed of pump1. 

 2 Click on OK to display the dial gauge. 

 3 Choose Edit>Select Object to return the cursor to an arrow to select the next object 
to be pasted. 
FactoryLink 6.5.0 / Tutorial / 21
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Pasting the Slider Gauge

 1 Repeat steps 1-5 under Pasting the Tank for the slider gauge. 

 2 Enter pump1_sp to control the speed of the pump when prompted for the output 
name. Click on OK to display the slider gauge. 

 3 Choose Edit>Select Object to return the cursor to an arrow to select the next object 
to be pasted. 

Pasting the Valves

 1 Repeat steps 1-6 under Pasting the Tank for the first valve, entering a valve name 
of vlve1. Click on OK to display the valve. 

 2 Move the cross-hair cursor elsewhere on the overview drawing and click the left 
mouse button again. When the dialog asks for a tag name, enter vlve2 to 
differentiate it from the first valve. Click on OK to display the second valve. 

 3 Choose Edit>Select Object to return the cursor to an arrow to select the next object 
to be pasted. 

Valve

Pipe

Elbows

Simulator
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Pasting the Pipes

 1 Choose Window>Power Pack- User:tutorial.gp to display the Power Pack. 

 2 Place the cursor over the horizontal pipe you want to copy from the tutorial power 
pack and click the left mouse button. 

 3 Release the mouse button. Hollow blocks display around the pipe indicating it is 
selected. 

 4 Choose Window>Drawing -User:overview.g to select the overview drawing. The paste 
cursor (cross hairs) displays on the drawing. 

 5 Move the cursor to the approximate area of the drawing where you want to 
position the first horizontal pipe, click and release the left mouse button to display 
the pipe. 

You are not prompted for a tag name for the pipes or the elbows, which you will 
paste in next because they are static, not animated, objects. This means no 
variable action is associated with them, such as changing color, size, position, or 
displaying information; therefore, the system does not communicate with them to 
exchange data nor require a tag name be assigned to them. 

 6 Move the cursor elsewhere on the screen and click the left mouse button again to 
display the second pipe. 

 7 Choose Edit>Select Object to return the cursor to an arrow to select the next object 
to be pasted. 

Pasting the Elbows

 1 Choose Window>Power Pack- User:tutorial.gp to display the Power Pack. 

 2 Place the cursor over the pipe elbow you want to copy from the tutorial power pack 
and click the mouse button. 

 3 Release the left mouse button. Hollow blocks display around the elbow indicating 
it is selected. 

 4 Choose Window>Drawing -User:overview.gt o select the overview drawing. The paste 
cursor (cross hairs) display on the drawing. 
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 5 Move the cursor to the approximate area of the drawing where you want to 

position the elbow, click and release the left mouse button to display the elbow. 

 6 Choose Edit>Select Object to return the cursor to an arrow to select the next object 
to be pasted. Repeat steps 1-4 to paste the other elbow. 

Pasting the Simulator

When controlling a real process, the real-time database elements are attached to 
transducers that use the FactoryLink device drivers. For this tutorial, the process 
is imitated by using the simulator object. 

 1 Repeat steps 1-6 under Pasting the Tank for the simulator. 

 2 Enter the pump name pump1, first valve name vlve1, second valve name vlve2, 
supply tank name tank1, and destination tank name tank2. 

 3 Click on OK to display the simulator. 

 4 Choose Edit>Select Object.
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Moving the Objects

You have pasted all the items you need on the screen. Now, use the following the 
steps to move them to their final positions: 

 1 Place the cursor over the object you want to move and click the left mouse button. 

 2 Release the mouse button. Handles display around the object indicating it is 
selected. 

 3 Place the cursor on the middle handle and click the left mouse button. The 
handles disappear. Hold the mouse button and drag the object to the desired 
location, then release the mouse button. The object and handles display in the 
new location. 

 4 Repeat these steps until each object is in the desired position.

 5 Position the cursor on the dotted box to the right of the screen and click on it. Solid 
handles called blocks display to indicate the box is selected. Choose Edit>Move to 
Front from the pull-down menu to ensure when the on-line help dialogs are 
displayed, they are in front of the objects they are documenting. 

 6 Repeat step 5 for the Style button on the right side of the screen. 

 7 Save the screen by choosing File>Save when the screen looks like the one above. 

Dotted Box

Style Button
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CREATING THE TRENDING SCREEN

Next, create a separate screen to track the flow rate or trend over time. This 
screen is composed of the system pump, gauges, simulator, and a chart for 
tracking data. 

 1 Using the cursor arrow, draw a rectangle around the center portion of the screen 
by clicking and holding the left mouse button down, then drag the mouse around 
the desired objects. 

 2 When you release the mouse button, solid black handles display around the 
objects indicating they are selected. 

 3 Choose Edit>Copy to copy the items selected. 

 4 Choose File>Close to close the overview drawing. Repeat this step to close the 
tutorial power pack. 

Drag to 

Start
Dragging

Here

End Here
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 5 Choose File>Open from the Application Editor main screen to display the File 
Selection dialog. 

 6 Use the cursor arrow to choose the drawing named area1 and click on it. Area1 
displays in the File Name field. 

 7 Click on OK to display the area1.g drawing. 

 8 Choose Edit>Paste to paste the items copied from the overview screen onto this 
screen. The cross-hair cursor displays. Position the cursor mid-way down the left 
side of the screen and click the left mouse button. 

 9 The dialogs you completed for these objects when you created the overview screen 
display with the information inserted. Click on OK for each dialog. If a pop-up 
question displays asking if you wish to overwrite the definition for any tag, click 
on NO. 
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 10 The objects display on the area1 screen.

 11 Choose Edit>Select Object to return the cursor to an arrow to select the next object 
to be pasted. 

 12 Choose File>Open Power Pack to display the Open Power Pack dialog.
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 13 Place the arrow on the power pack named s1trend.gp and click on it. S1trend.gp 
displays in the File Name field. Click on OK to display the s1trend power pack. 

 14 Place the cursor over the trend chart object and click on the mouse button. 
Release the mouse button. Hollow blocks display around the trend chart 
indicating it is selected and has been copied to a clipboard. 

 15 Choose File>Close to close the power pack. The area1 screen displays again. 
Choose Edit>Paste. The cursor displays as a cross hair. Position the cursor in the 
center of the right area of the screen and click the left mouse button to display a 
dialog. 

trend chart
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 16 Enter pumpspeed for the name of the trend chart. Enter pump1 for the tag name 

of the data to be trended. Enter 0 for the default minimum value and 100 for the 
default maximum value. Click on OK. 

 17 A pop-up dialog displays asking if you wish to overwrite the values currently used. 
Click on NO to display the trend chart. 

 18 Move the objects so the screen resembles the following.

 19 Choose File>Save to save the changes made to the area1 screen. 

 20 Choose File>Exit to exit the Application Editor. 

Next, test the application during run time. 
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TESTING THE APPLICATION

You must start FactoryLink and open the application screen to test the 
application. 

 1 Open the FactoryLink program directory and double-click on the Start 
FactoryLink icon.

 2 When the program starts, a series of opening screens display followed 
automatically by the overview screen.

 3 Perform the following steps to test if the application is working.

 4 The buttons on the pump and valves display bright green indicating the system is 
working. The contents of the tanks display blue with a black background 
representing the portions of the tanks that are empty. 

Slider Gauge Knob

Dial Display

Reset Button

Acknowledge
Alarm Button

Alarm Viewer
Button

Alarm Banner
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 5 Place the cursor over the knob on the slider gauge and move it to the right. The 

flow rate displayed on the dial gauge increases and the rate the fluid is 
transferred between tanks also increases. 

 6 Place the cursor over the green button on the valve and click the mouse button to 
shut off one of the valves. The button turns red, fluid transfer stops, and the dial 
gauge reads 0. 

 7 Click on the Reset button on the simulator to start the transfer process over. 

 8 Look at the alarm banner displayed at the bottom of the screen. An alarm displays 
that informs you the tank contents have reached one of the values you specified 
for an alarm level when you configured the tank. 

 9 Position the cursor over the Acknowledge Alarm (check) button and click the mouse 
button to acknowledge the alarm. The alarm disappears from the banner and the 
next oldest alarm (if any) displays in the banner. 

 10 Position the cursor over the Alarm Viewer (bell) button and click the mouse button. 
The alarm viewer screen displays.

 11 If any unacknowledged alarms display, scroll down the page so the alarm is 
highlighted, then click on the Acknowledge Selection button. The alarm disappears 
from the display. 

Highlighted Alarm

Acknowledge Selection

Return Button

Alarm Viewer Screen
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 12 Position the cursor over the Return button and click on the mouse to display the 
Overview screen. 

 13 Position the cursor over the Area1 button and click the left mouse button to 
display the Area1 screen.

 14 Move the knob on the slider gauge. Check that the change in flow rate is reflected 
on the trend chart. Move the gauge in the opposite direction and check that the 
trend chart reflects the change in the opposite direction. 

 15 Position the cursor over the Overview button and click on the mouse to display the 
overview screen. 

Slider Gauge Knob

Trend Chart

Overview Button
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 16 Position the cursor over the System button in the upper right corner of the 

Overview display and click the left mouse button. The Security Login dialog 
displays, asking for user name and password. 

 17 Enter flink for both fields and click on OK. 

The System button has a security function associated with it. In order to gain 
access to the display or function associated with the button, you must have the 
proper level of security clearance and know the correct password. This allows you 
to develop an application and specify who can access particular functions. Refer to 
Chapter 27, “Graphic Object Security Overview” in the Application Editor for 
more information. 

 18 The system or Run-Time Manager screen displays.

Stop Application
Button
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 19 Congratulations! You have verified the animation of your system objects and the 
buttons on the displays. You have finished the FactoryLink Basic Features portion 
of the tutorial. 

 20 Position the cursor on the button to the left of STOP APPLICATION and click the 
mouse button. This exits the FactoryLink program and returns you to the 
operating system. 

Now, you can 

• Develop your own application. 
• Continue with the second part of the tutorial, FactoryLink Advanced Features, 

which teaches you how to create and configure animated objects and buttons 
yourself in case you need to create an object that does not already exist in the 
Power Packs provided with FactoryLink. 

• Save your tutorial for future use and also begin to develop your own application. 
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SAVING AND RESTORING THE TUTORIAL

For Windows NT and Windows 95

 1 Access the FactoryLink 6.5.0 program directory and double-click on the 
FactoryLink Save Application icon to display the FactoryLink Application Save 
dialog.

 2 Click on the Local Multi-platform Save radio button and click on the box for Save 
Application Data files. Save the application from the source C:\FLAPP to the 
destination C:\FLTUTOR. If you are using a drive designation other than C for 
your hard drive, replace the C in the command with the correct drive letter. Click 
on OK at the bottom of the dialog to save the application. 

 3 As the system goes through the process of saving the application, it may prompt 
you to answer certain questions during the save. Answer Y to any questions. 
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 4 Once the application is saved, double-click on the FactoryLink Restore 
Application icon to restore the application.

 5 The FactoryLink Application Restore dialog displays. Click on the Local Multi-platform 
Save radio button. Restore the file from the source C:\FLTUTOR to the destination 
C:\TUTORIAL and click on OK. If you are using a drive designation other than C 
for your hard drive, replace the C in the command with the correct drive letter. 
FactoryLink 6.5.0 / Tutorial / 37



FACTORYLINK BASIC FEATURES
Saving and Restoring the Tutorial

 38

•

•
•

•

For OS/2

 1 Access the FactoryLink 6.5.0 program directory and click the right mouse button 
on the FactoryLink Backup Application icon.

 2 Choose Settings from the pop-up menu to display the Backup Applications Setting 
dialog. On the Program tab, for optional parameters, type

C:\FLAPP C:\FLTUTOR /loc.

This is the source drive:\directory (space) destination drive:\filename (space) /loc. 
If you are using a drive designation other than C for your hard drive, replace the C 
in the command with the correct drive letter. 

 3 Close the dialog by clicking in the upper left corner of the dialog and choosing 
CLOSE from the menu. 

 4 Double-click on the icon to display the Backup Application window. Check that the 
source and destination files are correct and answer Y to the question: “Do you wish 
to proceed? (Y/N)”

 5 The system will save the application. 

 6 Once the application is saved, restore the application. Access the FactoryLink 
6.5.0 program directory and click the right mouse button on the FactoryLink 
Restore Application icon.

 7 Choose Settings from the pop-up menu to display the Restore Applications Setting 
dialog. On the Program tab, for optional parameters, type

C:\FLAPP C:\FLTUTOR /loc.

This is the source drive:\directory (space) destination drive:\filename (space) /loc. 
If you are using a drive designation other than C for your hard drive, replace the C 
in the command with the correct drive letter. 

 8 Close the dialog by clicking in the upper left corner of the dialog and choosing 
Close from the menu. 
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 9 Double-click on the icon to display the Restore Application window. Check that the 
source and destination files are correct and answer Y to the question: “Do you wish 
to proceed? (Y/N)”

 10 The system restores the application. 

Linking an Icon to the Saved Tutorial

Windows NT

 1 To make it easy to open either your application or your tutorial, create an icon and 
link it to the tutorial application. Access the FactoryLink 6.5.0 program directory 
and click once on the Start FactoryLink icon.

 2 Choose Edit>Copy from the pull-down menu to copy the Start FactoryLink icon. 

 3 A pop-up dialog asks for the group to copy the program item to. Select the 
program group where you have FactoryLink installed. Click on OK to display the 
copied item in the program group. 

 4 With the copied icon selected, choose File>Properties from the pull-down menu to 
rename and configure Start FactoryLink. Type in the description Start FL 
Tutorial. 

 5 After the -a in the cmd line, enter C:\TUTORIAL (the drive and directory you 
restored the application to). If you are using a drive designation other than C for 
your hard drive, replace the C in the command with the correct drive letter.

 6 Click on OK to save the changes. 

 7 Now, when you access the FactoryLink 6.5.0 program directory, you will have a 
Start FactoryLink icon to use for opening your application and a Start FL Tutorial 
icon to use for opening the tutorial. 
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Windows 95

 1 To make it easy to open either your application or your tutorial, create an icon and 
link it to the tutorial application. Access the FactoryLink 6.5.0 program directory 
and click once on the Start FactoryLink icon.

 2 Choose Edit>Copy from the pull-down menu to copy the Start FactoryLink icon. 

 3 Choose Edit>Paste from the pull-down menu to paste the Start FactoryLink icon. 

 4 With the copied icon selected, choose File>Rename from the pull-down menu to 
rename the icon, Copy of Start FactoryLink. Type in the title Start FL 
Tutorial. 

 5 With the icon selected, choose File>Properties from the pull-down menu to display 
the Properties dialog. Place the cursor over the Program tab and click on it to 
display the Program tab. After the -a in the cmd line, enter C:\TUTORIAL (the drive 
and directory you restored the application to). If you are using a drive designation 
other than C for your hard drive, replace the C in the command with the correct 
drive letter. 

 6 Click on Apply and then on OK to save the changes. 

 7 Now, when you access the FactoryLink 6.5.0 program directory, you will have a 
Start FactoryLink icon to use for opening your application and a Start FL Tutorial 
icon to use for opening the tutorial. 
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OS/2

 1 To make it easy to open either your application or your tutorial, create an icon and 
link it to the tutorial application. Access the FactoryLink 6.5.0 program directory 
and click once on the Start FactoryLink icon to select it.

 2 Click on the right mouse button with the icon selected. 

 3 Select Copy from the pull-down menu to copy the Start FactoryLink icon. The 
FactoryLink 6.5.0 OS/2 - Copy dialog displays. 

 4 On the Opened tab, type Tutorial in the New Name field at the top of the dialog. 
Ensure the FactoryLink OS/2 folder is highlighted as the target for the operation, 
then click on Copy. 

 5 Click once on the new icon Tutorial to select it. Click the right mouse button on 
the icon. The Settings dialog displays. For the Optional Parameters field, type -A 
C:\Tutorial. If you are using a drive designation other than C for your hard 
drive, replace the C in the command with the correct drive letter.

 6 Click in the upper left corner to close the dialog and select CLOSE from the menu. 

 7 Now, when you access the FactoryLink 6.5.0 program directory, you will have a 
Start FactoryLink icon to use for opening your application and a Tutorial icon to 
use for opening the tutorial you have created. 
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This chapter teaches you advanced features of FactoryLink. You will be creating a 
control screen to monitor the temperature of liquid in a tank. The operator will be 
able to view the temperature in both numerical and graphic forms. An alarm 
button will flash if the temperature is too high. The control screen will also 
contain a trend chart that will plot the temperature over time. When you are 
finished, the screen will look like this:

You will learn how to:
• Copy Power Pack items. Power Packs are FactoryLink templates that can be 

copied and used to create screens. These templates are very powerful because 
animation is already associated with the templates and the system prompts you 
for the information it needs to work with the templates. 

• Draw and animate text and objects if the item you need is not already created in 
a Power Pack. If a Power Pack item exists that will perform the function you 
desire, it is easiest to use that item. However, you will learn how to create your 
own objects when there is no Power Pack item to perform the function you need. 
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• Configure a Math & Logic function to accept operator input values and perform 

calculations on the value. 

• Create an alarm that will activate when certain conditions occur.
• Export data to a database and track the data trends. 

You do not have to do the Quick Start portion of the tutorial before doing the 
Basics portion. They are designed so you can perform each section independently. 

So, let’s get started. 

STARTING THE APPLICATION EDITOR

Open the FactoryLink 6.5.0 program group and double-click on the FactoryLink 
Application Editor icon. 

DRAWING THE SCREEN

Now you are ready to begin drawing objects on the application screen by:

• Copying a screen control frame and a trending chart from the FactoryLink 
Power Packs. The frame will contain a line in which any system alarms will be 
displayed and buttons that enable users to move between screens. 

• Copying a trending chart from a Power Pack which will be used to display a plot 
of a temperature reading over time. 

• Drawing a rectangle that will be the thermometer and a circle for the 
temperature alarm button. 

• Typing in text to identify the different items on the screen.
• Creating animated text fields to allow the user to enter the temperature and to 

display the current process temperature. In a real life situation, you would 
probably receive the temperature from a sensor probe, and therefore not need to 
enter the temperature. But you will simulate the incoming temperature so you 
can test the application. 

• Copying and pasting buttons to enable the user to move between various 
screens. 
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Initially, you will draw each of the objects and type in the text. Later, you will 
place the objects in their final position on the screen, so you don’t be too concerned 
about detailed positioning of objects right now. 

Creating the Drawing File

 1 Choose File>Open from the Application Editor menu bar. The File Selection dialog is 
displayed with the cursor in the File Name field.

 2 Replace the current contents of the File Name field with a new file name, tutor2, to 
create a new drawing file for your tutorial. The Application Editor automatically 
adds the .g extension.

 3 Click on the OK button. A blank drawing window named tutor2.g is displayed.

Copying and Pasting the Drawing Frame

You will copy a frame that has button animation already created that allows you 
to move between displays. This is a function used in virtually every application, so 
you have been provided a Power Pack item to perform this function so it does not 
have to be redrawn every time. If you completed the Quick Start part of this 
tutorial, you used the preconfigured frames. Now, you will learn how to create 
your own frame and animate the buttons that control access to the frame, so you 
can do it when you are designing your own applications, if necessary. 

 1 Choose File>Open Power Pack from the menu. The Open Power Pack dialog is be 
displayed. Place the arrow on the Power Pack named frames1.gp and click on it. 
Frames1.gp is displayed in the File Name field. Click on the OK button. The frames1 
Power Pack is displayed on the screen. 
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The screen frames are very small, but they will expand to full-screen size when 
pasted. 

 2 Place the cursor over the Style1 frame on the left side of the screen and click on it. 
Hollow blocks called handles appear around the frame, indicating it is selected 
and copied. 

 3 Choose File>Close from the pull-down menu to close the Power Pack. The tutor2 
drawing is displayed on the screen. 

 4 Choose Edit>Paste from the pull-down menu. The paste cursor  is displayed on 
the drawing. 
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 5 Move the cursor to the center of the screen and click the left mouse button. The 
frame is displayed. 

 6 If necessary, move the template so it is even with the bottom and right sides of the 
screen. To move the template, choose Edit>Select Object from the pull-down menu. 
Position the cursor over the template and click on the left mouse button. Handles 
appear around the frame to indicate it is selected. Place the cursor over the center 
handle and hold the left mouse button. Drag the object to the desired location, 
then release the mouse button. The frame and its handles are displayed in the 
new location.

 7 Choose Edit>Separate to break the frame template into its component items so that 
you can work with the individual items later in the tutorial. 
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Drawing the Thermometer Rectangle

Draw a rectangle that you will animate later to function as a thermometer and to 
change colors as the process temperature changes. 

 1 Choose Draw>Box from the pull-down menu. The cursor changes to a pencil 
(indicating you are in the Draw mode) with a box next to it.

 2 Position the cursor near the upper left corner of the drawing window, hold down 
the left mouse button and drag the mouse until a rectangle approximately 1 inch 
by 4 inches has been drawn. Release the mouse button. The rectangle is displayed 
on the screen. 

Drawing the Alarm Circle

Draw a circle that you will animate later in the tutorial to function as a 
temperature alarm. It will flash when the process temperature reaches a certain 
level. 

 1 Choose Draw>Ellipse from the pull-down menu. The cursor changes to a pencil with 
a circle next to it. 

 2 Position the cursor near the center of the drawing window, hold down the left 
mouse button and drag the mouse until a circle of approximately 2 inches in 
diameter has been drawn. 

 3 Release the mouse button. The circle is displayed on the screen. 
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Setting the Font, Font Size, and Color for the Text

Each time you start the Application Editor, it sets the default text color to black 
and the default font to Helvetica (HELV). Change the text size to 24 point:

 1 Choose Attributes>Text from the pull-down menu. The Text Attributes dialog is 
displayed:

 2 Ensure the font HELV is selected in the Font Name box. If it is not, scroll through 
the font names until HELV is visible. Position the cursor over HELV and click the 
left mouse button. 

 3 Position the cursor in the scroll bar in the Font Size box. Scroll through the font 
sizes until 24 is visible. Position the cursor over 24 and click the left mouse button. 

 4 Ensure the black swatch is selected in the Text Color palette. If it is not, choose it 
now by positioning the cursor over it and clicking the left mouse button. 

 5 Position the cursor over the white swatch in the Background Color palette and click 
the left mouse button. 

 6 Click the OK button at the bottom of the dialog to implement the changes. 
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Typing in the Text

 1 Choose Draw>Text from the pull-down menu. The cursor changes to a pencil with 
an A next to it. 

Position the pointer below the temperature bar. Click the left mouse button to 
place the text cursor. Type the following text: 

XXX

 2 Position the cursor in the bottom center of the frame. Click the left mouse button 
to place the text cursor. Type the following text:

XXX

 3 Position the pointer in the top center of the frame. Click the left mouse button to 
place the text cursor. Type the following text:

Temperature Screen

This text block and the remaining text are used to identify objects on the screen, 
so you do not want it to stand out. You will change the text background to match 
the rest of the screen. 

 4 Choose Attributes>Text from the pull-down menu. 

 5 Position the cursor over the light grey swatch (bottom row, fifth from left) in the 
Background Color box and click the left mouse button. Click the OK button at the 
bottom of the dialog to implement the change. 

 6 Position the cursor in the drawing to create a block of text and click the left mouse 
button. Create a block of text for each of the following lines of text:

Temp Alarm

Trend

Current Temp:

Enter Temp:
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Adding a Legend to the Thermometer

 1 Choose Draw>Legend from the pull-down menu. The cursor changes to a pencil 
with a legend ruler next to it.

 2 Position the cursor to the left of the thermometer near the top corner. Hold down 
the left mouse button and drag the cursor to the bottom of the thermometer, 
making a narrow rectangle to the left of the thermometer. Release the left mouse 
button. A legend is displayed with a scale labeled from 0 to 100.

 3 Choose Attributes>Line. The Line Attributes dialog is displayed. Click the cursor on 
the box labeled Visible to deselect the visible option. Click OK. The border around 
the legend disappears.

 4 Choose Edit>Select from the pull-down menu.

 5 Adjust the legend to the left of the thermometer so the 0 tic mark is even with the 
bottom of the thermometer, and the 100 tic mark is even with the top of the 
thermometer by choosing the legend, placing the cursor over one of the top/bottom 
handles, then holding down the left mouse button and dragging until the tic mark 
is correctly aligned.

 6 If the legend overlaps the Current Temp field, ensure the legend is selected, and 
choose Edit>Move to Back to place the legend edges behind the Current Temp field. 
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Moving and Copying a Button

The buttons at the top of the frame are used to move from screen to screen in 
FactoryLink. You need to create a button that corresponds to the new screen you 
created, Tutor2. 

 1 Choose Edit>Select Object from the pull-down menu.

 2 Position the cursor over the Area3 button and click on the left mouse button. 
Release the mouse button. Handles will appear around the button, indicating it is 
selected. 

 3 Choose Edit>Copy from the pull-down menu to copy the button. 

 4 Choose Edit>Paste from the pull-down menu. The cursor is displayed as a 
cross-hair. Position the cursor to the right of the Area3 button and click the left 
mouse button. The copied Area3 button is displayed in the new location. You will 
make changes to the button and animate it later in this tutorial. 

 5 Choose Edit>Select Object to return the cursor to an arrow so you can perform the 
next operation.

Moving the Objects

Once all the items you need (except the trend chart) have been pasted on the 
screen, you can move them to their final positions. Perform the following steps to 
move an object. 

 1 Select the object you want to move by positioning the cursor over it and clicking 
the left mouse button. 

 2 Release the mouse button. Blocks called handles will appear around the object, 
indicating it is selected. 

 3 Place the cursor on the middle handle and click the left mouse button. The 
handles disappear. Drag the object to the desired location, then release the mouse 
button. The object and it’s handles are displayed in the new location. 

 4 Repeat these steps until each object is in the desired position. 
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 5 When finished, the Tutor2 screen looks like this.

 6 Choose File>Save to save your changes to the screen. 

ANIMATING THE GRAPHIC OBJECTS

Once you have created objects, you will animate the objects so they reflect the 
action of items in the real-time database. If you have done the Quick Start section 
of the tutorial, you used templates that already had animation associated with 
them. Now, you will learn how to create the animation yourself. You will animate 
the following items:
• The thermometer as a color bar to display the temperature graphically

• The Current Temp field to display the temperature numerically
• The temperature alarm button to change colors and reflect the normal 

temperature range and the out-of-range temperature

• The Enter Temperature prompt as a text-input field to accept operator input. In a 
real application, the system would receive information about the process 
temperature from an external device such as a temperature probe. Because you 
may not have such a device connected to your system when developing this 
tutorial, you will have to simulate the incoming information. 

• The Tutor2 button on the Overview screen to open your application drawing, 
tutor2.g.

Refer to Chapter 9, “Animating Objects” in the Application Editor Guide for 
details about animation and the different types of animation objects.
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Animating the Thermometer

You will animate the thermometer rectangle so the simulated temperature change 
is demonstrated by a color bar rising or falling as the process temperature 
changes.

 1 Choose Edit>Select Object from the pull-down menu. Position the cursor on the 
thermometer rectangle and click the left mouse button to select the object. 

 2 Choose Animation>Bar to display the Bar Animation dialog and animate the 
rectangle as a bar object. Enter temp in the Tag field as the name assigned to the 
database element used to control the bar. 

Tag names are used by FactoryLink to refer to elements in the real-time database. 
Each element must have a unique name so whenever FactoryLink writes 
information to or reads information from the element, it will open the correct 
element. The names are case sensitive (i.e. the system views TEMP as different 
from temp). Set the lower and upper limits of the thermometer by completing two 
steps:

 3 Enter 100 in the Maximum field and 0 in Minimum field in the Scale box to specify 
the range. The temperature range for the tank process is 0-100 degrees Celsius. 

 4 Use the default direction of up. At run time, the color in the thermometer moves 
upward as the temperature increases.
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If you would like the bar to show the temperature as yellow when the temperature 
is in the acceptable range (less than 80 degrees), and red when the temperature is 
too high(80 degrees and up), configure it in the Color Changes field. 

 5 Double-click the first FG (foreground) color button. Choose yellow from the color 
palette and click on the OK button. Double-click the first BG (background) color 
button. Choose white from the color palette and click on the OK button. 

 6 Enter 0 in the first limit box.

Using Steps 5 and 6, you have configured the thermometer to show the 
temperature as yellow on a white background beginning at temp = 0°.

 7 Double-click the second FG (foreground) color button. Choose red from the color 
palette and click on the OK button. Double-click on the second BG (background) 
color button from the top. Choose white from the color palette and click on the OK 
button. 

 8 Enter 80 in the second limit box. 

Using Steps 7 and 8, you have configured the thermometer to show the 
temperature as red on a white background beginning at temp = 80. 

 9 Click on the Split Colors radio button to configure the thermometer so it will show 
yellow for temperatures up to 79 and red only for that part of the bar above 80. 

 10 Click on the OK button to apply the animation. The Tag Definition dialog is 
displayed so you can define the tag temp you referenced when animating the bar. 
Follow the steps below to configure the element temp. 
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Defining a Tag Element temp

The Tag Definition dialog is displayed:

Specify the following information to define temp:

 1 Enter current temperature in the Description field. 

 2 Choose ANALOG as the data type.

 3 Choose SHARED for the domain. You may want different operators to view or 
share the information contained in this tag, so it should be created in the SHARED 
domain. Refer to Fundamentals for an explanation of domains. 

If you click on the OK button now, the tag would be created; however, you can 
configure many options to accompany tags. The following procedures instruct you 
about these options.
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Configuring Alarms

 1 Click on the tab labeled Alarms near the top of the Tag Definition dialog. The Alarms 
tab is activated:

You have already animated the thermometer bar to change colors when the 
temperature reaches a certain level. Suppose you also want the system to trigger 
and record an alarm when the temperature reaches certain levels. These alarms 
are displayed at the bottom of the screen and on an alarm logging record. These 
alarms need to be acknowledged and a printed report of the alarm log can be 
generated. 

For your system, you want an alarm to be triggered at 80 degrees as a warning to 
the operator so a cooling system can be activated. If the process temperature 
reaches 90 degrees, the operator should be alerted that the temperature is 
approaching a critical stage. You may also wish to warn the operator if the 
temperature falls below 10 degrees so a heater can be turned on. Perform the 
following steps to configure the alarms.

 2 Choose the condition HIHI from the list in the Condition Attributes box. Choose the 
group CRITICAL from the list to indicate this is a critical alarm. Type in 90 for the 
limit. Click on the Add button in the Condition Attributes box. The Alarm is 
displayed in the Configured Alarms box. 
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 3 Choose the condition HI from the list in the Condition Attributes box. Choose the 

group WARNING from the list to indicate this is a warning alarm. Type in 80 for 
the limit. Click on the Add button in the Condition Attributes box. The Alarm is 
displayed in the Configured Alarms box. 

 4 Choose the condition < from the list in the Condition Attributes box. Choose the 
group WARNING from the list to indicate this is a warning alarm. Type in 10 for 
the limit. Click on the Add button in the Condition Attributes box. The Alarm is 
displayed in the Configured Alarms box. 

The alarm conditions HIHI, HI, GT and > function identically. They perform a 
comparison between the value specified in the limit and the value of the tag, and 
cause an alarm if the value of the tag is greater than the value specified in the 
limit. Different ways of specifying the trigger values enable you to differentiate 
between the alarms. The alarm conditions LOLO, LO, LT and < function similarly. 
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Configuring Scaling

 1 Click on the tab labeled Scale/Deadb near the top of the Tag Definition dialog. The 
Scaling/Deadbanding tab is activated. 

Suppose your temperature probe reads incoming (raw) data in a Fahrenheit scale, 
and you want to have the temperature displayed on the screen in engineering 
units of a Celsius scale. The temperature range for the process is between freezing 
and boiling. If you enter in the low and high ranges for the incoming (raw) and 
scaled (engineering units) data, FactoryLink will automatically determine the 
appropriate scaling values and convert the incoming data to the engineering unit 
values. FactoryLink will also automatically create tags associated with the raw 
and scaled values for this tag. For example, the incoming data is assigned to a tag 
temp.raw, and a disable tag, temp.lock has been automatically created. 

 2 Enter 212, the boiling point in the Fahrenheit scale, in the Raw High box. Enter 32, 
the freezing point in the Fahrenheit scale, in the Raw Low box.

 3 Enter 100, the boiling point in the Celsius scale, in the Engineering Units High box. 
Enter 0, the freezing point in the Celsius scale, in the Engineering Units Low box.

Now, the incoming data is on a Fahrenheit scale, and the data displayed in the 
thermometer and Current Temp field is on a Celsius scale. 
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Saving Changes to the Tag temp

All of the information configured will now function automatically when the system 
runs. You may have noticed that the tabs configured have two asterisks (**) in 
front of the tab name. This indicates there is information on the tab. Normally, 
you would also enter information on one of the tabs for the device that relays 
information from the temperature probe to the system. However, since you do not 
have a real temperature probe connected to the system, you will instead simulate 
incoming information in your Enter Temp field. 

 1 Click on OK at the bottom of the dialog to save the all the information.

Animating the Temperature Alarm

In this procedure you will animate the temperature alarm circle to flash when the 
temperature is too high (80 or higher). 

 1 Choose Edit>Select Object from the pull-down menu, then position the cursor arrow 
over the alarm circle and click the left mouse button to select the object.

 2 Choose Animation>Paint. The Paint Animation dialog is displayed. In the Tag field, 
type temp so the alarm circle will change colors when the information stored in the 
temp tag changes. 

 3 Double-click the first FG (foreground) color button. Choose light grey from the color 
palette and click on the OK button.

 4 Enter 0 in the Limit field for the top line.

 5 Double-click the second FG (foreground) color button. Choose red from the color 
palette and click on the OK button.
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 6 Position the cursor over the Blink field for second line and click the left mouse 
button until “FAST” is displayed in the Blink field. 

 7 Enter 80 in the Limit field for the second line.

 8 Click on the OK button. The Tag Definition dialog does not open because you 
already defined temp when you animated the thermometer.

Animating the Current Temp Display Field

You want to animate the XXX field next to Current Temp so the simulated 
temperature displayed graphically by the thermometer is displayed numerically 
here.

 1 Choose Edit>Select Object from the pull-down menu, then position the cursor arrow 
over the XXX field next to Current Temp and click the left mouse button to select 
the object.

 2 Choose Animation>Output Text. The Output Text Animation dialog is displayed. 

 3 Type temp in the Tag field so the numeric value displayed here equals the value 
displayed graphically in the thermometer.

 4 Click on the OK button. The Tag Definition dialog does not open because you 
already defined temp when you animated the thermometer.
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Animating the Enter Temperature Prompt

In this procedure you will animate the XXX field next to Enter Temperature to 
simulate incoming temperature data so you can test the application. This field 
would not be necessary in a real application as incoming temperature information 
would come from an electronic device, but you will probably have other situations 
that will require animating a field as input text. 

 1 Choose Edit>Select Object from the pull-down menu, then position the cursor arrow 
over the XXX field next to Enter Temperature and click the left mouse button to 
select the object.

 2 Choose Animation>Input Text. The Input Text Animation dialog is displayed. 

 3 Type tempset in the Tag field. The database element with this tag will receive and 
store the temperature you enter in this field at run time. 

 4 Choose the action SET in the Action field, so the system will set the tempset 
element to the value entered in the field. 

 5 Set the temperature range of the thermometer. Since the incoming temperature is 
read on a Fahrenheit scale in a range between freezing and boiling, do this by 
specifying the maximum and minimum values as 212 and 32, respectively. 
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 6 Position the cursor over the background updates box and click the left mouse 
button. This enables the field to display the temperature written to tempset as 
well as read the input temperature from the keyboard. Click on the OK button to 
save the changes. The Tag Definition dialog is displayed, prompting you to define 
the new element, tempset, you just created.

Defining the Tag Element tempset

 1 Enter operator input temperature in the Description field. 

 2 Choose ANALOG as the data type.

 3 Choose SHARED for the domain. 

 4 Click on the OK button at the bottom of the dialog to save the information.

Animating and Revising the Button

You want to change the copied Area3 button to read Tutor2, indicating this is the 
Tutor2 screen. 

 1 Choose Edit>Select Object from the pull-down menu, then position the cursor arrow 
over the copied Area3 button and click the left mouse button to select the object.

 2 Hold down the Control key on your keyboard, move the cursor arrow over the text 
portion of the button and click the left mouse button to select the text portion of 
the button. When the text portion of the button is selected, the cursor arrow will 
turn into an I-beam. Edit the text to read Tutor2. 
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 3 Choose Edit>Select Object from the pull-down menu, then position the cursor arrow 

over the Tutor2 button and click the left mouse button to select the object. Hollow 
blocks called handles appear around the object, indicating it is selected. 

 4 Choose Animation>Button from the pull-down menu. The Button Animation dialog is 
displayed:

 5 Choose NUL for the Mouse Click or Key, indicating there is no equivalent mouse or 
keyboard function for this button action.

 6 Choose NUL for the Action, since this button represents the name of the screen 
currently displayed.

 7 Remove Area3 from the Value field by backspacing over it. 

 8 Click on the OK button. The Tutor2 button has now been animated so when it is 
pressed at run time, nothing will happen. 
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Import the Trend Chart 

You will import a Trend Chart template provided in a Power Pack. 

 1 Choose File>Open Power Pack from the pull-down menu. The Open Power Pack 
dialog is displayed. Use the arrow to select the power pack named s1trend.gp and 
click on it. Click on OK. The s1trend Power Pack is displayed on the screen. 

 2 Position the cursor over the trending chart and click the left mouse button to 
select the trending chart. 

 3 Choose File>Close from the pull-down menu to close the power pack. 

 4 Choose Edit>Paste to paste the trending chart on to the Tutor2 screen. 

 5 The cursor is displayed as a cross hair on the display. Position the crosshair on the 
right side of the screen and click the left mouse button. 

 6 The template dialog is displayed. Enter temptrend for a name for the chart. Enter 
temp for the name of the information to be plotted on the chart. Enter 0 for the 
minimum and 100 for the maximum. This provides a range in which to plot the 
temperature - the same as the range displayed on the thermometer. 

 7 Click on the OK button. 
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 8 Pop-up windows are displayed, asking if you wish to overwrite values for the tag 

temp. Click on the No button. Repeat this process for each window displayed. 

 9 The trend chart is pasted on to the screen. It is too large to fit in the area you have 
left on the screen. You will size it to fit on the screen.

 10 Choose Edit>Select Object from the pull-down menu. The cursor will change to an 
arrow. Position the arrow in one of the four corner handles around the trending 
chart. While holding down the left mouse button, drag the handle until the 
trending chart is the appropriate size to fit on the screen. Move the object until it 
is properly positioned on the display. 

Saving the Animated Drawing

Your screen will now look like this:
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 1 Choose Edit>Select Object from the pull-down menu, then position the cursor arrow 
over the Tutor2 button and press the left mouse button to select the object. 

 2 Choose Edit>Copy from the pull-down menu to copy the button. You will be pasting 
the copied button onto the Overview screen in the next section. 

 3 Choose File>Save from the pull-down menu. The system will save the Tutor2 
drawing you created. 

 4 Choose File>Close from the pull-down menu to close the drawing you have created. 

Creating and Animating the Tutor2 Button on the Overview Screen

When FactoryLink starts, it will open up to a splash screen and then 
automatically bring up the Overview screen after 5 seconds. To go from this display 
to the tutor2 display you created, you will copy and animate a Tutor2 button so 
you can move between the Overview screen and the Application screen. Complete 
the following steps:

 1 Choose File>Open. The Open dialog is displayed.

 2 Choose OVERVIEW.G. and click on the OK button. The Overview screen opens. If 
you completed the Quick Start section of the tutorial, the Overview screen will not 
be blank. 

 3 Choose Edit>Paste from the pull-down menu. The cursor is displayed as a 
cross-hair. Position the cursor to the right of the Area3 button and click the left 
mouse. The Tutor2 button you copied from the Tutor2 screen is displayed:
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 4 Choose Edit>Select Object. The cursor will change to an arrow. Click on the Tutor2 

button to select it. 

 5 Choose Animation>Button from the pull-down menu. The Button Animation dialog is 
displayed:

 6 Choose NUL for the Mouse Click or Key, indicating there is no equivalent mouse or 
keyboard function for this button action.

 7 Choose DRW for the Action, indicating clicking on the button will draw what is 
specified in the Source field.

 8 Type TUTOR2 in the Source Value field. Click on the OK button.

 9 The Tutor2 button has now been animated so when it is pressed at run time, the 
Tutor2 screen is drawn on the computer terminal. 

 10 Choose File>Save to save the change to the Overview screen. 

Exiting the Editor

 1 Choose File>Exit to exit from the Application Editor. 
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SIMULATING COMMUNICATIONS

You will simulate communication with an external device using the Math & Logic 
task. You will write a Math & Logic procedure to change the value of the tag temp 
based on the operator input value into the Tempset field. In a real application, 
there would be an external device providing the temperature information, and you 
would not need to create this procedure. However, you will create a procedure so 
you can test the application you have created, and learn how to use the Math & 
Logic procedures so you can utilize them in your real applications. 

Accessing the Configuration Manager

You need to open the Configuration Manager to configure the system to simulate 
communications.

 1 Open the FactoryLink 6.5.0 program group and double-click on the FactoryLink 
Configuration Manager icon. 

 2 The Configuration Manager Main Menu will open. 

 3 Ensure the current domain selected is SHARED in the Configuration Manager 
Domain Selection box. Configure the Math & Logic tasks in the shared domain.

Setting Up the Interval Timer

The system must know how often to check whether or not to perform a particular 
procedure. In this case, you will use the interval timer sec1 to tell the system to 
poll for your procedure trigger every second. 

 1 Double-click on Interval Timer from the Configuration Manager Main Menu to 
display the Interval Timer Information panel.
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 2 Define the interval trigger tag sec1, if it is not already present, by typing sec1 in 

the Tag Name field and 1 in the Secs field.

 3 Click on the Exit button to return to the Configuration Manager Main Menu. 

Math & Logic Variables 

Before you can write a procedure, you must reference the element names to be 
used in the procedure. This is done in the Math and Logic Variables Information 
panel. 

 1 Double-click on the Math & Logic Variables in the Configuration Manager Main 
Menu. The Math and Logic Variables Information panel opens. Complete the panel as 
follows:

 2 Type tempset in the Tag Name column. Press the Enter or Return key to move to the 
next row in the Tag Name column. The Tag Type and Tag Description for the 
element are automatically displayed. This information is available because you 
defined this tag when animating your screen. 
 / FactoryLink 6.5.0 / Tutorial



FACTORYLINK ADVANCED FEATURES
Simulating Communications

3

A
d

van
ced

 F
eatu

res
 3 Enter temp.raw in the next row of the Tag Name column. Press Enter or Return. The 
Tag Type and Tag Description for the element are automatically displayed because 
these tags have been previously defined.

 4 Click on the Enter button on the screen to save the information.

 5 Click on the Exit button to return to the Main Menu.

Math & Logic Procedures

Once you have referenced the element names you will use in the Math & Logic 
task, you can use them to write a procedure that increments or decrements the 
value of the element, temp.raw. This procedure is what makes the animation 
work. Temp.raw is the tag FactoryLink automatically created when you made 
temp a scaled tag. Compare the value in the Tempset field (the incoming 
temperature on a Fahrenheit scale) to temp.raw (the unscaled value of temp). 
Remember the raw values for the tag temp are in a Fahrenheit scale, and the 
converted value is in a Celsius scale. 
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 1 Double-click on the Math and Logic Procedures in the Main Menu. The Select a File 

dialog is displayed. Type the program name SETTEMP in the entry field. The 
system automatically adds the .prg (program) extension. 

 2 Click on the Enter button on the screen. The Math and Logic Procedure panel is 
displayed. 

 3 Enter the procedure as shown. Press Enter or Return on your keyboard to begin 
each new line of text.

The procedure, SETTEMP tells the system that when you enter a value into the 
ENTER TEMP field, this value, which is written to tempset, is compared to the 
value in temp.raw. When this value is different than the value already in tempset, 
the value of temp.raw is changed by 1 every second. FactoryLink will then convert 
the value in temp.raw to a Celsius range and display it as the value in temp, and 
the thermometer will move up or down to reflect the change until the value in 
temp.raw is equal to that in tempset. 

 4 Next, validate the procedure to ensure it is correct. Choose File>Validate from the 
pull-down menu. 
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If validation errors occur, verify the elements used in the procedure match the 
element names listed in the Math and Logic Variables Information panel. If validation 
errors exist, verify that all the element names have been typed correctly. All 
errors must be corrected before the procedure can be saved. 

Choose File>Save from the pull-down menu to save the procedure. 

 5 Choose Exit>Exit from the pull-down menu to exit the Math and Logic Procedure 
panel and return to the Main Menu. 

Math & Logic Triggers

You must specify a trigger that indicates when to execute the procedure in the 
Math and Logic Trigger Information panel. Double-click on Math & Logic Triggers in 
the Main Menu.

 1 Enter sec1 in the Trigger Tag column. This is the interval timer you defined earlier.

 2 Enter settemp in the Procedure column. This is the name of your Math & Logic 
procedure.

 3 Enter an optional description of what the procedure does in the Description 
column; for example, “Proc to raise and lower temp.”

 4 Click Enter to save the information. The system will fill in the MODE column.

 5 Click Exit to return to the Main Menu.

The procedure SETTEMP is executed once every second because the value of the 
trigger element sec1 is force-written to a 1 once every second. 
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System Configuration

The flags in the System Configuration Information panel determine the tasks that 
start automatically at run time. You must set up the Timer and Math & Logic 
tasks so they will start when the tutorial application runs. 

 1 Double-click on System Configuration from the Main Menu to display the System 
Configuration panel. 

 2 Scroll down to the Flags column in the TIMER row and verify an R is displayed in 
the Flags column. Add the R if it is not displayed in the column. The Timer task 
will now start automatically at run time. 

 3 Scroll down to the Flags column in the IML (Integrated Math & Logic) row and add 
an R to the Flags column, if necessary. The Math & Logic task will start 
automatically at run time. 

 4 Click Enter to save the changes.

 5 Click on Exit to exit the panel.

 6 Choose Exit> Exit to exit the Configuration Manager. 
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RUNNING THE APPLICATION

Starting the Application

 1 Double-click the Start FactoryLink icon to start a FactoryLink application.

 2 A splash screen is displayed. After 5 seconds, the Overview Screen is automatically 
displayed. 

 3 Click the Tutor2 button. The screen you created is drawn. 

Testing the Application

Remember you are entering temperatures in a Fahrenheit scale and the system is 
converting to a Celsius scale, so the temperature displayed in the Current Temp 
field and the thermometer bar are in a different scale than the temperature you 
are entering. 
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 1 Enter a temperature of 50 in the Enter Temp field and press Enter. 

A yellow bar gradually moves vertically from the bottom of the thermometer to 
the 10 mark. The numeric temperature display below the thermometer also shows 
the incrementing temperature. 

On the trend chart, the pen traces a trend line from 0 to 10 as the Math & Logic 
task increments the temperature. When the trend line reaches 10, it levels off.

 2 Press ESC to clear the Enter Temp field and enter a temperature of 180. Press 
Enter. 

The numeric temperature display indicates the incrementing temperature. When 
the temperature reaches 80, that portion of the bar above 80 displays as red. The 
alarm turns red and blinks. 

On the trend chart, the pen traces a trend line from 10 to 82, then levels off.

 3 Press ESC to clear the Enter Temp field and enter a temperature of 215. Press 
Enter. 

An error message is displayed, warning that an out-of-range value has been 
entered:

WARNING
Maximum value is ’212’

 4 Click OK. The input temperature of 180 reappears in the Enter Temp field.
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 5 Click on the alarm bell on the lower left corner of the screen. The Alarm Log 
screen is displayed. It shows the alarms logged when the temperature exceeded 80 
degrees Celsius. 

 6 Press the Return button to go to the Overview screen. 

 7 Position the cursor over the Overview button and click the left mouse to display the 
Overview screen. 

 8 Position the cursor over the System button in the upper right corner of the 
Overview display and click the mouse. A dialog is displayed, asking for the user 
name and password. 
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 9 Enter Flink for both fields and click on the OK button. 

The System button has a security function associated with it. In order to gain 
access to the display or function associated with the button, the operator must 
have the proper level of security clearance and know the correct password. This 
allows you to develop an application and specify who can access particular 
functions. Refer to Chapter 27, “Graphic Object Security” in the Application 
Editor Guide for more information. 

 10 The system (Run-Time Manager) screen is displayed:

Now, you have verified the animation of your system objects and the buttons on 
your displays. You are finished with the Basics portion of the tutorial. 

 11 Position the cursor on the button to the left of STOP APPLICATION and click the 
left mouse button. This exits the FactoryLink program and returns you to your 
operating system. 

 12 Now, you can develop your own application, using the skills you have learned in 
this tutorial. 

Stop Application Button
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SAVING AND RESTORING THE TUTORIAL

For Windows NT and Windows 95

 1 Open the FactoryLink 6.5.0 program directory and double-click on the 
FactoryLink Save Application icon.

 2 The FactoryLink Application Save dialog is displayed. Click on the Local Multi-platform 
Save radio button, and click on the box for Save Application Data files. Save the 
application from the source C:\FLAPP to the destination C:\FLTUTOR. If you are 
using a drive designation other than “C” for your hard drive, replace the “C” in 
above command with the correct drive letter. Click on the OK button at the bottom 
of the dialog to save the application. 

 3 The system will go through the process of saving the application. It may prompt 
you to answer certain questions during the save. Answer “Y” to any questions 
asked. 
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 4 Once the application has been saved, you will need to restore the application. 

Double-click on the FactoryLink Restore Application icon.

 5 The FactoryLink Application Restore dialog is displayed. Click on the Local 
Multi-platform Save radio button. Restore the file from the source C:\FLTUTOR to 
the destination C:\TUTORIAL and click on the OK button. If you are using a drive 
designation other than “C” for your hard drive, replace the “C” in the above 
command with the correct drive letter. 
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For OS/2

 1 Open the FactoryLink 6.5.0 program directory and right mouse button click on the 
FactoryLink Backup Application icon.

 2 Choose Settings from the pop-up menu. The Backup Applications Setting dialog is 
displayed. On the Program tab, for optional parameters, type:
C:\FLAPP C:\FLTUTOR /loc. 
This is the source drive:\directory (space) destination drive:\filename (space) /loc. 
If you are using a drive designation other than “C” for your hard drive, replace the 
“C” in the above command with the correct drive letter. 

 3 Close the dialog by clicking in the upper left corner of the dialog and choosing 
CLOSE from the menu. 

 4 Double-click on the icon. The Backup Application window is displayed. Make sure 
the source and destination files are correct, and answer “Y” to the question: “Do 
you wish to proceed? (Y/N)”

 5 The system will go through the process of saving the application. 

 6 Once the application has been saved, you will need to restore the application. 
Open the FactoryLink 6.5.0 program directory and right mouse button click on the 
FactoryLink Restore Application icon.

 7 Choose Settings from the pop-up menu. The Restore Applications Setting dialog is 
displayed. On the Program tab, for optional parameters, type:
C:\FLAPP C:\FLTUTOR /loc. 
This is the source drive:\directory (space) destination drive:\filename (space) /loc. 
If you are using a drive designation other than “C” for your hard drive, replace the 
“C” in the above command with the correct drive letter. 
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 8 Close the dialog by clicking in the upper left corner of the dialog and choosing 

CLOSE from the menu. 

 9 Double-click on the icon. The Restore Application window is displayed. Make sure 
the source and destination files are correct, and answer Y to the question: “Do you 
wish to proceed? (Y/N)”

 10 The system will restore the application. 

Linking an Icon to the Saved Tutorial

Windows NT

 1 To make it easy to open either your tutorial or your application, you will create an 
icon and link it to the tutorial application. Open the FactoryLink 6.5.0 program 
directory and click once on the Start FactoryLink icon to select it.

 2 Choose File>Copy from the pull-down menu to copy the Start FactoryLink icon. 

 3 A pop-up dialog will ask for the group to which to copy the program item. Select 
the program group where you have FactoryLink installed. Click on the OK button. 
The copied item will appear in the program group. 

 4 With the copied icon selected, choose File>Properties from the pull-down menu to 
rename and configure Start FactoryLink. Type in the description Start FL 
Tutorial. 

 5 For the cmd line, after the -a, enter C:\TUTORIAL (the drive and directory to which 
you restored the application). If you are using a drive designation other than “C” 
for your hard drive, replace the “C” in the above command with the correct drive 
letter.

 6 Click on the OK button to save the changes. 

 7 Now, when you open the FactoryLink 6.5.0 program directory, there is a Start 
FactoryLink icon to use for opening your application, and a Start FL Tutorial icon 
to use for opening the tutorial you have created. 
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Windows 95

 1 To make it easy to open either your tutorial or your application, you will create an 
icon and link it to the tutorial application. Open the FactoryLink 6.5.0 program 
directory and click once on the Start FactoryLink icon to select it.

 2 Choose Edit>Copy from the pull-down menu to copy the Start FactoryLink icon. 

 3 Choose Edit>Paste from the pull-down menu to paste the Start FactoryLink icon. 

 4 With the copied icon selected, choose File>Rename from the pull-down menu to 
rename the icon “Copy of Start FactoryLink.” Type in the title Start FL 
Tutorial. 

 5 With the icon selected, choose File>Properties from the pull-down menu. The 
Properties dialog is displayed. Select the Program tab by positioning the cursor over 
it and clicking on it. The Program tab is displayed. For the cmd line, after the -a, 
enter C:\TUTORIAL (the drive and directory to which you restored the 
application). If you are using a drive designation other than “C” for your hard 
drive, replace the “C” in the above command with the correct drive letter. 

 6 Click on the Apply button and then on the OK button to save the changes. 

 7 Now, when you open the FactoryLink 6.5.0 program directory, there is a Start 
FactoryLink icon to use for opening your application, and a Start FL Tutorial icon 
to use for opening the tutorial you have created. 
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OS/2

 1 To make it easy to open either your tutorial or your application, you will create an 
icon and link it to the tutorial application. Open the FactoryLink 6.5.0 program 
directory and click once on the Start FactoryLink icon to select it.

 2 With the icon selected, click on the right mouse button. Choose Copy from the 
pull-down menu to copy the Start FactoryLink icon. 

 3 The FactoryLink 6.5.0 OS/2 - Copy dialog is displayed. 

 4 On the Opened tab, type Tutorial in the New Name field at the top of the dialog. 
Ensure the FactoryLink OS/2 folder is highlighted as the target for the operation 
then click on the COPY button at the bottom of the dialog. 

 5 Click once on the new icon Tutorial to select it. Right mouse button click on the 
icon. The Settings dialog is displayed. For the Optional Parameters field, type -A 
C:\Tutorial. If you are using a drive designation other than “C” for your hard 
drive, replace the “C” in the above command with the correct drive letter.

 6 Close the dialog by clicking in the upper left corner of the dialog and choosing 
CLOSE from the menu. 

 7 Now, when you open the FactoryLink 6.5.0 program directory, there is a Start 
FactoryLink icon to use for opening your application, and a Tutorial icon to use for 
opening the tutorial you have created. 
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